Jump to content
Froxlor Forum
  • 1
ING

Port 443 und Let´s Encrypt

Question

Hallo zusammen,

nachdem ich Froxlor unter Debian 9 installiert habe, alles soweit Konfiguriert habe und Port 443 sowie Let´s Encrypt Aktiviert habe, kann ich nicht mehr über Port 80 sowie Port 443 auf das Dashboard zugreifen.

Was kann das sein ?!

 

Beseten dank schonmal im Vorraus

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Fehlermeldung? Bitte mal in die Logs schauen "geht nicht mehr" ist keine hilfreiche Meldung, als Serveradmin solltest du das aber wissen

Share this post


Link to post
Share on other sites
  • 0

Hallo! 
Habe das gleiche Problem.
Meine Server-Admin-Kenntnisse beschränken sich leider auf Confixx, Plesk und ein paar bash-Kommandos.

Hoffe, ich kann es aber besser beschreiben.

Ausgangszustand 

OS:  Debian GNU/Linux 8.10 (jessie)
Webserver:  Apache/2.4.10 (Debian)
Froxlor:  0.9.39.5 (DB: 201802130)
PHP-Version:  5.6.33-0+deb8u1
MySQL-Server-Version:  5.5.58-0+deb8u1
Webserver-Interface:  APACHE2HANDLER

(Froxlor war bei netcup in der Standardeinrichtung für Debian jessie dabei.)

Inzwischen habe ich 3 Domains eingerichtet, laufen prima unter http.

Ziel: SSL mit Let's Encrypt

Habe dazu diese Anleitung hier gefunden: https://meteor-digitals.de/ssl-kostenlos-mit-froxlor-und-lets-encrypt/

1. Froxlor Domaineinstellungen
/admin_domains.php&page=domains

Für alle Domains Server-Aliase alle ohne Wildcards (www.domain.tld) eingestellt.

2. Froxlor IPs und Ports
/admin_ipsandports.php
Port 443 hinzugefügt

3. Froxlor System Einstellungen
/admin_setting.php

SSL aktiviert

Kurze Zeit später konnte ich nicht mehr auf das Panel zugreifen.
Nehme an, der Apache hatte keine Lust mehr (Screenshot 1)

Die SSL-Einstellungen sind jetzt noch im Auslieferungszustand, denke ich (Screenshot 2).

Erste Vermutung: der Cronjob zum Erstellen der Konfigurationsdateien hackt dazwischen bevor ich die SSL-Einstellungen vornehmen kann. 
Habe deshalb Snapshot eingespielt, diesen Cronjob deaktiviert und dann weiter gemacht.

4. Let’s Encrypt-Konfiguration für Apache 2.4.

nano /etc/apache2/conf-enabled/acme.conf

Inhalt

Alias "/.well-known/acme-challenge" "/var/www/html/froxlor/.well-known/acme-challenge"
<Directory "/var/www/html/froxlor/.well-known/acme-challenge">
Require all granted
</Directory>

Ergebnis: Server läuft noch, aber Apache will nicht mehr restarten (Screenshot 3).

---

Zusatzfragen:

Das Admin-Panel läuft unter http://<ip-adresse>/froxlor
Ist das ein Problem?

Und wie kann ich einen Domainnamen anstelle der IP einrichten?
Über System - Einstellungen - Systemeinstellung Hostname "Welchen Hostnamen hat der Server?" ?

Macht es Sinn, zuerst Let's Encrypt von Hand zu installieren?

Wird es irgendwann eine Minimaldokumentation für die Konfigurationseinstellungen geben?
Und wenn nein, warum nicht?
;-)

Bin für jeden Hinweis dankbar.

2018-06-26-froxlor-ssl-on-apache-error.png

2018-06-26-froxlor-ssl-einstellungen.png

2018-06-26-froxlor-apache-restart.png

Share this post


Link to post
Share on other sites
  • 0

Hallo Cardman,

ganz dumme Fragen zurück: woran sehe ich, ob SSL aktiviert ist?
Falls nicht: wie mache ich das?

Hab die Konfiguration aus dem Froxlor Admin Panel verwendet:

mkdir -p /etc/apache2/sites-enabled/
chown root:0 /etc/apache2/sites-enabled/
chmod 0600 /etc/apache2/sites-enabled/
mkdir -p /etc/apache2/sites-enabled/
chown root:0 /etc/apache2/sites-enabled/
chmod 0600 /etc/apache2/sites-enabled/
mkdir -p /var/customers/webs/
mkdir -p /var/customers/logs/
mkdir -p /var/customers/tmp
chmod 1777 /var/customers/tmp
a2dismod userdir
a2enmod headers
/etc/init.d/apache2 restart

Danke für jeden Hinweis!

Share this post


Link to post
Share on other sites
  • 0

Hallo Cardman,

macht es Sinn, zuerst schon mal SSL und Let's Encrypt per Kommoandozeile, also ohne Froxlor zu installieren?

Cheers,

Markus

Share this post


Link to post
Share on other sites
  • 0

Cardman, Cardman,

danke!

Im Prinzip lief alles, ich habe sogar schon das hübsche Let's Encrypt Icon gesehen. :rolleyes:
Siehe Screenshot 1.

Das Dashboard behauptete sogar, die Let's Encrypt Zertifikakte würden aktualisiert.
Siehe Screenshot 2.

Leider dauerte es nicht lange und der Apache hatte keine Lust mehr mitzuspielen.
Zunächst lief er ja noch - wenn auch mit Murren.
Die Apache Konfiguration meckerte über falsche Konfiguration.
Siehe Screenshot 3.

Nach einem Server-Reboot wollte er aber gar nicht mehr.
Siehe Screenshot 4.

Was ist passiert?

Die letzte bootfähige Konfiguration war wie folgt

  • Frisch installierter Server mit 

    OS:  Debian GNU/Linux 8.10 (jessie)
    Webserver:  Apache/2.4.10 (Debian)
    Froxlor:  0.9.39.5 (DB: 201802130)
    PHP-Version:  5.6.33-0+deb8u1
    MySQL-Server-Version:  5.5.58-0+deb8u1

  • Froxlor Konfiguration für 

   apache, postfix, dovecoat, proFTPd und Cronjobs eingerichtet.

  • Froxlor eingerichet mit

   3 Kunden, 3 Domains, 3 Webseiten unter http, läuft. Nur nicht mit SSL.

  • Apache mit SSL gestartet
a2enmod ssl
  • Let's Encrypt Konfiguration für Apache 2.4
nano /etc/apache2/conf-enabled/acme.conf

Inhalt

Alias "/.well-known/acme-challenge" "/var/www/html/froxlor/.well-known/acme-challenge"
<Directory "/var/www/html/froxlor/.well-known/acme-challenge">
Require all granted
</Directory>
  • PHP-Curl installiert
apt-get install php5-curl
service apache2 restart
  • SSL in Foxlor eingeschaltet

Läuft. Sreenshot 5.
Apache und Root Server lassen sich neu starten.

#-------------------Let's Encrypt---------------# 

1. Froxlor - Ips und Ports - Port 443 als SSL-Port festlegen

2. Froxlor - SSL-Einstellungen - Let's Encrypt einschalten

3. Froxlor - Cronjobeinstellungen - aktualisiert Let's Encrypt Zertifikate wurde automatisch auf aktiv gesetzt

3. Apache - Fehlermeldung - Cert nicht gefunden

4. Openssl - Cert für Apache erstellt

openssl genrsa -out /etc/ssl/private/apache.key 2048
openssl req -new -x509 -key /etc/ssl/private/apache.key -days 365 -sha256 -out /etc/ssl/certs/apache.crt

5. Froxlor - SSL-Einstellungen - Pfade für Key und Cert angepasst 

6. Froxlor - Cronjob "aktualisiert Let's Encrypt Zertifikate" startet nicht, obwohl aktiv

7. Froxlor - Cronjob manuell gestartet

php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt

8. Froxlor - Domaineinstellungen - 443 als SSL-Port festgelegt und Let's Encrypt eingeschaltet.

Apache lässt sich restarten.
Hurra, es läuft!
So einigermaßen.

  • Leider ist das Zertifikat ungültig, im Browser wird nur das selbst in Schritt 4 ausgestellte Zertifikat angezeigt.
  • Froxlor hat immer noch keine Lust, automatisch Letsencrypt zu aktualisieren, zeigt aber meinen Versuch als letzten.
  • Let's Encrypt zeigt folgende Fehler.
[warning] [Lets Encrypt self-check] Please check http://personaltrainer-senti.de/.well-known/acme-challenge/nu1s6mc-2FNRJSDtvdT9AUuk9hiCMxMr0y4YSZ2SkZw - token seems to be not available. This is just a simple self-check, it might be wrong but consider using this information when Let's Encrypt fails to issue a certificate
[error] Could not get Let's Encrypt certificate for personaltrainer-senti.de: Verification ended with error:  {"identifier":{"type":"dns","value":"personaltrainer-senti.de"},"status":"invalid","expires":"2018-07-04T03:07:57Z","challenges":[{"type":"dns-01","status":"invalid","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/p1HbFf6mud-njvqDZ3PAOlQWwD6eL3heU9dm2yYr4gY\/5323664094","token":"AxRUh4V0hykqAc9yIIskfjjHGhb8PEG6ELVgbAYJcnM"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:unauthorized","detail":"Invalid response from http:\/\/personaltrainer-senti.de\/.well-known\/acme-challenge\/nu1s6mc-2FNRJSDtvdT9AUuk9hiCMxMr0y4YSZ2SkZw: \"<!DOCTYPE HTML PUBLIC \"-\/\/IETF\/\/DTD HTML 2.0\/\/EN\">\n<html><head>\n<title>404 Not Found<\/title>\n<\/head><body>\n<h1>Not Found<\/h1>\n<p\"","status":403},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/p1HbFf6mud-njvqDZ3PAOlQWwD6eL3heU9dm2yYr4gY\/5323664096","token":"nu1s6mc-2FNRJSDtvdT9AUuk9hiCMxMr0y4YSZ2SkZw","keyAuthorization":"nu1s6mc-2FNRJSDtvdT9AUuk9hiCMxMr0y4YSZ2SkZw.uY9R4HvVHz9L1NY3nkQZg4IqSFV48rfxlD7dSv0-m2A","validationRecord":[{"url":"http:\/\/personaltrainer-senti.de\/.well-known\/acme-challenge\/nu1s6mc-2FNRJSDtvdT9AUuk9hiCMxMr0y4YSZ2SkZw","hostname":"personaltrainer-senti.de","port":"80","addressesResolved":["185.183.158.15"],"addressUsed":"185.183.158.15"}]}],"combinations":[[0],[1]]}

 

Hast du noch eine Idee für mich?

Danke

Markus

2018-06-30-froxlor-domains.png

2018-06-30f-apache-status-server-reboot.png

2018-06-30f-froxlor-dashboard.png

2018-06-30f-apache-status.png

2018-06-29-apache-status.png

Share this post


Link to post
Share on other sites
  • 0

Problem gefunden, letztendlich fehlerhafter Pfad in der acme.conf Alias-Config (/var/www/html/froxlor statt /var/www/froxlor)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...