Jump to content
Froxlor Forum
  • 0
hanshandlampe

Unbekannt Subdomains liefern Froxlor-Panel

Question

Ich habe das Problem, dass alle unbekannten Subdomains immer das Froxlor-Panel ausliefern. Leider mit falschem SSL-Zertifikat, weil das Panel eigentlich (nur) unter einer anderen (Sub-) Domain läuft (laufen sollte).

Was mache ich falsch? Wo lässt sich das konfigurieren?

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Das ist per default durchaus korrekt, außer du setzt den Domain-Alias der Domain die das betrifft auf WILDCARD, dann landen alle anfragen auf dem Docroot des Kunden, sonst halt auf dem ersten vhost der verfügbar ist und das ist froxlor; alternativ kannst du dir einen eigenen vhost basteln (er sollte mit einer Nummer kleiner als 10_* beginnen, z.B. 01-my-custom-vhost.conf) der auf den gewünschten Pfad verweist.

Share this post


Link to post
Share on other sites
  • 0

Weil das apache (oder auch andere webserver) nunmal so machen...zeigt eine domain auf eine IP auf die auch der Webserver hört wird versucht einen Vhost zu matchen, gibt es keinen wird der erste match ausgeliefert...wie gesagt, bastel dir halt einen eigenen vhost und lass da 404 zurückgeben wenn du das gerne so hättest

Share this post


Link to post
Share on other sites
  • 0
vor 1 Stunde schrieb d00p:

(er sollte mit einer Nummer kleiner als 10_* beginnen, z.B. 01-my-custom-vhost.conf)

Sollte er nicht eher mit einer sehr hohen Nummer beginnen? Inhalt dann in etwa so:

<VirtualHost 192.168.178.100:80>
 ServerName null
 ServerAlias *
 Redirect 404 /
</VirtualHost>

Das soll ja quasi eine Fallback-Lösung sein: Wenn es keinen vhost für die Subdomain gibt, dann liefere ein 404 aus.

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, d00p said:

[...] sonst halt auf dem ersten vhost der verfügbar ist [...]

 

Share this post


Link to post
Share on other sites
  • 0
17 minutes ago, Tealk said:

müsste dann nicht schon die "000-default.conf" einspringen?

die braucht froxlor nicht, ich deaktivier die immer. Alternativ kann man da natürlich eine Platzhalterseite erstellen oder schlichtweg auch eine eigene vhost-config je nach wünschen

Share this post


Link to post
Share on other sites
  • 0

Also ich hätte das gerade mal folgendermaßen gemacht:

ich habe die Datei sites-enabled/01_placeholder.conf erstellt. Ich hab extra sites-enabled genutzt weil ich froxlor einen anderen ordner zugewiesen habe. Folgendes ist der Inhalt:

<VirtualHost ip:80>
 DocumentRoot /var/www/html
</VirtualHost>

Das funktioniert auch soweit, nur hab ich auch Domains mit wo "HSTS für jede Subdomain" aktiviert ist. Also wollte ich das obere eben auch für die SSL variante erstellen:

<VirtualHost ip:443>
 DocumentRoot /var/www/html
</VirtualHost>

nur sobald ich den SSL teil erstelle, geht keine meiner Seiten mehr. Normal sollte das doch nur greifen wenn kein anderer Match ist oder?

Mir ist klar das das auf nen reinen Fehler läuft dann weil kein Zertifikat hinterlegt ist, aber man bekommt dann kein anderes Zertifikat angezeigt und kennt dann eine korrekte Subdomain.

Share this post


Link to post
Share on other sites
  • 0
16 hours ago, Tealk said:

<VirtualHost ip:443> DocumentRoot /var/www/html </VirtualHost>

ein ssl-vhost ohne zertifikate geht halt nicht, du sagst es ja selbst. Fehlt ja auchh SSLEngine On usw. das gibt halt protokoll mismatch (non-ssl <> ssl). und was genau heisst "keine seite geht mehr"? Gibt es denn eine Fehlermeldung? Was wird im Browser angezeigt?

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, d00p said:

ein ssl-vhost ohne zertifikate geht halt nicht, du sagst es ja selbst.

Das sollte aber nur für Matches zutreffen oder? Mein Gedanke dahinter war, das dann bei Subdomains die nicht existieren nicht mehr das froxlor Zertifikat angezeigt wird.

Leider kann ich den Fehler von gestern nicht mehr reproduzieren.

Finde es eigenartig das es keine einfache Möglichkeit gibt zu sagen, alle Subdomains die nicht konfiguriert sind egal ob per non-ssl oder ssl verbannt man in Verzeichnis xy

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Tealk said:

Finde es eigenartig das es keine einfache Möglichkeit gibt zu sagen, alle Subdomains die nicht konfiguriert sind egal ob per non-ssl oder ssl verbannt man in Verzeichnis xy

Warum werden überhaupt Subdomains auf den Server geleitet die dort nicht konfiguriert sind? Lass doch einfach die catchall Einträge im DNS weg und konfiguriere das manuell richtig.

Share this post


Link to post
Share on other sites
  • 0

weil ich viel experimentiere und nicht immer eine gefühlte Ewigkeit warten will bis der DNS wieder einmal kapiert hat das es eine neue subdomain gibt.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...