Jump to content
Froxlor Forum
  • 0
UnknownLSL

Apache loopback for Wordpress

Question

Hi guys,

 

It seems like Wordpress wants to have a loopback configuration for its API.

"The website wasn't able to finish a loopback request"
Error: [] cURL error 28: Operation timed out after 10001 milliseconds

Is it possible to configure that with the current functionality? Following up with the Wordpress support forum, they are not really helpful. They just make it quick with a recommendation to their webhosting sponsors which is very sad, like: "Use one of the webhosters from our list, they will work well."

Mep.

Does anybody know how to fix it? I could make it manually with set the customer configuration to "Mail only", but I think that would be a functionality which would affect pretty many users.

 

Regards and stay healthy,
UnknownLSL

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 1

If i'm correct then this is not loopback-device related but in case you are using php-fpm with pm=static and children=1 then this is the problem, try at least children=2 so wordpress can request itself internally 

Share this post


Link to post
Share on other sites
  • 0

Wow haha, unbeleavable. That worked pretty fantastic! Thank you -very- much!

For others who also receive errors depending on the Wordpress REST Plugin: That solution fixed them as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By tmuecksch
      Guten Tag,
      ich habe einen Debian 9 Server mit Froxlor und Apache2 am laufen. Wenn ich mit dem Kunden FTP Zugang Dateien hochlade haben diese Ordnungsgemäß das ownership 10000:10000.
      Wenn jedoch in der PHP-Weboberfläche eine Datei hochgeladen wird, wird diese mit dem ownership www-data:www-data hochgeladen. Liegt hier ein Konfigurationsfehler vor oder ist das Verhalten sogar so gewünscht? Ich kann den Fehler leider nicht entdecken. Das Problem ist nur, dass das PHP-Script dann eine Permission Denied Fehlermeldung wirft, wenn versucht wird die Datei zu lesen.
       
      Liebe Grüße
      tmuecksch
    • By DavidCK
      Hi There,
       
      I have a problem with proftpd and folders permissions. I installed wordpress in the domain folder, the installation required sudo chown -R www-data:www-data permission, I assigned this permission via ssh but the problem is when I connect via ftp I can not edit nothing inside my domain folder because my ftp account does not have the permission.
       
      Anyone knows How Can I revert this?
       
      Thanks for your time.
       
      wordpress runs perfect with froxlor!!
    • By webass
      Hi,
      ich habe einen Kundenaccount.
      Da sollte Wordpress drin installiert werden.
       
      Die php settings je Domain ?berschreiben ja sicherlich /etc/php5/fpm/php.ini, daher habe ich dort das memory limit passend gemacht und gespeichert.
      Dann hab ich gewartet und gewartet und der cronjob lief nicht durch. Dann habe ich die config files erneuert und es hat immer noch nichts gebracht, die Werte wurden nicht geschrieben, der cronjob umfasst wohl bei mir diesen Kunden nicht.
       
      Dann habe ich ?berpr?ft wie es im Cron aussieht und da ich die Config ja anfangs gemacht hatte, sieht der normal aus.
      Woran k?nnte das denn noch liegen?
      Ich musste den Cron dann mit --force laufen lassen und konnte erst danach Worpdress fertig installieren.
       
      Alles ist in Sachen cron settings ist auf default, nichts, nie ge?ndert.
      Hier mal froxlor cronjob:
      # cat /etc/cron.d/froxlor # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php Hilfe...
      m?chte, dass es automatisch geht. (Hab auch schon gegoogelt und hier gesucht)
      LG
      Andre
×
×
  • Create New...