Jump to content
Froxlor Forum
  • 0
Sould

Let's Encrypt Zertifikate

Question

Hallo,

ich stehe gerade vor ein Problem mit Let's Encrypt Zertifikate, die ich gerne verwenden möchte.

Froxlor ist derzeit auf die neuste Version 0.9.36.

Let's Encrypt ist aktiviert und auf den ersten Blick scheint auch alles zu funktionieren.

Nach dem aktivieren einer Domain, wird diese angestoßen.

 

Jetzt allerdings kommt das eigentliche Problem.

Rufe ich die Domain auf:

z.B. https://sould.de/ habe ich mal als test genommen.

Bekomme ich das "Diese Verbindung ist nicht sicher"

 

Was läuft hier falsch ?

Über eure Hilfe währe ich sehr dankbar.

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

Das Zertifikat das bei der Domain hinterlegt ist ist abgelaufen. 
Zudem ist es auch kein Let´s Encrypt Zertifikat, vermutlich hast du noch das alte drinstehen.

Share this post


Link to post
Share on other sites
  • 0

Hallo,

für die Domain gab es noch kein Zertifikat.

Habe nur das Encrypt aktiviert und sonst nichts, das selbe Problem hatte ich bei einer anderen Domain die ich getestet habe. Also bekomme ich immer abgelaufenen Zertifikate? Muss ich das noch irgendwo einstellen ?

Share this post


Link to post
Share on other sites
  • 0

Nein...server-datum/uhrzeit mal gecheckt? Wobei das normal auch nicht ausschlaggebend sein dürfte. Schau doch einfach mal in die System-Log in Froxlor bzw. rufe den cronjob manuell mit --debug auf

Share this post


Link to post
Share on other sites
  • 0

Folgenden Fehler bekomme ich von Froxlor angezeigt:

 

Could not get Let's Encrypt certificate for sould.de: Please check http://sould.de/.well-known/acme-challenge/hw9FNw-N6dzWVwZIGI9k80QbtMeT7Zw-9J00lm9Zh74 - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/sould.de\/.well-known\/acme-challenge\/hw9FNw-N6dzWVwZIGI9k80QbtMeT7Zw-9J00lm9Zh74): failed to open stream: HTTP request failed! HTTP\/1.1 404 Not Found\r\n","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":171}

Share this post


Link to post
Share on other sites
  • 0

Hast du die acme.conf im Webserver angelegt? Siehe Konfigurations-Templates für den Webserver

Share this post


Link to post
Share on other sites
  • 0

Ich hatte das selbe Problem, bei mir war der Pfad innerhalb der acme.conf Falsch. Ich habe darauf hin einen symbolischen Link erstellt und es hat funktioniert.

Alias "/.well-known/acme-challenge" "/var/www/html/froxlor/.well-known/acme-challenge"
<Directory "/var/www/html/froxlor/.well-known/acme-challenge/">
        Require all granted
</Directory>
./
├── froxlor
│   ├── actions
│   ├── css
│   ├── install
│   ├── js
│   ├── lib
│   ├── lng
│   ├── logs
│   ├── scripts
│   ├── templates
│   └── updates
└── html
    └── froxlor -> ../froxlor/

Share this post


Link to post
Share on other sites
  • 0

Ehm, wenn du die config aus DEINEM froxlor heraus aufrufst (via Konfiguration -> etc.etc.etc) dann MUSS dieser Pfad stimmen, denn der wird relativ zu deiner Froxlor installation ermittelt. Dann hast du das Template wohl woanders einfach blind kopiert. 

 

Und statt einem umständlichen und eher unschönen Symlink - pass doch den Pfad in der Config einfach an?!

Share this post


Link to post
Share on other sites
  • 0

Ich habe nachgeschaut, du hast absolut recht. Ich hatte ebenfalls Probleme mit den SSL Zertifikaten. Ich werde wohl die conf aus unachtsamkeit mit einer aus einer Anleitung überschrieben haben.

 

Danke für den Hinweis, werde meine config ändern und den link entfernen.

Share this post


Link to post
Share on other sites
  • 0

Hallo,

ich habe jetzt nochmal geschaut.

Also lt.Anleitung sollte die acme.conf  in

/etc/apache2/conf-enabled/acme.conf

Aber dort gibt es den ORdner conf-enabled nicht....

Wo gehört die acme.conf denn hin ?

 

Die acme-challenge ist angelegt, nur nicht im html

Also habe ich folgenden Code für die acme.conf

 

Alias "/.well-known/acme-challenge" "/var/www/froxlor/.well-known/acme-challenge"
<Directory "/var/www/froxlor/.well-known/acme-challenge/">
        Require all granted
</Directory>

 

Müsste also nur noch wissen, wo die .conf ursprünglich stecken sollte

Share this post


Link to post
Share on other sites
  • 0

Die muss da rein wo sie von der apache.conf bzw httpd.conf inkludiert wird, schau am besten einfach mal in der globalen config nach. Eigentlich zeigen die unsere configtemplates genau wo sie hin soll, allerdings musst du die richtige distribution auswählen, denn diese Ordner unterscheiden sich leider immer wieder.

 

Falls die von dir genutzte Distribution nicht dabei ist, musst du bitte gucken, welcher Ordner da für dich der richtige ist, wie gesagt, einfach in der apache config nachgucken.

Share this post


Link to post
Share on other sites
  • 0
:~# grep -ir "include" /etc/apache2/
/etc/apache2/apache2.conf:#   In order to avoid conflicts with backup files, the Include directive is
/etc/apache2/apache2.conf:# * ports.conf is always included from the main configuration file. It is
/etc/apache2/apache2.conf:# Possible values include: debug, info, notice, warn, error, crit,
/etc/apache2/apache2.conf:# Include module configuration:
/etc/apache2/apache2.conf:Include mods-enabled/*.load
/etc/apache2/apache2.conf:Include mods-enabled/*.conf
/etc/apache2/apache2.conf:# Include list of ports to listen on and which to use for name based vhosts
/etc/apache2/apache2.conf:Include ports.conf
/etc/apache2/apache2.conf:# Include of directories ignores editors' and dpkg's backup files,
/etc/apache2/apache2.conf:# Include generic snippets of statements
/etc/apache2/apache2.conf:Include conf.d/
/etc/apache2/apache2.conf:# Include the virtual host configurations:
/etc/apache2/apache2.conf:Include sites-enabled/
/etc/apache2/conf.d/security:# Set to "EMail" to also include a mailto: link to the ServerAdmin.
/etc/apache2/conf.d/localized-error-pages:# includes to substitute the appropriate text.
/etc/apache2/conf.d/localized-error-pages:#   Alias /error/include/ "/your/include/path/"
/etc/apache2/conf.d/localized-error-pages:# /usr/share/apache2/error/include/ files and copying them to /your/include/path/,
/etc/apache2/conf.d/localized-error-pages:# even on a per-VirtualHost basis.  If you include the Alias in the global server
/etc/apache2/conf.d/localized-error-pages:# The default include files will display your Apache version number and your
/etc/apache2/conf.d/localized-error-pages:# The internationalized error documents require mod_alias, mod_include
/etc/apache2/conf.d/localized-error-pages:# <IfModule mod_include.c>
/etc/apache2/conf.d/localized-error-pages:#        Options IncludesNoExec
/etc/apache2/conf.d/localized-error-pages:#        AddOutputFilter Includes html
/etc/apache2/mods-available/reqtimeout.conf:# cause problem with ssl enabled virtual hosts: This timeout includes
/etc/apache2/mods-available/mime.conf:# For files that include their own HTTP headers:
/etc/apache2/mods-available/mime.conf:# To parse .shtml files for server-side in cludes (SSI):
/etc/apache2/mods-available/mime.conf:# (You will also need to add "Includes" to the "Options" directive.)
/etc/apache2/mods-available/mime.conf:AddOutputFilter INCLUDES .shtml
/etc/apache2/mods-available/alias.conf:# Note that if you include a trailing / on fakename then the server will
/etc/apache2/mods-available/alias.conf:# We include the /icons/ alias for FancyIndexed directory listings.  If
/etc/apache2/mods-available/autoindex.conf:# and not include in the listing.  Shell-style wildcarding is permitted.
/etc/apache2/mods-available/setenvif.conf:# a directory that does not include the trailing slash.  This fixes a
/etc/apache2/mods-available/include.load:LoadModule include_module /usr/lib/apache2/modules/mod_include.so
/etc/apache2/mods-available/userdir.conf:                Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
/etc/apache2/suexec/www-data:# suexec man page included in the package for more details.
/etc/apache2/sites-available/default:   # Possible values include: debug, info,notice, warn, error, crit,
/etc/apache2/sites-available/default-ssl:       # Possible values include: debug, info, notice, warn, error, crit,
/etc/apache2/sites-enabled/15_default.conf:             Include /etc/apache2/froxlor.d/*.conf
/etc/apache2/sites-enabled/16_webmail.conf:             Include /etc/apache2/froxlor.d/horde.conf

Das spuckt er mir aus

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...