Jump to content
Froxlor Forum
  • 0

Let's Encrypt lässt sich nicht aktivieren


Go to solution Solved by d00p,

Question

Hallo,

hab die Tage Froxlor auf 0.9.35.1-1 geupdatet und wollte die neue Let's Encrypt Funktion für meine Domains nutzen.

Leider bekomme ich es nicht aktiviert, wenn ich unter Domains "Benutze Let's Encrypt" aktiviere, und dann auf Speichern gehe, schmeißt er mich wieder auf die Domain ansicht und irgendwie passiert rein gar nichts.

 

Auf meienm Server wird Debian Jessie benutzt, somit hab ich auch die acme.conf eingefügt und den Service neugestartet.

Mein Problem was ich bemerkt habe ist, das im froxlor Ordner kein .wellknown Order erstellt wurde.

 

 

Hab das Thema hier zu gefunden:

https://forum.froxlor.org/index.php/topic/13318-probleme-bei-der-nutzung-von-lets-encrypt/

 

nur zeigen meine Logs nichts besonderes an:

Apr 18 12:05:01   CRON[xxxxx]: (root) CMD (/usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null)
Apr 18 12:05:01   CRON[xxxxx]: (root) CMD (/usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null)
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] Updating Let's Encrypt certificates
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] cron_tasks: Searching for tasks to do
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] Let's Encrypt certificates have been updated
Apr 18 12:05:01   Froxlor: [ Action cronjob] [notice] Checking system's last guid
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::createIpPort: creating ip/port settings for  5.xx.xxx.56:80
Apr 18 12:05:01   Froxlor: [ Action cronjob] [notice] 5.xx.xxx.56:80 :: namevirtualhost-statement no longer needed for apache-2.4
Apr 18 12:05:01   Froxlor: [ Action cronjob] [debug] 5.xx.xxx.56:80 :: inserted vhostcontainer
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::createVirtualHosts: creating vhost container for domain 5, customer xxx
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::createVirtualHosts: creating vhost container for domain 2, customer xxx
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::createVirtualHosts: creating vhost container for domain 1, customer xxx
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::createVirtualHosts: creating vhost container for domain 6, customer xxx
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::createVirtualHosts: creating vhost container for domain 10, customer xxx
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::createVirtualHosts: creating vhost container for domain 9, customer xxx
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
Apr 18 12:05:01   Froxlor: [ Action cronjob] [information] apache::reload: reloading apache
Apr 18 12:05:02   apache2[xxxxx]: Reloading web server: apache2.
Apr 18 12:05:02   Froxlor: [ Action cronjob] [notice] Checking system's last guid

Was mach ich also falsch, das ich das nicht aktiviert kriege?

Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
  • Solution

na haben wir

a2enmod ssl 

vergessen?

 

Und in der meldung vorher noch zu sehen hast du apache-2.4, du kannst also das "namevirtualhost" aus der IP/Port auf "no" stellen, brauchst du nicht

Link to post
Share on other sites
  • 0

- activate Let's Encrypt in the settings
- as admin, goto Configuration -> select your distro -> select Webserver -> select your software
- copy'n'paste the acme.conf part of the configration template
- restart/reload webserver

Das hab ich alles gemacht. Hab nun etwas rumprobiert und meine IP mit dem Port 443 erstellt. 

Listen: Nein

NameVirtualHost: Ja

vHost-Container: Ja

Specialsettings: Nein

ServerName: Ja

SSL: Ja

 

Ist das notwendig, den Port einzutragen beim "Let's Encrypt"?

 

Nun meckert nämlich apache:

Apr 18 12:13:23   systemd[1]: Reload failed for LSB: Apache2 web server.
Apr 18 12:13:33   apache2[xxx]: Reloading web server: apache2 failed!
Apr 18 12:13:33   apache2[xxx]: The apache2 configtest failed. Not doing anything. ... (warning).
Apr 18 12:13:33   apache2[xxx]: Output of config test was:
Apr 18 12:13:33   apache2[xxx]: AH00526: Syntax error on line 8 of /etc/apache2/sites-enabled/10_froxlor_ipandport_5.xx.xxx.56.443.conf:
Apr 18 12:13:33   apache2[xxx]: Invalid command 'SSLEngine', perhaps misspelled or defined by a module not included in the server configuration
Apr 18 12:13:33   apache2[xxx]: Action 'configtest' failed.
Apr 18 12:13:33   apache2[xxx]: The Apache error log may have more information.
Apr 18 12:13:33   systemd[1]: apache2.service: control process exited, code=exited status=1
Apr 18 12:13:33   systemd[1]: Reload failed for LSB: Apache2 web server.

#Advanced Froxie

Ja, unter Einstellungen -> SSL-Einstellungen -> Let's Encrypt verwenden, ist es aktiviert...

Link to post
Share on other sites
  • 0

Ist das notwendig, den Port einzutragen beim "Let's Encrypt"?

Bei Let's Encrypt selbst kannst du gar keinen port einstellen. Wenn du die IP/Port Einstellungen meinst, dann: ja natürlich ist das nötig

Link to post
Share on other sites
  • 0

Doch noch ein kleines Problem, meine www. weiterleitungen wollen nicht mit https so wirklich.

 

Ich benutze meine Seite OHNE www. somit werden alle www. anfragen auf domain.de geleitet.

 

wenn ich aber nun https://www.domain.de versuche aufzurufen bekomme ich immer folgenden Fehler:

 

Dieser Verbindung wird nicht vertraut.

www.domain.de verwendet ein ungültiges Sicherheitszertifikat. Das Zertifikat gilt nur für domain.de. 

 

System-Log gibt folgenden Fehler:

Could not get Let's Encrypt certificate for www.domain.de: 
Please check http://www.domain.de/.well-known/acme-challenge/Vpdrux-9hmxFWcaooNPKbQTYjR88OBiFNF8HPqB3vyI - token not available; 
PHP error: {"type":2,"message":"file_get_contents(http:\/\/www.domain.dee\/.well-known\/acme-challenge\/Vpdrux-9hmxFWcaooNPKbQTYjR88OBiFNF8HPqB3vyI): 
failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":154}
das passiert wenn ich auf die www. -supdomains das Let's Encrypt aktivieren möchte...
Link to post
Share on other sites
  • 0

php_network_getaddresses: getaddrinfo failed: Name or service not known

 

ping www.domain.tld geht ja? Ansonsten würd ich schätzen du hast keinen wildcard A-Record für die Domain im DNS

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...