Jump to content
Froxlor Forum
  • 0

umask f?r vmail ?ndern


feiaweng

Question

Hallo,

 

kann man die umask, die vmail benutzt ?ndern?

Wenn eine Mail reinkommt, hat die die Rechte 600.

M?chte man Mails mit mutt lesen, geht das nat?rlich nicht, da man als Benutzer ja nicht der Benutzer vmail ist.

Wie mach ich das, damit neue Mails nicht 600 haben, sondern 660?

 

Danke und Gruss

Ralf

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

?hm, ?ber mutt kann ich dir nich sagen wie das tut, normal loggt sicher der Benutzer per client ein, der verbindet sich mit Courier/Dovecot und das liest dann die mails vom Filesystem mit den rechten des users vmail...

Link to comment
Share on other sites

?hm, ?ber mutt kann ich dir nich sagen wie das tut, normal loggt sicher der Benutzer per client ein, der verbindet sich mit Courier/Dovecot und das liest dann die mails vom Filesystem mit den rechten des users vmail...

das ist richtig. So machen es die Normalkunden auch.

Aber einer von denen loggt sich mit ssh ein, und liest sseine mails ?ber die bash mit mutt.

Link to comment
Share on other sites

Auf die schnelle kann ichs dir allerdings nur f?r dovecot sagen, da gibts ne direktive in der dovecot.conf, die heisst sogar "umask 0600" (etwas weiter unten)

also mit umask steht in meiner dovecot.conf nichts drin. Aber ich denke, das ist was anderes. Der Zugriff soll ja ?bers Filesystem stattfinden, da ist dovecot au?en vor.

Link to comment
Share on other sites

...

   	# Postfix uses the client socket for SMTP Auth
       client {
           # Assuming the default Postfix $queue_directory setting
           path = /var/spool/postfix/private/auth
           mode = 0660
           # Assuming the default Postfix user and group
           user = postfix
           group = postfix
       }

       # Note that we're setting a master socket. SMTP AUTH for Postfix and Exim uses client sockets.
       master {
		path = /var/run/dovecot/auth-master
		mode = 0660
		user = vmail
		group = vmail
   }

...

 

da stehts, und es ist schon 0660

Link to comment
Share on other sites

...

   	# Postfix uses the client socket for SMTP Auth
       client {
           # Assuming the default Postfix $queue_directory setting
           path = /var/spool/postfix/private/auth
           mode = 0660
           # Assuming the default Postfix user and group
           user = postfix
           group = postfix
       }

       # Note that we're setting a master socket. SMTP AUTH for Postfix and Exim uses client sockets.
       master {
		path = /var/run/dovecot/auth-master
		mode = 0660
		user = vmail
		group = vmail
   }

...

 

da stehts, und es ist schon 0660

bin mir nicht sicher, ob das das ist, was ich ben?tige.

Hab grad gefunden, dass man in der dovecot.conf die umask ?ndern kann.

Habs auf umask = 0007 ge?ndert, und dovecot neugestartet, hat aber nichts gebracht.

Link to comment
Share on other sites

660 w?rde imho auch nichts nutzen, da dass ja nur der Gruppe vmail Lese und Schreibrechte geben w?rde.

 

An den Berechtigungen in diese Richtung ?berhaupt was zu ?ndern macht f?r mich auch keinen Sinn, da der User dann mit Mutt ja die Mails aller Kunden lesen k?nnte...

Link to comment
Share on other sites

660 w?rde imho auch nichts nutzen, da dass ja nur der Gruppe vmail Lese und Schreibrechte geben w?rde.

 

An den Berechtigungen in diese Richtung ?berhaupt was zu ?ndern macht f?r mich auch keinen Sinn, da der User dann mit Mutt ja die Mails aller Kunden lesen k?nnte...

Also ich hab momentan keine L?sung f?r dieses Problem. Muss ich das wohl so hinnehmen, dass es nicht geht. Ist sowieso nicht der Standard, die Mails mit mutt zu lesen. Auf dem fr?heren Server waren die Mail im home-Folder des users, da geh?rte dem User alle Dateien. Jetzt mit froxlor geh?ren die Files im mail-Folder vmail. Und deswegen geht es halt nicht. Wennn du/ihr noch eine passende Idee habt, bin ich dankbar. Ich hab momentan keine, au?er vielleicht mit setfacl und getfacl die Berechtigungen im Mailfolder des Users zu ?ndern, m?sste aber bei jeder Mail passieren, da jede neue Mail immer mit 0600 reinflattert.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...