Jump to content
Froxlor Forum

feiaweng

Members
  • Content Count

    125
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by feiaweng

  1. Hallo Community, kann man diese Froxlor Version auf acme v2 umstellen, ohne dass es Probleme macht ? Oder arbeitest acme v2 nur korrekt mit Froxlor 0.10.x zusammen ? Gruß feiaweng
  2. ich hab vermutet, dass diese Zeile einen Konflikt aussagt: Considering conflict php5 for php7.2 Wenn dem nicht so ist, dann kann ich das wohl ignorieren. Bisher hatte ich noch keine solche Meldung beim Aktivieren eines Moduls.
  3. ich bin immer noch an dem Thema dran. Momentan bin ich am evlaluieren, welche Apache Modul denn laufen muss. mpm_event, mpm_worker, mpm_prefork. Wenn ich alle 3 disable, dann a2enmod php7.2 eingebe, läd er automatisch mpm_prefork. Andere lässt er wohl nicht zu. Was mich wundert, ist die Meldung a2enmod php7.2 Considering dependency mpm_prefork for php7.2: Considering conflict mpm_event for mpm_prefork: Considering conflict mpm_worker for mpm_prefork: Enabling module mpm_prefork. Considering conflict php5 for php7.2: Enabling module php7.2. To activate the new configuration,
  4. Ich habe folgendes gemacht: dump von Server 1 eingespielt, Froxlor DB Update gemacht, Alle Einstellungen durchgegangen, mod_proxy Haken aktiviert, libnss-extrausers angehakt, Config Templates konfiguriert von Hand, Configs neu schreiben aktiviert, cronjob mit --force --debug laufen lassen. ich hatte noch libapache2-mod-fcgi installiert. Hab ich removed. das Modul fastcgi und fcgid brauch ich doch bei Debian Stretch nicht mehr, oder ? Dafür hab ich doch proxy_fcgi aktiviert. jetzt kommt allerdings ein Internal Server error 503. oder sollte ich doch im Panel Immer nur eine E
  5. Ich guck am Wochenende nochmal ganz genau, ob ich was übersehen habe. Kann natürlich nicht ausschließen dass ich irgendwo was gemacht habe, was ich nicht mehr weiß, oder das vom Debian Upgrade kommt. Wenn ich nichts finde, nehm ich jedoch gerne mal dein Angebot an draufzugucken. Ich danke dir vielmals für deine Informationen und Mühe. Ich meld mich auf jeden Fall mit einem Feedback. Gruß feiaweng
  6. Was meinst du mit Konfigurationsdateien prüfen ? Im Panel aktiviere ich die Checkbox, dass ich libnss-Extrausers nutzen will. Führe dann die Befehle aus dem Config Template aus. Wie werden denn die passwd group Shadow befüllt ? Aus der froxlor DB und dem cronjob. Im Debug zeigt er leider nur an, dass er 0 Datensätze angelegt hat. Wo kann ich denn noch gucken ?
  7. Hier noch eine Ausgabe, was mich wundert, warum will der unbedingt /etc/php/7.2/fpm/pool.d/www.conf haben, obwohl ich /etc/php-fpm.d konfiguriert habe? Process: 20706 ExecStopPost=/usr/lib/php/php-fpm-socket-helper remove /run/php/php-fpm.sock /etc/php/7.2/fpm/pool.d/www.conf 72 (code=exited, status=0
  8. sorry, service apache2 restart AH00543: apache2: bad user name USER apachectl[19943]: Action 'start' failed. apachectl[19943]: The Apache error log may have more information. systemd[1]: apache2.service: Control process exited, code=exited status=1 systemd[1]: Failed to start The Apache HTTP Server. service php7.2-fpm restart Starting The PHP 7.2 FastCGI Process Manager... php-fpm7.2[20704]: [04-Jun-2020 19:36:57] ERROR: [pool adrenalinpur.de] cannot get uid for user 'USER' php-fpm7.2[20704]: [04-Jun-2020 19:36:57] ERROR: FPM initialization failed system
  9. so hab jetzt folgendes gemacht: dump importiert, froxlor DB update gemacht, alle Einstellungen konfiguriert im Panel, nach dem Cronjob von Froxlor kommt dann die Meldung, php7.2-fpm startet nicht. Hab wieder das Problem, dass Apache die User nicht, weil die /var/lib/extrausers files leer sind. Jetzt weiß ich grad nicht weiter.
  10. also ich habe einen mysqldump vom alten Server (Debian 8 und Froxlor 0.9.40), den Dump importiere ich nun in mysql, dann habe ich alle Daten die ich brauche, dann starte ich froxlor auf dem neuen Server (Debian 9 und Froxlor 0.10.17) gehe alle Einstellungen durch, und führe die config templates aus. Oder meintest du ich soll auf dem neuen Server die Froxlor Version 0.9.40 installieren, und diese dann updaten auf 0.10.17?
  11. ok,danke, ich werde das jetzt genau so mache. Froxlor reinstallieren, dann starten, alle Einstellungen durchgehen, dann services aus den config templates konfigurieren, dann mysql import.
  12. Ok, ich könnte ja nochmal von vorne anfangen: mysqldump importieren Konfiguration im Panel komplett durchgehen, bzw. das install-services.php script ausführen Apache SSL aktiveren php-fpm config anpassen Wäre das der richtige Weg?
  13. ich habe nachdem ich die DB importiert habe, im Apache SSL und PHP_FPM deaktiviert gelassen. Im Apachen SSL aktiviert. Funktioniert. Wenn ich PHP_FPM aktiviere und den Apachen neu starte hat er alle Letsencrypt Certs gelöscht, wenn ich diese vom alten System unt /etc/apache2/ssl einfüge, lässt er sich starten. Ich muss dazu sagen, auf dem Server 1 habe ich viele LE Certs installiert. getent passwd zeigt keine mysql user an, nur die lokalen. Ausfürhren des cronjobs: /usr/bin/php7.2 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug [information] TasksCro
  14. Hallo Community, ich habe froxlor 0.9.40 auf Debian Jessie laufen, und wollte auf dem 2. Server Debian und froxlor upgraden. Nach dem Update auf Debian Stretch habe ich alle mysql-DBs gedumpt, und wollte diese auf dem anderen Server importieren. Das hat teilweise funktioniert. Sobald ich php-fpm im Panel aktiviere, und angebe, ich möchte libnss-extrausers nutzen, fährt apache nicht mehr hoch. Liegt daran, das getent passwd keine User liefert, und somit der Apache den User nicht kennt. Und die php-fpm config basiert ja noch auf libnss-mysql-bg. Wenn ich im Panel den Haken se
  15. Hi d00p, danke, die Funktion SSL aktivieren ohne LE, und dann auf den Button klicken und SSL editieren, kannte ich noch nicht. Danke für deine schnelle Hilfe. Funktioniert. Gruss feiaweng
  16. Hallo Community, ich habe mehrere Domains mit LE Zeritifkaten, sowie eine Domain mit eigener IP mit einem Thawte Cert laufen. Kann ich ein domainbasiertes Zertifikat installieren, auch Thawte, ohne eigene IP? Im GUI (0.9.40.1-1+jessie1)finde ich nichts dazu. Geht es überhaupt, ohne eigene IP, und wenn LE konfiguriert ist? Die neue Froxlor Version habe ich noch nicht laufen, hab mich noch nicht getraut. Das mach ich aber demnächst mal. Danke und Gruss feiaweng
  17. Hallo cardman, habs so gemacht, wie du gesagt hast. Funktioniert wieder. Vielen Dank. feiaweng
  18. Hallo Community, ich habe das jetzt bei mehreren Kunden festgestellt. Diese haben als Beispiel 6 DBs angelegt. Sieht man auch im phpmyadmin. In der Übersicht sehe ich aber nur 2. Eine neue anlegen über froxlor geht nicht. Dann kommt die Meldung, dass es diese schon gibt. Wie bekomme ich diese in die bestehenden in die Übersicht zurück? Sie waren ja schon mal da. Danke feiaweng
  19. der Speicherverbrauch ist nun max. 256 MB, vorher waren es ja ca. 500 für die eine Webseite. Sieht also schon viel besser aus. Danke euch beiden für die Hinweise. Gruss feiaweng
  20. Danke aPollO, hab die empfohlenen Werte mal gesetzt, und beobachte das mal die nächsten Tage. Gruss feiaweng
  21. Hallo aPollO, das ist noch auskommentiert in der /etc/php5/fpm/php-fpm.conf. Also alle 3 Werte nutzen somit den Default Wert 0. Welche Werte sollte ich hier einstellen? Gruss feiaweng
  22. die Werte habe ich von munin-graphen. Siehe Anhang. Die Namen darf ich leider nicht veröffentlichen. Aber man sieht den current verbrauch von RAM und CPU. Einige der Domains brauchen viel, andere eher weniger. Liegt an der Anzahl der Zugriffe. Bin gerade dabei die Artikel durchzulesen, aber geändert habe ich noch nichts. Das mache ich später mal in Ruhe. Was ich gelesen habe, ist das man mit pm = static/dynamic schon mal eine erste Option der Optimierung hat ? Gruss
  23. Ich habe jetzt umgestellt von FCGI auf PHP-FPM. Ich sehe allerdings dass trotzdem viel CPU und RAM benötigt wird. Bei einer Domain ganz besonders, aber da läuft auch ioncube. Dieses musste ich allerdings für PHP global aktivieren, da man es nicht wie Zendguard für einzelne Domains aktivieren kann. Kann ich noch was optimieren von den Schaltern die php-fpm anbietet? Welche Infos muss ich liefern? Danke feiaweng
  24. Danke d00p, ich aktviere das global. Aber interessehalber mal gefragt: Specify alternative path to FastCGI process manager config file. -> ist damit das php.ini file gemeint, welches nur die eine Zeile mit der zend_extension enthält? Ist aber nur aus Interesse gefragt. Ich bleibe lieber bei der Methode die nicht so kompliziert ist ? Gruss feiaweng
  25. Hallo Community, ich stelle gerade den phpHandler um von fcgid auf php-fpm. Generell funktioniert php-fpm. Folgendes Anliegen habe ich nun: Mit fcgid und eigener php.ini für jede Doamin konnte ich nur für eine Domain eine extension aktivieren zend_extension = /usr/lib/php/20151012/ioncube_loader_lin_5.6.so Mit php-fpm gibt es nun keine eigene php.ini für die Domain mehr. In der php-fpm Konfiguration für die Domain kann ich die obige Zeile nicht angeben. Dies führt zu einem error. Die zend_extension kann ich global einschalten in der etc/php5/fpm/php.ini G
×
×
  • Create New...