Jump to content
Froxlor Forum
  • 0

Froxlor installation mit nginx und php-fpm verweist nicht auf den fpm sock


Go to solution Solved by d00p,

Question

Hi,

 

ich weiß nicht warum aber ich laufe jetzt schon mehrmals in den selben Fehler. Ich habe Nginx mit php-fpm installiert; auch Froxlor lies sich problemlos installieren, dann habe ich die Einstellungen vorgenommen und die Konfiguration durch gemacht, sobald aber der Cronjob läuft erstellt er mir eine nginx config die keinen Pfad zum fpm hat:

# 10_froxlor_ipandport_202.61.246.121.80.conf
# Created 01.03.2021 23:36
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

server { 
	listen    202.61.246.121:80 default_server;
	# Froxlor default vhost
	server_name    DOMAIN;
	access_log     /var/log/nginx/access.log combined;
	root     /var/www/;
	index    index.php index.html index.htm;

	location / {
	}
	location ~ \.php {
		fastcgi_split_path_info ^(.+?\.php)(/.*)$;
		include /etc/nginx/fastcgi_params;
		fastcgi_param SCRIPT_FILENAME $request_filename;
		fastcgi_param PATH_INFO $fastcgi_path_info;
		try_files $fastcgi_script_name =404;
		fastcgi_pass 127.0.0.1:8888;
		fastcgi_index index.php;
	}
}

Und ich komm einfach nicht drauf warum das passiert

 

ich bekomm auch komischerweise folgenden output:

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug
[information] TasksCron: Searching for tasks to do
[information] Task4 started - Rebuilding froxlor_bind.conf
[information] Cleaning dns zone files from /etc/bind/domains/
[information] No domains found for nameserver-config, skipping...
[information] nginx::createIpPort: creating ip/port settings for  202.61.246.121:80
[information] nginx::writeConfigs: rebuilding /etc/nginx/sites-enabled/
[information] Froxlor\Cron\Http\NginxFcgi::reload: fpm config directory "/etc/php/8.0/fpm/pool.d/" is empty. Creating dummy.
[information] Froxlor\Cron\Http\NginxFcgi::reload: running service php8.0-fpm restart
[information] Froxlor\Cron\Http\NginxFcgi::reload: fpm config directory "/etc/php/7.4/fpm/pool.d/" is empty. Creating dummy.
[information] Froxlor\Cron\Http\NginxFcgi::reload: running service php7.4-fpm restart
[information] Froxlor\Cron\Http\NginxFcgi::reload: reloading Froxlor\Cron\Http\NginxFcgi
sh: 1: nscd: not found
sh: 1: nscd: not found
[notice] Checking system's last guid

 

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 1

kann man schon machen, aber php8 ist da bei vielen sehr viel strikter als die 7er Reihe, es könnte also hier und da schon zu ungewolltem verhalten kommen. unsere demo läuft ja auch schon einige zeit auf php8, aber da läuft z.B. kein Cron oder so, das muss ich alles nochmal genau testen

Link to post
Share on other sites
  • 1

  

2 minutes ago, Tealk said:

Also empfiehlst du die Nutzung im Produktiven noch nicht? Ich konnte auf der Spielwiese bisher keinen Fehler, außer meinen eigenen dort oben, erkennen.

Ansicht läuft Froxlor oh. probleme mit PHP8, klar gibt es kleinere kinderkrankheiten, was normal ist. persönlich habe ich oh. probleme froxlor mit php8 im aktiven einsatz. nur viele CMS Systeme (wenn man sowas benutzen will), haben noch viele probleme damit.

Link to post
Share on other sites
  • 0

Und ich hab gestern stunden lang diese Checkbox nicht gesehen -.-
Dank dir.

 

Und Top, sehe gerade Froxlor läuft sogar schon unter PHP8

Link to post
Share on other sites
  • 0
32 minutes ago, Tealk said:

Und Top, sehe gerade Froxlor läuft sogar schon unter PHP8

das meiste ja :x

Link to post
Share on other sites
  • 0
2 minutes ago, d00p said:

das meiste ja :x

Also empfiehlst du die Nutzung im Produktiven noch nicht? Ich konnte auf der Spielwiese bisher keinen Fehler, außer meinen eigenen dort oben, erkennen.

Link to post
Share on other sites
  • 0

also dieses

sh: 1: nscd: not found
sh: 1: nscd: not found

kommt aber immer noch wenn der cron ausgeführt wird. Aber nscd braucht man doch gar net wenn man libnss-extrausers nutzt oder?

 

7 minutes ago, irisdina said:

nur viele CMS Systeme (wenn man sowas benutzen will), haben noch viele probleme damit.

ja gut das ist mir schon aufgefallen, bei mir läuft fast alles auf php7.4 ganz ganz selten das was auf php8 läuft

Link to post
Share on other sites
  • 0
8 minutes ago, Tealk said:

kommt aber immer noch wenn der cron ausgeführt wird. Aber nscd braucht man doch gar net wenn man libnss-extrausers nutzt oder?

korrekt, das brauchst du nicht, das nscd zeug wird ausgeführt wenn du fcgid oder fpm nutzt und NICHT libnss-extrausers in den einstellungen aktiviert hast, schau mal ob die Settings passen

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...