Jump to content
Froxlor Forum
  • 0
lively

Neu-Installation mit Nginx - Fehler 403 Forbidden im Froxlor-Ordner

Question

Nginx mit php 7.2 installiert, Standardseite lässt sich aufrufen, beim Froxlor-Verzeichnis Fehler 403. Wenn ich den Froxlor-Pfad mit index.php mit angebe, wird die Datei zum download angeboten statt ausgeführt zu werden.

Was übersehe ich?

danke!

liv

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

index.php in der "index" anweisung das er das auch als "einstiegsdatei" annimmt?

index index.html index.php;

 

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, lively said:

wird die Datei zum download angeboten statt ausgeführt zu werden.

dann funktioniert dein php nicht, hast du schon froxlor generierte configs oder willst du erst installieren?

Share this post


Link to post
Share on other sites
  • 0

aus der default config:

        # pass PHP scripts to FastCGI server
        #
        #location ~ \.php$ {
        #       include snippets/fastcgi-php.conf;
        #
        #       # With php-fpm (or other unix sockets):
        #       fastcgi_pass unix:/run/php/php7.3-fpm.sock;
        #       # With php-cgi (or other tcp sockets):
        #       fastcgi_pass 127.0.0.1:9000;
        #}

da musst du jetzt wissen ob du fpm hast oder nen php-cgi dienst der läuft, ein "mod_php" gibt es bei nginx nicht

Share this post


Link to post
Share on other sites
  • 0

Hi dOOp,

ich will erst Froxlor installieren.

In welchem file schaue ich nach mit index.php?

Share this post


Link to post
Share on other sites
  • 0

kannst Du bitte auch die Pfade mit angeben, weiss nicht von welchen dateien Du sprichast.

Share this post


Link to post
Share on other sites
  • 0

Am besten einfach php-fpm installieren:

apt-get install php-fpm

und im default vhost entsprechend aktivieren (/etc/nginx/sites-enabled/default):

server {

	[...]

        # pass PHP scripts to FastCGI server
        #
        location ~ \.php$ {
               include snippets/fastcgi-php.conf;
        #
        #       # With php-fpm (or other unix sockets):
               fastcgi_pass unix:/run/php/php7.3-fpm.sock;
        #       # With php-cgi (or other tcp sockets):
        #       fastcgi_pass 127.0.0.1:9000;
        }

	[...]
}

dann nginx restarten und es sollte gehen :)

Share this post


Link to post
Share on other sites
  • 0

php-fpm installiert, Standard-ist PHP 7.2.24 installiert. Weiter Fehler 403

Ist das das Problem?

Share this post


Link to post
Share on other sites
  • 0

7.2....du sagst es doch selbst...dann ändere doch bitte den pfad zum socket in der /etc/nginx/sites-enabled/default auch entsprechend von /run/php/php7.3-fpm.sock auf /run/php/php7.2-fpm.sock (und schau am besten ob dein php-7.2 das socket auch genau dort erstellt)

ich dachte du adaptierst das dann schon passend auf dein system :)

Share this post


Link to post
Share on other sites
  • 0

Nach einem Festplatten-Crash und einer Neu-Installation bin ich jetzt bis zur Froxlor-Einrichtungs-Seite gelangt.

Musste noch das root-Kennwort für MySQl setzen.

Wenn ich auf "Installation vorsetzen" klicke, passiert ... NICHTS

Was tun?

Vielen Dank!Froxlor_Install.thumb.png.4bb41d1ce5dccd7efea6b615ccf98804.png

Share this post


Link to post
Share on other sites
  • 0

Mal in die Webserver logs geschaut? Das so gar nichts passiert ist etwas ungewöhnlich...er sollte ja zumindest das Formular absenden....

Share this post


Link to post
Share on other sites
  • 0

Moin dOOp,

keine Einträge in ../mysql/error.log, auch nicht in /nginx-Log's

Anscheindend wurde das root-MySQl-Kennwort doch nicht gesetzt.
Das gehe ich erst einmal an

 

Share this post


Link to post
Share on other sites
  • 0

Naja, egal wie, das formular würde er doch absenden....du sagst es passiert NICHTS und nicht das du nach dem Absenden einen Fehler bekommst. Also das wäre das erste mal das ich höre das wieso-auch-immer das installationsformular nicht abzuschicken geht ohne jegliche meldung

Share this post


Link to post
Share on other sites
  • 0

Ja, die Wege des Herrn und der EDV sind unergründlich. 😉

Anscheinend habe ich mir meine MySQL-Config zerschossen.

Zumindest weiss ich wie ich bis zu diesem (Installation) Punkt komme.

Ich bleibe dran 😉

 

Share this post


Link to post
Share on other sites
  • 0

Das wird immer komischer:

Das Setzen eines MySQL-root-Kennwort wird nicht angenommen:

Ich kann mich ohne Kennwort am mysql anmelden.

Mich schon wund gegoogelt.

Ubuntu 18.04

Kannst du dir das erklären?

Läuft Froxlor auch mit mariadb?

Share this post


Link to post
Share on other sites
  • 0

tjaja, diese root-user kacke... probiers hiermit: 

und ja, froxlor läuft problemlos mit mariadb

 

Share this post


Link to post
Share on other sites
  • 0

Jetzt nimmt er das root-PW nicht.

Was ein Dreck.

Ich versuche es mit MariaDB, muss ich irgend etwas beachten?

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, lively said:

Jetzt nimmt er das root-PW nicht.

wie "er nimmt das root-pwd nicht"? Bisschen genauere beschreibung WO und in welchem Zusammenhang...sonst wird es etwas schwer.

1 hour ago, lively said:

Ich versuche es mit MariaDB, muss ich irgend etwas beachten?

nein, funktioniert genauso

Share this post


Link to post
Share on other sites
  • 0

Hi d00p,

mysql-Prompt: Kennwort nicht akzeptiert bei der Eingabe.

MySQL-Server deinstalliert, inkl. Configs, MaraiDB hängt sich anschliessend bei der Installation/Initialiserung auf ...

Der Server mag mich nicht.

Egal, ich setze ihn jetzt  neu auf, ist ja nichts drauf.

Ich komme wieder 😉

Share this post


Link to post
Share on other sites
  • 0

.. wieder zurück 😉

Nach dem Einbau eines neuen Controllers und 2 Platten läuft der Server endlich.

Ubuntu 16.04 und 18.04:
Was mir aufgefallen ist, das weder in MySQl, noch in MariaDB, bei einer Neu-Installation ein root-Kennwort gesetzt wird.

Komisch ..
An sich kenne ich es so, dass in /etc/.my.cfn bzw. /root/.my.cfn das root-MySQL-Kennwort steht.
 Bin ich blond oder habe ich irgend etwas verpasst? 😉

Froxlor-Installation:

dank deiner (d00p) Anleitung oben habe ich die ersten Anfängerfehler umschifft, froxlor-Eingabe-Maske steht, nur was gebe ich ihm als "Passwort für den MySQL-Root-Account:" an?

Muss ich erst noch ein MySQL/MariaDB-root-PW setzen?

liv

 

 

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, lively said:

Was mir aufgefallen ist, das weder in MySQl, noch in MariaDB, bei einer Neu-Installation ein root-Kennwort gesetzt wird.

ja das ist normsl mittlerweile :) Damit ist aber auch nur lokaler access via auth plugin möglich, daher sind die änderungen notwendig

5 minutes ago, lively said:

Muss ich erst noch ein MySQL/MariaDB-root-PW setzen?

Ja ;)

Share this post


Link to post
Share on other sites
  • 0

Empfehlung:
"CREATE USER 'admin'@'localhost' IDENTIFIED BY 'password_here';
GRANT ALL PRIVILEGES ON *.* TO 'admin'@'localhost' WITH GRANT OPTION;"

Ausgabe:
MariaDB [(none)]> CREATE USER 'admin'@'localhost' IDENTIFIED BY 'xxxxxxxxx';
Query OK, 0 rows affected (0.00 sec)

MariaDB [(none)]> GRANT ALL PRIVILEGES ON *.* TO 'admin'@'localhost' WITH GRANT OPTION;
Query OK, 0 rows affected (0.00 sec)

Test:
mysql -u admin -p

Kennwort wird abgefragt, Login erfolgreich, ohne Kennwort -->Access denied (so soll es auch sein)

Froxlor:
Ergebnis:
SQLSTATE[HY000] [1045] Access denied for user 'admin'@'localhost' (using password: NO)

Habe dann nochmals alles neu eingetragen, jetzt geht es nicht weiter, wenn ich auf "Installation fortführen" klicke.

Grrrr...

Das ist die gleiche Situation wie gestern.

Nachtrag:

In der Grafik ist User "root"eingetragen, mit User "admin" das gleiche Spiel.

Froxlor_Install.png

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, lively said:

Empfehlung:
"CREATE USER 'admin'@'localhost' IDENTIFIED BY 'password_here';
GRANT ALL PRIVILEGES ON *.* TO 'admin'@'localhost' WITH GRANT OPTION;"

Ausgabe:
MariaDB [(none)]> CREATE USER 'admin'@'localhost' IDENTIFIED BY 'xxxxxxxxx';
Query OK, 0 rows affected (0.00 sec)

MariaDB [(none)]> GRANT ALL PRIVILEGES ON *.* TO 'admin'@'localhost' WITH GRANT OPTION;
Query OK, 0 rows affected (0.00 sec)

Test:
mysql -u admin -p

Kennwort wird abgefragt, Login erfolgreich, ohne Kennwort -->Access denied (so soll es auch sein)

Froxlor:
Ergebnis:
SQLSTATE[HY000] [1045] Access denied for user 'admin'@'localhost' (using password: NO)

Habe dann nochmals alles neu eingetragen, jetzt geht es nicht weiter, wenn ich auf "Installation fortführen" klicke.

Grrrr...

Das ist die gleiche Situation wie gestern.

Froxlor_Install.png

Naja, du legst den user admin@localhost an und gibts bei der installation aber die 127.0.0.1 an....klar funktioniert das nicht, den user admin@127.0.0.1 kennt er nicht

Share this post


Link to post
Share on other sites
  • 0

Also ehrlich gesagt weiss ich nicht was du da komisches machst, mit anpassungen von root oder auch eigenem admin mit vollen rechten funktioniert das bei mir wunderbar. Ggfls probierst du mal einen anderen Browser o.Ä. wer weiss was da u.U. an plugins oder sonstwas irgendwas blockiert - da kann ich nur raten. Aber generell funktioniert das prima und einwandfrei (wie offenbar bei vielen vielen anderen leute auch....)

Share this post


Link to post
Share on other sites
  • 0

Ist mir klar, das das Problem zwischen Tastatur und Stuhl zu suchen ist 😉

Bin einen Schritt weiter, mit Chrome geht es schon einmal einen Schritt weiter.

Manche Dinge sind so trivial, das es weh tut 😉

Froxlor wurde erfolgreich installiert.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...