Jump to content
Froxlor Forum
  • 0
DrRosental

PHP-FPM 7.0 auf Froxlor installieren mit Debian 9 alias Stretch

Question

Hallo,

ich habe auf https://www.jaba.hosting/php-fpm-7-0-auf-froxlor-mit-debian-9/ angefangen um zu php-fpm + http2 zu wechseln. Leider habe ich den roten Schritt (cron ausschalten) missachtet und jetzt bekomme ich immer:

Aug 28 02:03:12 apachectl[14981]: AH00526: Syntax error on line 8 of /etc/apache2/sites-enabled/10_froxlor_ipandport_[...].conf:
Aug 28 02:03:12 apachectl[14981]: Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration
Aug 28 02:03:12 apachectl[14981]: Action 'start' failed.
Aug 28 02:03:12 apachectl[14981]: The Apache error log may have more information.
Aug 28 02:03:12 systemd[1]: apache2.service: Control process exited, code=exited status=1
Aug 28 02:03:12 systemd[1]: Failed to start The Apache HTTP Server.

proxy_fcgi ist enabled ... Was kann ich tun?

Vielen Dank!

Max

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0
On 8/28/2019 at 2:08 AM, DrRosental said:

Aug 28 02:03:12 apachectl[14981]: Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration

Das scheint mir aber nicht als wär mod_proxy / mod_proxy_fcgi da aktiv für die config. Hast du in den Froxlor PHP-FPM Einstellungen die Option "Use mod_proxy / mod_proxy_fcgi
Must be enabled when using Debian 9.x (Stretch). Activate to use php-fpm via mod_proxy_fcgi. Requires at least apache-2.4.9" aktiviert?

 

Share this post


Link to post
Share on other sites
  • 0

na der sagt froxlor, dass du "mod_proxy / mod_proxy_fcgi" nutzt (was du ab debian 9 MUSST) und erstellt aufgrund dessen andere webserver-configs - das was du jetzt hast gibt es für debian 9 und höher nicht mehr (FastCgiExternalServer)

Share this post


Link to post
Share on other sites
  • 0

Hallo,

ich habe mir die Anleitung auch nochmals angeschaut und bekomme nach aktivieren einen 503 ERROR. EIne Idee?

 

Danke

Share this post


Link to post
Share on other sites
  • 0

503 = service unavailable, heisst, das wohl dein php-fpm dienst nicht (korrekt) läuft. Schau doch dazu einfach in die logs bitte.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...