Jump to content
Froxlor Forum

Jazz

Members
  • Posts

    27
  • Joined

  • Last visited

Everything posted by Jazz

  1. Habs hinbekommen musste noch die Datei aus fpm-pool 7.0 nach 7.4 verschieben und php7.4-fpm neustarten
  2. Hi ich habe das entsprechend angepasst. Trotzdem zeigt er mir immer noch, dass ich Version 7.0 nutzen würde. Noch ne Idee? 7.3 und 7.4 ist installiert und hatten auch daemons (ich musste also 7.4 auf 7.5 umbenennen, damit ich system default auf 7.4 umschreiben kann)
  3. Ok also es war falscher Pfad der Dateien. Ich habe den geändert wir die www.conf lag. Jetzt gehts. Und Grep fpm zeigt auch nun mehr prozesse
  4. root@rs243945:~# ps faux | grep fpm root 8101 0.0 0.0 15436 1940 pts/1 S+ 22:23 0:00 | \_ grep fpm root 12954 0.0 0.2 392888 40504 ? Ss 21:11 0:00 php-fpm: master process (/etc/php/7.0/fpm/php-fpm.conf) www-data 12955 0.0 0.0 392888 9112 ? S 21:11 0:00 \_ php-fpm: pool www www-data 12956 0.0 0.0 392888 9112 ? S 21:11 0:00 \_ php-fpm: pool www root@rs243945:~# von unterwegs deswegen knapp.
  5. Mist zu früh gefreut. einmal Serverneustart und wieder der Error. es läuft aber der fpm dienst. Wieder die gleichen fehler im Log. Ne Idee wo ich suchen kann? LG Jazz Danke
  6. Ja der lief. Fehler gerade gefunden: Installiert war noch libapache2-mod-fcgid php-cgi und auch das modul a2enmod suexec fcgid Lösung: a2dismod fcgid systemctl restart apache2 apt-get remove libapache2-mod-fcgid php-cgi Schönen Abend und danke für schnelle Reaktion.
  7. Hi d00p, wenn ich FPM aktiviere bekomme ich im Log und einen Error 503 Service unavailiable. Die Datei welche er unten sucht gibt es tatsächlich nicht. System ist Debian Stretch. Installiert die Config (wie im froxlor Portal). Davor lief es mit mod_php. [Thu Oct 31 19:43:34.567423 2019] [proxy_fcgi:error] [pid 18535] [client 109.192.97.206:58290] AH01079: failed to make connection to backend: httpd-UDS, referer: https://www.itcares.de/ [Thu Oct 31 19:43:35.104924 2019] [proxy:error] [pid 18506] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-jazz-itcares.de-php-fpm.socket (*) failed [Thu Oct 31 19:43:35.105013 2019] [proxy_fcgi:error] [pid 18506] [client 109.192.97.206:58291] AH01079: failed to make connection to backend: httpd-UDS, referer: https://www.itcares.de/ [Thu Oct 31 19:46:48.499095 2019] [proxy:error] [pid 18535] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-jazz-itcares.de-php-fpm.socket (*) failed [Thu Oct 31 19:46:48.499142 2019] [proxy_fcgi:error] [pid 18535] [client 109.192.97.206:58398] AH01079: failed to make connection to backend: httpd-UDS, referer: https://www.itcares.de/ [Thu Oct 31 19:46:55.779000 2019] [proxy:error] [pid 18503] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-jazz-itcares.de-php-fpm.socket (*) failed [Thu Oct 31 19:46:55.779047 2019] [proxy_fcgi:error] [pid 18503] [client 109.192.97.206:58402] AH01079: failed to make connection to backend: httpd-UDS, referer: https://www.itcares.de/
  8. Hi was war denn die Lösung? Habe gerade das gleiche Problem. LG
  9. Ah glaub gefunden, seit v 10 gibts das oder?
  10. Tut mir leid dann bin ich blind. Wo denn? Hier vielleicht? LG
  11. Hallo, ich habe mir die Anleitung auch nochmals angeschaut und bekomme nach aktivieren einen 503 ERROR. EIne Idee? Danke
  12. Kurze Frage was ist der Unterschied zwischen PHP-FPM und FCGID? Möchte auch switchen.
  13. Hi zusammen, einer ne Idee wie ich Kunden die Apache Logs zugänglich machen kann? Nach Kunden getrennt sind sie ja schon. Danke und liegen Grüße. Leider ist in der Version 10.3 ja das System Log nicht dafür zu gebrauchen oder? MfG Jazz
  14. Ich habe den Fehler gefunden: mittels curl direkt geprüft: curl --ssl https://www.google.com curl: (60) SSL certificate problem: unable to get local issuer certificate More details here: http://curl.haxx.se/docs/sslcerts.html curl performs SSL certificate verification by default, using a "bundle" of Certificate Authority (CA) public keys (CA certs). If the default bundle file isn't adequate, you can specify an alternate file using the --cacert option. If this HTTPS server uses a certificate signed by a CA represented in the bundle, the certificate verification probably failed due to a problem with the certificate (it might be expired, or the name might not match the domain name in the URL). If you'd like to turn off curl's verification of the certificate, use the -k (or --insecure) option. Dann habe ich also alle CA Certificates gelöscht und neu geladen. rm -rf /etc/ssl/certs/* update-ca-certificates Und jetzt läufts php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating domain.de [information] Adding SAN entry: domain.de [information] Adding SAN entry: www.domain.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Using existing account key [information] letsencrypt Starting new account registration [information] letsencrypt Sending registration to letsencrypt server [information] letsencrypt Sending signed request to /acme/new-reg [information] letsencrypt New account registered. [information] letsencrypt Accepting lets encrypt Terms of Service [information] letsencrypt Accepting agreement at URL: https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf [information] letsencrypt Sending signed request to /acme/reg/27418516 [information] letsencrypt Lets encrypt Terms of Service accepted [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for domain.de [information] letsencrypt Token for domain.de saved at /var/www/froxlor/.well-known/acme-challenge/8QmzNO3ybx8974rtyomQakbWJmli7Qnj6u3zJxw0tDM and should be available at http://domain.de/.well-known/acme-challenge/8QmzNO3ybx8974rtyomQakbWJmli7Qnj6u3zJxw0tDM [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/2Us3xiR-1gZjIHSrUKnVDcVYd9xbX7uQ7e_vYq2s41w/3058514136 [information] letsencrypt Verification pending, sleeping 1s [information] letsencrypt Verification ended with status: valid [information] letsencrypt Requesting challenge for www.domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for www.domain.de [information] letsencrypt Token for www.domain.de saved at /var/www/froxlor/.well-known/acme-challenge/yVAZBkl875Q5e98ih9qB_-sqh6860weYPFkozjl9ms4 and should be available at http://www.domain.de/.well-known/acme-challenge/yVAZBkl875Q5e98ih9qB_-sqh6860weYPFkozjl9ms4 [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/af1QJstZI8UbnntWCKkha13EOASwuvWuH89IsLbjU5o/3058514442 [information] letsencrypt Verification pending, sleeping 1s [information] letsencrypt Verification ended with status: valid [information] letsencrypt Sending signed request to /acme/new-cert [information] letsencrypt Got certificate! YAY! [information] letsencrypt Requesting chained cert at https://acme-v01.api.letsencrypt.org/acme/issuer-cert [information] letsencrypt Done, returning new certificates and key [information] Updated Let's Encrypt certificate for domain.de [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid Vielen Dank an dich d00p. Vielleicht hilfts ja jemanden
  15. Hallo ja das habe ich auch schon gefunden in anderer Form aber die gleiche Lösung. Hilft bei mir leider nicht. Echt komisch. Hast du noch eine Idee?
  16. Hallo d00p, noch eine Frage habe gerade die curl Version gecheckt ist: 7.26.0 zu alt? Danke
  17. Hallo, ok dann muss ich erstmal den Server umziehen von wheezy auf jessie, da es für wheezy via apt-get nix aktuelleres gibt.
  18. Hi OS = Debian wheezy 3.2.41-042stab125.3 CA Certificates? Was genau meinst bzw. was muss ich prüfen? Vielen Dank
  19. Sorry hat ein wenig gedauert bis ich mich wieder darum kümmern konnte. Ich habe inzwischen das gekaufte SSL Zertifikat den Port/IPs zugweisen und in den Froxlor einstellungen Hostnamen etc gesetzt. Erreichbar ist da auch alles. Problem habe ich aber weiters mit Kundendomains für welche ich gerne Let's Encrypt nutzen würde. Ich bekommen weiterhin die Fehler php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating jgolze.de [information] Adding SAN entry: jgolze.de [information] Adding SAN entry: www.jgolze.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Using existing account key [information] letsencrypt Starting new account registration [information] letsencrypt Sending registration to letsencrypt server [error] Could not get Let's Encrypt certificate for jgolze.de: Curl: SSL certificate problem: unable to get local issuer certificate [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid
  20. Hi die Debian Version ist 7.11 mit Apache 2.2. Für das Froxlor habe ich gekaufte Zertifikate (also auch bei den IP und Porteinstellunegn). Hast du ne Idee? Danke. Hatte bisher keine Zeit dafür deswegen habe ich mich so lange nicht gemeldet.
  21. Hallo zusammen, ich habe vor ein paar Tagen die Lets Encryt Funktion aktiviert und auch die acme Datei erstellt für apache2.2. IPs mit SSL habe ich zugewiesen. Mit Zertifikaten welche gekauft sind funktioniert das Thema SSL auch schon, aber Lets Encrypt geht irgendwie nicht. Ich bekomme beim Aufruf von php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug information] Updating Let's Encrypt certificates [information] Updating golze.net [information] Adding SAN entry: domain.net [information] Adding SAN entry: www.domain.net [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Using existing account key [information] letsencrypt Starting new account registration [information] letsencrypt Sending registration to letsencrypt server [error] Could not get Let's Encrypt certificate for domain.net: Curl: SSL certificate problem: unable to get local issuer certificate [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid Hat jemand eine Idee? Die Froxlor Seite selbst hat ein gekauftes Zertifikat welches ich über eine Domain eingebunden habe. Sprich Domain angelegt mit Zertifikat und Verweis auf den Froxlor Installationspfad. Ich habe es nicht direkt über den "Hostnamen" eingebunden.
  22. Hi thanks I solved it. In froxlor database panel languages: delete lng/modules/sasettings/german.lng.php and lng/modules/sasettings/english.lng.php Done.
×
×
  • Create New...