Jump to content
Froxlor Forum

DrRosental

Members
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About DrRosental

  • Rank
    Newbie
  1. Thanks again! I tried that and entered "/etc/init.d/apache2 reload && chown root:USER /etc/ssl/froxlor-custom/my.domain.tld.*" to be as restrictive as possible. However, forcing the master cronjob only gives: SECURITY CHECK FAILED! The execute string '/etc/init.d/apache2 reload \&\& chown root:USER /etc/ssl/froxlor-custom/my.domain.tld.\*' is a possible security risk! In fact, it seems that it doesn't process the (second) command at all (but the command is okay if I do it manually). Edit: Solved by doing this
  2. Thanks for your help! Hmmm, okay but this looks like a lot of overhead compared to the idea that froxlor could just create the files like root:ssl-cert, doesn't it? Just a guess: wasn't it the intention to create them like that? I mean since the directory froxlor-custom is owned like that? In my eyes this would be a powerful feature working out of the box like: just add your user to the group "ssl-cert" and you are ready to reuse the (automatically updated) certificates, yay! ... ? Edit: or simply a new group like "froxlor-cert"
  3. Hi there, I'm wondering how to use the certificates in /etc/ssl/froxlor-custom for other things like a websocket server. I recogniced that the directory /etc/ssl/froxlor-custom is owned by root:ssl-cert but unfortunately the certificates are owned by root:root and so it seems that I cannot read them from other users - even if I add them to the group ssl-cert. This may be a simple question about rights but I'm not aware of a solution ... What can I do? Thanks!
  4. Kann ich den Haken manuell in der Datenbank setzen und dann die configs neu generieren lassen?
  5. Hallo, ich habe auf https://www.jaba.hosting/php-fpm-7-0-auf-froxlor-mit-debian-9/ angefangen um zu php-fpm + http2 zu wechseln. Leider habe ich den roten Schritt (cron ausschalten) missachtet und jetzt bekomme ich immer: Aug 28 02:03:12 apachectl[14981]: AH00526: Syntax error on line 8 of /etc/apache2/sites-enabled/10_froxlor_ipandport_[...].conf: Aug 28 02:03:12 apachectl[14981]: Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration Aug 28 02:03:12 apachectl[14981]: Action 'start' failed. Aug 28 02:03:12 apachectl[14981]: The Apache error log may have more information. Aug 28 02:03:12 systemd[1]: apache2.service: Control process exited, code=exited status=1 Aug 28 02:03:12 systemd[1]: Failed to start The Apache HTTP Server. proxy_fcgi ist enabled ... Was kann ich tun? Vielen Dank! Max
×
×
  • Create New...