Jump to content
Froxlor Forum
  • 0
Tealk

X-Frame-Options aktivierung nicht auffindbar

Question

Hi,

 

ich bin gerade auf der suche wo der Header "X-Frame-Options" gesetzt sein könnte. Ich habe ihn bis jetzt in der "/etc/apache2/conf-enabled/security.conf" gefunden aber dort ist er auskommentiert und keine andere .conf enthält den Parameter. In der ".htaccess" ist er ebenfalls nicht gesetzt.

Hat jemand noch einen Tipp wo ich sonst noch suchen könnte?

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

https://github.com/Froxlor/Froxlor/blob/master/lib/init.php#L44

Share this post


Link to post
Share on other sites
  • 0

Danke @d00p nur wie kann ich das löschen?

Und ja ich hab schon versucht das entfernen von dem Header auszureden, manchen ist aber nicht zu helfen :(

Share this post


Link to post
Share on other sites
  • 0

Wieso willst du das überhaupt deaktivieren, das hat schon seinen Sinn...auskommentieren im Code sollte aber reichen, ggfls cached Der browser das Aber auch

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, d00p said:

Wieso willst du das überhaupt deaktivieren, das hat schon seinen Sinn...auskommentieren im Code sollte aber reichen, ggfls cached Der browser das Aber auch

weil es manchmal sinnvoller ist das in der Apache Configuration statt in der Webanwendung zu machen. V.a. wenn unter der (Sub-)Domain noch andere Anwendungen laufen die keine X-Frame-Options im Code haben.

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, d00p said:

Wieso willst du das überhaupt deaktivieren, das hat schon seinen Sinn...auskommentieren im Code sollte aber reichen, ggfls cached Der browser das Aber auch

Ich gar nicht, nur helfe ich gerade wo aus und der will unbedingt seine seite bei komischen Diensten registrieren die per iframe die Webseite anzeigen. Und nach dem 5ten versuch das auszureden hab ich aufgegeben.

Foxlor läuft unter einer Subdomain und auf der Hauptdomain ein wordpress und dort muss der header raus.

Und nur auskommentieren? Ohne neuschreiben der Server configs oder so?

Share this post


Link to post
Share on other sites
  • 0

wenn froxlor unter der subdomain läuft...und dort den header setzt....was hat das dann mit dem wordpress auf der hauptdomain zu tun???

Share this post


Link to post
Share on other sites
  • 0

Sorry das habe ich wirklich missverständlich kommuniziert.

Ich möchte das für andere Domains deaktivieren, finde aber nirgends etwas warum es überhaupt aktiv ist.

Share this post


Link to post
Share on other sites
  • 0

Froxlor setzt das nicht für Kunden-Domains. Nur für sich selbst.

Share this post


Link to post
Share on other sites
  • 0

Ja, denn das hatte ich auch noch nie, nur bei der neusten Installation ist der Header gesetzt und ich weiß nicht wie das sein kann.

Share this post


Link to post
Share on other sites
  • 0

Der neuesten Version von was? Froxlor macht da nichts anders. Hast du vllt irgendwas in der Richtung in die eigenen vhost settings eingetragen oder sowas?

Share this post


Link to post
Share on other sites
  • 0

Ein neuer Server den ich installiert habe. Nein eben nicht keinerlei Anpassungen in der VHost oder in der .htaccess. Alles unberührt, das habe ich schon geprüft, daher verstehe ich das ja nicht und hab hier die frage gestellt ob jemand eine Idee hat wo man noch schauen könnte.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...