Jump to content
Froxlor Forum
  • 0
Eichjoernchen

fcgid + suexec phpmyadmin?

Question

Hallo!

Eine Frage habe ich noch zum Thema fcgi und froxlor. Es funktioniert alles au?er phpmyadmin. Da kann ich den Cash leeren wie ich will er will trotzdem die php downloaden. Habe inzwischen einiges aus dem syscp-forum probiert. Unter anderem habe ich nach einem Tipp die phpmyadmin dateien nach froxlor kopiert und die rechte auf froxlorlocal ge?ndert. Es tut sich nichts. Hat da jemand eine L?sung?

Phpmyadmin liegt offiziell in /usr/share/phpmyadmin/

Gru? J?rn

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Entweder in der Apache Konfiguration f?r dieses Verzeichnis die FCGIWrapper & AddHandler zeilen einf?gen oder eine .htaccess in diesem Verzeichnis mit diesen beiden Zeilen erstellen.

?brigens - die froxlorlcoal / syscplocal Nutzer in der Anleitung kann man zwar machen, es ist aber nicht notwendig. Ich pers?nlich sehe keine (realistischen( Szenerien, in denen sich dies auf die Sicherheit des Servers auswirkt.

Share this post


Link to post
Share on other sites
  • 0

Entweder in der Apache Konfiguration f?r dieses Verzeichnis die FCGIWrapper & AddHandler zeilen einf?gen oder eine .htaccess in diesem Verzeichnis mit diesen beiden Zeilen erstellen.

?brigens - die froxlorlcoal / syscplocal Nutzer in der Anleitung kann man zwar machen, es ist aber nicht notwendig. Ich pers?nlich sehe keine (realistischen( Szenerien, in denen sich dies auf die Sicherheit des Servers auswirkt.

Hallo!

Danke f?r die schnelle Antwort!

Kannst du mal genauer sagen, welches Verzeichnis du meinst? Ich habe jetzt innerhalb von Froxlor, aber auch innerhalb von phpmyadmin jeweils eine .htaccess Datei versucht, brachte nichts.

Die datei hatte folgenden Inhalt:

AddHandler fcgid-script .php
FCGIWrapper /var/www/php-fcgi-scripts/froxlorlocal/php-fcgi-starter .php

Gru? J?rn

Share this post


Link to post
Share on other sites
  • 0

Sagt das Apache Logfile denn etwas? Enden die Dateien wirklich auf .php (was sie sollten, allzu alt kann die Version ja nicht sein)? Wie ist die genaue Apache-Konfiguration f?r /usr/share/php/phpmyadmin - irgendwo in /etc/apache2 sollte sie liegen.

Share this post


Link to post
Share on other sites
  • 0

Sagt das Apache Logfile denn etwas? Enden die Dateien wirklich auf .php (was sie sollten, allzu alt kann die Version ja nicht sein)? Wie ist die genaue Apache-Konfiguration f?r /usr/share/php/phpmyadmin - irgendwo in /etc/apache2 sollte sie liegen.

Hallo!

Das war der entscheidende Hinweis f?r mich! Die phpmysql.conf war der Schl?ssel. Ich habe dort zwischen <directory></directory> noch zus?tzlich folgendes eingef?gt:

FCGIWrapper /var/www/php-fcgi-scripts/froxlorlocal/php-fcgi-starter .php
   Options +ExecCGI
   Order allow,deny
   allow from all

Nun funktioniert es auf meinem Testserver und auf meinem VServer bei Netcup!

Danke!

Gru? J?rn :D :D :D

Share this post


Link to post
Share on other sites
  • 0

?brigens - die froxlorlcoal / syscplocal Nutzer in der Anleitung kann man zwar machen, es ist aber nicht notwendig.

 

Wenn man mpm-worker nutzt schon, da dann kein mod_php l?uft...

Share this post


Link to post
Share on other sites
  • 0

Wenn man mpm-worker nutzt schon, da dann kein mod_php l?uft...

 

Wieso sollte dies den froxlorlocal User voraussetzen?

Share this post


Link to post
Share on other sites
  • 0

FCGI l?sst sich auch ohne suexec nutzen, ebenso wie mpm-worker. Der Vorteil hiervon ist, dass es nicht als www-data, sondern als froxlorlocal l?uft; was in der Praxis bei den meisten Nutzern keinen Unterschied machen sollte.

Share this post


Link to post
Share on other sites
  • 0

Die Zeile mehr f?r Suexec st?rt dann auch keinen und wenn jemand die kontrolle ?ber den Webserv User bekommt, ist es ja auch nicht schlecht, wenn er die Froxlor Dateien nicht modifizieren kann.

Share this post


Link to post
Share on other sites
  • 0

Seit ich mit http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_Handbuch fcgid und suexex eingerichtet habe, funktioniert phpmyadmin nicht mehr. //edit: Das äußert sich darin, dass ich beim Öffnen von der phpmyadmin-Seite die php-Datei angezeigt bekomme und im Quellcode sogar die php-Befehle stehen. Das bedeutet, dass keine Interpretation stattfindet.

Muss ich dafür nun auch einen vhost, einen User etc. anlegen?

Wenn ich +ExecCGI unter Options hineinschreibe, dann kommt die Fehlermeldung: Either all Options must start with + or -, or no Option may.

 

Meine /etc/apache2/conf.d/phpmyadmin.conf sieht so aus:

# phpMyAdmin default Apache configuration

Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
	Options FollowSymLinks
	DirectoryIndex index.php

	<IfModule mod_php5.c>
		AddType application/x-httpd-php .php

		php_flag magic_quotes_gpc Off
		php_flag track_vars On
		php_flag register_globals Off
		php_admin_flag allow_url_fopen Off
		php_value include_path .
		php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
		php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/:/usr/share/php/php-gettext/:/usr/share/javascript/
	</IfModule>

</Directory>

# Authorize for setup
<Directory /usr/share/phpmyadmin/setup>
    <IfModule mod_authn_file.c>
    AuthType Basic
    AuthName "phpMyAdmin Setup"
    AuthUserFile /etc/phpmyadmin/htpasswd.setup
    </IfModule>
    Require valid-user
</Directory>

# Disallow web access to directories that don't need it
<Directory /usr/share/phpmyadmin/libraries>
    Order Deny,Allow
    Deny from All
</Directory>
<Directory /usr/share/phpmyadmin/setup/lib>
    Order Deny,Allow
    Deny from All
</Directory>


Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...