Jump to content
Froxlor Forum
  • 0

Apache und Standart-Subdomains


Mansi

Question

Hallo,

 

ich habe grade meinen vServer frisch augesetzt. Diesmal hatte ich keine lust Froxlor manuell zu installieren und habe das Froxolor image von meinem Hoster ausgew?hlt. Ob ihr's glaubt oder nicht, alles war richtig eingerichtet(was man auf den ersten blick sehen konnte).

 

Als ich dann allerdings den ersten Kunden ins WI eingetragen habe, wollte der Apache-Server nicht auf Anfragen der Standart Sub-domain reagieren. Forefox lieferte immer :"Der Server braucht zu lange um eine Antwort zu senden.". Der DNS-Record ist richtig gesetzt und liefert auch die richtige IP-Adresse und ein trace-route liefert mir auch den richtigen Ziel-Server. Deswegen gehe ich davon aus, dass Apache nicht will.

 

Hier mal meine Apache-Configs:

 

httpd.config (sehr voll :rolleyes: )

ServerName enter-game.de

 

vhost.config

# 20_froxlor_normal_vhost_ftp1.enter-game.de.conf
# Created 29.02.2012 16:57
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.
# Domain ID: 2 - CustomerID: 2 - CustomerLogin: ftp1
<VirtualHost 62.108.44.35:80>
 ServerName ftp1.enter-game.de
 ServerAlias *.ftp1.enter-game.de
 ServerAdmin bla@mail.com
 DocumentRoot "/var/customers/webs/ftp1/"
 php_admin_value open_basedir "/var/customers/webs/ftp1/:/tmp/"
 php_admin_flag safe_mode On
 ErrorLog "/var/customers/logs/ftp1-error.log"
 CustomLog "/var/customers/logs/ftp1-access.log" combined
</VirtualHost>

 

Weder die allgemeinen access-logs von Apache noch die Custom Access-logs zeigen irgendwelche Anfragen.

 

 

Hat jemand eine Ahnung woran das liegen k?nnte ?

 

 

Gr??e,

 

Mansi

 

 

EDIT: Eine andere Frage habe ich noch: Brauch man zum Traffic z?hlen zwangsm??ig awstats oder geht das auch mit webalizer ?

Link to post
Share on other sites

3 answers to this question

Recommended Posts

Was ist das Problem und welche Domain sei nicht erreichbar?

 

EDIT: Eine andere Frage habe ich noch: Brauch man zum Traffic z?hlen zwangsm??ig awstats oder geht das auch mit webalizer ?

 

Webalizer ist quasi Standard derzeit. Klar kannst du das benutzen, wird ja auch offiziell auf der Projektwebsite angegeben.

Link to post
Share on other sites

Naja Webalizer w?rde ich nicht unbedingt als Standard bezeichnen, AWStats kommt, bedingt durch die Verbreitung kommerzieller Panel wo es meist genutzt wird, h?ufiger zum Einsatz, aber das ist ja nur nebens?chlich.

 

Zum Traffic auswerten verwendet Froxlor das jeweils gew?hlte soweit ich weiss, je nach Konfiguration.

Link to post
Share on other sites

Hallo,

 

habe das gleiche Problem wie Mansi.

Habe Debian 6.0 sqeezy froxlor 2.21 habe aber auch schon 2.26 probiert, gleiches ergebnis, Froxlor erzeugt zwar die Standardsubdomain z.B. site.vps344.server.de aber ist nicht erreichbar. ?ber normale domain geht alles.

 

Danke!

 

 

@Mansi hast du schon eine l?sung gefunden?

 

 

Mfg.

 

Sergio

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Similar Content

    • By Exsolium87
      Hallo d00p mit dem restlichen Froxlor-Team,
       
      ich arbeite schon seit über 6 Jahre mit Froxlor und weiß dieses Tool sehr zu schätzen.
      Ich habe bislang meinen Server von extern Verwalten lassen sodass ich nur Zugriff auf das Panel hatte und alles Hintergrund nicht mitbekommen hab.
      Aktuell befass ich mich, mit unter auch wegen meines Studiums zum Wirtschaftsinformatiker näher mit der Materie und habe auf einem Pi 3 Model B, Apache24, MariaDB 10 und PHP 7.4 installiert.
      Danach bin ich dann der Installationsroutine von Froxlor gefolgt und hab noch zusätzlich einen Roundcube Webmailer installiert als auch eine Domain auf den Pi laufen lassen.
      Soweit so gut. Die Hauptdomain vrultimate.net löst wie gewünscht auf das Froxlor Panel auf (/var/www/froxlor ... in /var/www/html) umbenannt, die Crons laufen durch und scheint sonst keine Probleme zu haben. Also habe ich einen "Testkunden" angelegt, mittels FTP ein paar Inhalte draufgezogen und eine Subdomain für diesen (myselfe.vrultimate.net) Der Pfad (/var/customers/webs/myselfe/) scheint richtig angelegt zu sein und laut Domain-Einstellungen sollte die Subdomain auch in das Verzeichnis verweisen. Leider löst die Subdomain aber auf die Standard Froxlor Seite und ich verstehe nicht warum. Ich habe die Einstellungen mit denen meines vormaligen Hosters verglichen und konnte bis auf die Versionsunterschiede und entsprechende Anpassungen von den Einstellungen her, keine Differenzen entdecken.  Vielleicht könnt Ihr mir helfen, neue Erkenntnisse zu bekommen 😃 

      Viele Grüße 😃 
    • By Marcel -//- AdSoleWare
      Hello.
      I manually installed Froxlor on Debian 8 and tried setting up. i installed php 7.3 in as it was the only missing point. i restarted apache2 and now it wont start. I need help
       
      Error Log:
       
    • By Michael Groß
      Hallo,
      nachdem ich meinen Froxlor-Server neu aufgesetzt habe, habe ich nun ein anderes komisches Problem.
      Ich habe die Konfigurationsschritte vollständig durchgeführt - sicherheitshalber auch zuerst "automatisch" durchführen lassen und danach noch einmal verifiziert.
      Lege ich nun einen Kunden an (http://test.computer-stube.com), verweist dies auf den Root des Servers.
      Schaue ich in die vHost-Datei, steht dort folgendes:
      # 29_froxlor_normal_vhost_test.computer-stube.com.conf # Created 07.02.2020 16:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:80> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> # 29_froxlor_ssl_vhost_test.computer-stube.com.conf # Created 07.02.2020 17:26 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 (SSL) - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:443> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder off SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/certs/apache.crt SSLCertificateKeyFile /etc/ssl/private/apache.key <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=0" </IfModule> DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> Also an sich ist die richtige Konfiguration hinterlegt.
      Im Cron ist folgendes konfiguriert:

      # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null 5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null 10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null Auch das manuelle Ausführen mittels "
      php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force bringt bei mir leider keinen Erfolg.
      Die Ausgabe vom debug ist wie folgt:
      root@lx001:/etc/apache2/sites-enabled# php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting/renewing Let's Encrypt certificates [information] No new certificates or certificates due for renewal found [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:80 [notice] 178.63.105.174:80 :: namevirtualhost-statement no longer needed for apache-2.4 [debug] 178.63.105.174:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:443 [debug] 178.63.105.174:443 :: inserted vhostcontainer [information] apache::createVirtualHosts: creating vhost container for domain 3, customer test [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi [notice] Creating passwd file [notice] Writing 1 entries to passwd file [notice] Succesfully wrote passwd file [notice] Creating group file [notice] Writing 1 entries to group file [notice] Succesfully wrote group file [notice] Creating shadow file [notice] Writing 1 entries to shadow file [notice] Succesfully wrote shadow file [notice] Checking system's last guid  
      Ich fühle mich gerade echt dämlich, kann ja eigentlich nicht so schwer sein, da es eigentlich ja alles nur "Copy+Paste" ist
      Das Endverzeichnis wurde jedoch korrekt angelegt:
      root@lx001:/var/customers/webs# ls test root@lx001:/var/customers/webs# cd test root@lx001:/var/customers/webs/test# ls index.html webalizer Ich habe zusätzlich zur "Standardkonfiguration" noch libnss-extrausers und FCGID  eingerichtet, da ich ältere PHP Versionen benötige.
      Grüße
      Michael
    • By Jason Szymanski
      Hallo,
       
      ich habe leider ein Problem mit Froxlor.
      Zu meiner Situation: Froxlor läuft auf der Subdomain web01.meinedomain.net
      Jetzt möchte ich die Domain aber auch noch weiter Nutzen und habe mich daher als Kunde angelegt und die Domain meineDomain.net als Domain hinzugefügt.
      Dort kann ich auch weitere Subdomains hinzufügen. Das scheint soweit auch zu klappen ich sehe das er VHosts anlegt und auch die Verzeichnisse im FTP anlegt.
      Wenn ich jetzt allerdings versuche auf meinedomain.net oder eine andere Subdomain unter dieser Domain zuzugreifen leitet er mich auf web01.meinedomain.net
      Ich habe mich schon in den Einstellungen umgeschaut konnte aber keine entsprechende Einstellung finden an der das liegen könnte.
      Wie verhindere ich also das er mich auf Froxlor umleitet?
       
      Mit Freundlichen Grüßen
      Jason Szymanski
    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
×
×
  • Create New...