Jump to content
Froxlor Forum
  • 0
princeofnaxos

Migration from syscp

Question

7 answers to this question

Recommended Posts

  • 0

There was ...many years...but as syscp is dead for ages now we decided to drop that long ago...you would need to upgrade from syscp to an older version of froxlor (https://files.froxlor.org/releases). Can't remember when exactly we dropped that...but 0.9.1x should still include it. After that you can upgrade the old froxlor using the latest tarball easily

Share this post


Link to post
Share on other sites
  • 0

So I installed 0.9.1, but that version does not work in PHP5.6. Could you try and find out which exact version I have to use?

Currently, I installed 0.9.19, but I don't know where to expect the 'do you want to upgrade from syscp' question.

Thanks for your effort.

Share this post


Link to post
Share on other sites
  • 0
34 minutes ago, princeofnaxos said:

So I installed 0.9.1, but that version does not work in PHP5.6. Could you try and find out which exact version I have to use?

Currently due to work, no, sorry

34 minutes ago, princeofnaxos said:

Currently, I installed 0.9.19, but I don't know where to expect the 'do you want to upgrade from syscp' question.

Well did you overwrite syscp files or did you run a new install? The key is to have the lib/userdata.inc.php file as it tells froxlor that there is a database and with what credentials to connect there. Then when opening froxlor in a browser it should tell you that you can update

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, princeofnaxos said:

So I installed 0.9.1, but that version does not work in PHP5.6. Could you try and find out which exact version I have to use?

Currently, I installed 0.9.19, but I don't know where to expect the 'do you want to upgrade from syscp' question.

Thanks for your effort.

If the accounts are not so much (Less than 25), why not manually recreate them so as to start on a very clean slate.

Don't really know BUT you seem to love Older Unsupported Software versions.

PHP5.6 is almost dropped if not dropped already. Why not move up to PHP 7.0 or if you have very old scripts on your websites, then install both 5.6 and 7.0 OR 7.2 .

As for SYSCP, never used or saw it, only heard about it. Scripts such at such an Age are meant to be kept ar Museums, not to be used in Today's environment.

Share this post


Link to post
Share on other sites
  • 0

Pretty bald to say that I love unsupported software. You base that on what? PHP 5 is still supported, but not so much longer.

We looked at upgrading to Froxlor already in 2014. That’s when my account was created. We didn’t upgrade for many reasons, one of them being time. Also, we had a well-running system, so why change that and risk running into trouble? Furthermore, we made some changes to syscp which we would have to make again to the Froxlor version of 2014.

And no, we cannot start from scratch. We have hundreds of mailboxes and websites.

Just an advice to you: if you don’t have anything substantial to add to a discussion, then just stay out of it. Better for everyone.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×