Jump to content
Froxlor Forum

princeofnaxos

Members
  • Content Count

    40
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by princeofnaxos

  1. Hi, I have a domain that is using SSL. Now I created a subdomain on this domain and created a redirect for it. The master cronjob now throws an error: "empty certificate file! Cannot create ssl-directives". Looking in the virtual host files, I see that there is a file called "29_froxlor_ssl_vhost_[mysubdomain].conf". Since the subdomain is a pure redirection, it should not use SSL. There is no need for it. It seems as if subdomains automatically are marked to use SSL, if the main domain is. Since there is no way to add certificates to the subdomain other than via Let's Encrypt, I think that this is wrong. Or they should be added to the SANs automatically.
  2. When I try to create a subdomain as customer, I cannot see all of the domains that are owned by this customer. What filter is applied to the list?
  3. Hab Froxlor ausgecheckt in meinem SourceTree. Brauchst du etwas tun bevor ich PullRequest machen kann?
  4. Wo steht dann 'useradd froxlorlocal'? Ich finde es nicht (weil ich alle Konfiguration-Schritte durchgegangen bin)
  5. Wenn running "froxlor_master_cronjob.php -- tasks", it produces this error at the end: sh: 1: /etc/init.d/php-fpm: not found On Debian Stretch with PHP 7.2, this should be "/etc/init.d/php7.2-fpm". Is this a configuration setting? I can't find it.
  6. I'm using git, so if I make changes, then I can't pull any longer. Better you update the master. Trotzdem finde ich dass es dort nicht ganz klar ist, dass man diesen Nutzer/Gruppe selber anlegen muss. Oder mindestens eine Warnung wenn den nicht existiert. Man sieht ja den Output vom Cronjob nicht, wenn man nicht selber auf der Konsole das Skript ausführt.
  7. Same error with ACME v1: PHP Fatal error: Uncaught Error: Call to a member function logAction() on null in /var/www/froxlor.0-10/lib/Froxlor/Cron/Http/LetsEncrypt/LetsEncrypt.php:166
  8. I know it is not for production, but I expect you would know about things that don't work? I'm willing to help. Jaja, schön, but I see nowhere that I need to create the user myself.
  9. Maybe the user is created on fresh install? At least it wasn't created for me. I now did it with 'useradd froxlorlocal'. Does it need a group as well?
  10. chown: invalid user: ‘froxlorlocal:froxlorlocal’ [information] Updating Let's Encrypt certificates PHP Notice: Undefined variable: cronlog in /var/www/froxlor.0-10/lib/Froxlor/Cron/Http/LetsEncrypt/LetsEncryptV2.php on line 164 PHP Fatal error: Uncaught Error: Call to a member function logAction() on null in /var/www/froxlor.0-10/lib/Froxlor/Cron/Http/LetsEncrypt/LetsEncryptV2.php:164 Stack trace: #0 /var/www/froxlor.0-10/lib/Froxlor/Cron/Http/LetsEncrypt/LetsEncrypt.php(32): Froxlor\Cron\Http\LetsEncrypt\LetsEncryptV2::run() #1 /var/www/froxlor.0-10/lib/Froxlor/Cron/MasterCron.php(101): Froxlor\Cron\Http\LetsEncrypt\LetsEncrypt::run() #2 /var/www/froxlor.0-10/scripts/froxlor_master_cronjob.php(20): Froxlor\Cron\MasterCron::run() #3 {main} thrown in /var/www/froxlor.0-10/lib/Froxlor/Cron/Http/LetsEncrypt/LetsEncryptV2.php on line 164
  11. So I enabled "Use Let's Encrypt" in the domain, but I don't see any certificate being created. Where are they stored? How can I monitor the process?
  12. Japp, I already found it. But here, I have to paste the content of the cert, and not its path? That is not very handy, since we have a Let's Encrypt mechanism in place.
  13. I take that back. Misunderstood you, thought you meant I should login as the customer.
  14. Hmm, we actually use froxlor only as admin, so I would expect it to be there as well. We don't know our customer's passwords...
  15. There is no "lock" in the Domains list. Would explain why I don't find it ?
  16. After migrating from syscp, all SSL hosts have empty host files. A comment is there, saying "# no ssl-certificate was specified for this domain, therefore no explicit vhost is being generated". Looking in lib/Froxlor/Cron/Http/Apache.php, I see that $domain['ssl_cert_file'] must be empty in order to get that message. But where in the domain form should I enter the certificate's filename? There is nothing under "Webserver SSL settings" that looks like that.
  17. Don't get me wrong here: my froxlor installation is in /var/www/froxlor. But the data files (webs, mails, database) are still called 'syscp'. I hoped the migration would move/rename them, that's all.
  18. Today I performed the migration. Had a few issues, but generally it went well. Went all the way to installing from the git-master, although it is said not to use it in production environment yet. I only was surprised (or disappointed) that the syscp file structure is maintained on the server: everything is still under /var/syscp. Probably not so important, but still. I can move/rename manually.
  19. Trying to edit a domain in Froxlor 0.10, I end up with a 500 error. The Apache error log says: ``` [Fri Dec 28 14:44:26.521632 2018] [php7:error] [pid 27116] [client 83.248.199.185:62145] PHP Fatal error: Uncaught Error: Access to undeclared static property: Froxlor\\UI\\HtmlForm::$_form in /var/www/froxlor.0-10/lib/Froxlor/UI/HtmlForm.php(52) : eval()'d code:1\nStack trace:\n#0 /var/www/froxlor.0-10/lib/Froxlor/UI/HtmlForm.php(52): eval()\n#1 /var/www/froxlor.0-10/admin_domains.php(630): Froxlor\\UI\\HtmlForm::genHTMLForm(Array)\n#2 {main}\n thrown in /var/www/froxlor.0-10/lib/Froxlor/UI/HtmlForm.php(52) : eval()'d code on line 1, referer: https://froxlor.fasterminds.com/admin_domains.php?page=domains&s=1c0e3a2e7e88e9eeeb66e5c0efc09ab7 ```
  20. Pretty bald to say that I love unsupported software. You base that on what? PHP 5 is still supported, but not so much longer. We looked at upgrading to Froxlor already in 2014. That’s when my account was created. We didn’t upgrade for many reasons, one of them being time. Also, we had a well-running system, so why change that and risk running into trouble? Furthermore, we made some changes to syscp which we would have to make again to the Froxlor version of 2014. And no, we cannot start from scratch. We have hundreds of mailboxes and websites. Just an advice to you: if you don’t have anything substantial to add to a discussion, then just stay out of it. Better for everyone.
  21. Ok, that helped. Won't bother you too much ?
  22. So I installed 0.9.1, but that version does not work in PHP5.6. Could you try and find out which exact version I have to use? Currently, I installed 0.9.19, but I don't know where to expect the 'do you want to upgrade from syscp' question. Thanks for your effort.
  23. Thanks for your answer, @d00p. I'll try and follow that path.
×
×
  • Create New...