Jump to content
Froxlor Forum
  • 0

Subdomains


Question

Hallo, mir ist da noch ein Problem aufgefallen, vielleicht hat jemand von Euch ne Lösung.

Im Froxlor habe ich eine SubDomain angelegt. Die Subdomain wurde auch auf dem Server angelegt mit entsprechender index.html datei

Leider ist jedoch die Supdomain nicht erreichbar.

Forbidden

You don't have permission to access / on this server.

 

was kann ich tun, dass die Domain erreichbar ist ??

Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

# 29_froxlor_normal_vhost_webshop.bitcom24.net.conf
# Created 27.09.2017 13:40
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 8 - CustomerID: 1 - CustomerLogin: bitcom4you
<VirtualHost 192.168.231.254:80>
  ServerName webshop.bitcom24.net
  ServerAlias www.webshop.bitcom24.net
  ServerAdmin lennestadt@bitcom4you.de
  DocumentRoot "/var/customers/webs/bitcom4you/webshop.bitcom24.net/"
  # PHP is disabled for this vHost
  Alias /webalizer "/var/customers/webs/bitcom4you/webalizer"
  ErrorLog "/var/customers/logs/bitcom4you-error.log"
  CustomLog "/var/customers/logs/bitcom4you-access.log" combined
</VirtualHost>

Link to post
Share on other sites
  • 0

# 29_froxlor_ssl_vhost_webshop.bitcom24.net.conf
# Created 27.09.2017 13:40
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 8 (SSL) - CustomerID: 1 - CustomerLogin: bitcom4you
<VirtualHost 192.168.231.254:443>
  ServerName webshop.bitcom24.net
  ServerAlias www.webshop.bitcom24.net
  ServerAdmin lennestadt@bitcom4you.de
  SSLEngine On
  SSLProtocol -ALL +TLSv1 +TLSv1.2
 SSLCompression Off
  SSLHonorCipherOrder On
  SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128
  SSLVerifyDepth 10
  SSLCertificateFile /etc/ssl/certs/apache.crt
  SSLCertificateKeyFile /etc/ssl/private/apache.key
  <IfModule mod_headers.c>
    Header always set Strict-Transport-Security "max-age=0"
  </IfModule>
  DocumentRoot "/var/customers/webs/bitcom4you/webshop.bitcom24.net/"
  # PHP is disabled for this vHost
  Alias /webalizer "/var/customers/webs/bitcom4you/webalizer"
  ErrorLog "/var/customers/logs/bitcom4you-error.log"
  CustomLog "/var/customers/logs/bitcom4you-access.log" combined
</VirtualHost>

Link to post
Share on other sites
  • 0

ssl -> weil ALIAS auf /var/www/froxlor/.well-known/acme-challenge/ zeigt, und der is via IP erreichbar 

Hauptdomain: kenn ich den vhost nicht dazu, dennoch bleibt die aussage: mit internen IP's wird das halt nix, kenn dein Setup nicht, standard ist es nicht

Link to post
Share on other sites
  • 0

# 35_froxlor_normal_vhost_bitcom24.net.conf
# Created 27.09.2017 13:50
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 1 - CustomerID: 1 - CustomerLogin: bitcom4you
<VirtualHost 192.168.231.254:80>
  ServerName bitcom24.net
  ServerAlias www.bitcom24.net
  ServerAdmin lennestadt@bitcom4you.de
  <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge
    RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [R=301;L,NE]
  </IfModule>
  <IfModule !mod_rewrite.c>
    Redirect 301 / https://bitcom24.net/
  </IfModule>
</VirtualHost>

Link to post
Share on other sites
  • 0

# 35_froxlor_ssl_vhost_bitcom24.net.conf
# Created 27.09.2017 13:50
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 1 (SSL) - CustomerID: 1 - CustomerLogin: bitcom4you
<VirtualHost 192.168.231.254:443>
  ServerName bitcom24.net
  ServerAlias www.bitcom24.net
  ServerAdmin lennestadt@bitcom4you.de
  SSLEngine On
  SSLProtocol -ALL +TLSv1 +TLSv1.2
 SSLCompression Off
  SSLHonorCipherOrder On
  SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128
  SSLVerifyDepth 10
  SSLCertificateFile /etc/ssl/certs/apache.crt
  SSLCertificateKeyFile /etc/ssl/private/apache.key
  <IfModule mod_headers.c>
    Header always set Strict-Transport-Security "max-age=0"
  </IfModule>
  DocumentRoot "/var/customers/webs/bitcom4you/bitcom24.net/"
  FcgidIdleTimeout 30
  SuexecUserGroup "bitcom4you" "bitcom4you"
  <Directory "/var/customers/webs/bitcom4you/bitcom24.net/">
    <FilesMatch "\.(php)$">
      SetHandler fcgid-script
      FcgidWrapper /var/www/php-fcgi-scripts/bitcom4you/bitcom24.net/php-fcgi-starter .php
      Options +ExecCGI
    </FilesMatch>
    Require all granted
    AllowOverride All
  </Directory>
  Alias /webalizer "/var/customers/webs/bitcom4you/webalizer"
  ErrorLog "/var/customers/logs/bitcom4you-error.log"
  CustomLog "/var/customers/logs/bitcom4you-access.log" combined
</VirtualHost>

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...