Jump to content
Froxlor Forum
  • 0
fibis

Let's Encrypt und reverse proxy

Question

Bei mir kommt es seit neustem zu Problemen bei der Erneuerung der Zertifikate von LE. Die Fehlermeldung sieht wie folgt aus:

Could not get Let's Encrypt certificate for domain.org: Please check http://domain.org/.well-known/acme-challenge/d2xR4OzG2NIaiVqGQbYSfJnEKAxI1NGaFmFQVEoMN2g - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/domain.org\/.well-known\/acme-challenge\/d2xR4OzG2NIaiVqGQbYSfJnEKAxI1NGaFmFQVEoMN2g): failed to open stream: HTTP request failed! HTTP\/1.1 404 NOT FOUND\r\n","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":171}

Dies tritt aber bei mir nur bei Domains auf, die als reverse proxy fungieren. Die Konfiguration sieht hierbei wie folgt aus:

ProxyPreserveHost On
    # seafile fileserver
    #
    ProxyPass /seafhttp http://127.0.0.1:8082
    ProxyPassReverse /seafhttp http://127.0.0.1:8082
    RewriteRule ^/seafhttp - [QSA,L]

    #
    # seahub
    #
        ProxyPreserveHost On
        ProxyPass / http://localhost:8000/
        ProxyPassReverse / http://localhost:8000/

Könnte es daran liegen?

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 1
Just now, Tealk said:

Wie kann man denn in Froxlor einen reverse proxy eintragen?

Wenn du wie oben beschrieben vhost direktiven meinst -> domain -> eigene vhost einstellungen, andere optionen gibt es dazu nicht

Share this post


Link to post
Share on other sites
  • 0

jo, du leitest ja alles von / an localhost:8000...und wenn er dort das .well-known/acme-challenge/ nicht findet gehts halt nicht (siehe 404 fehler)

Share this post


Link to post
Share on other sites
  • 0
36 minutes ago, d00p said:

Wenn du wie oben beschrieben vhost direktiven meinst

Dann habe ich aber das selbe Problem mit Let's Encrypt oder nicht?

Share this post


Link to post
Share on other sites
  • 0

naja, was erwartest du wenn alles an http://localhost:8000/ weitergeleitet wird? Ansich könntest du noch versuchen da mit Rewrite was zu erreichen, dass er bei .well-known/ requests nicht auf den proxy geht

Share this post


Link to post
Share on other sites
  • 0
17 minutes ago, d00p said:

Rewrite was zu erreichen, dass er bei .well-known/ requests nicht auf den proxy geht

hab ich gar nicht daran gedacht, muss ich mir mal anschauen

also erwartet wird dort der docker collabora

 

//EDIT

Also das eintragen von dem Proxi klappt, danke für die Hilfe :D

Share this post


Link to post
Share on other sites
  • 0
13 minutes ago, Tealk said:

Also das eintragen von dem Proxi klappt, aber ich habe ja immer noch den "DocumentRoot" parameter in der vhost. Wie bekomme ich den denn raus?

garnicht, zumindest nicht wenn die domain web-technisch von froxlor verwaltet wird

Share this post


Link to post
Share on other sites
  • 0

ok, ja das macht anscheinend für die Anbindung keinerlei Probleme. Danke nochmals :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...