Jump to content
Froxlor Forum

Question

Hello!

 

I follow all the configuration files and all the services start OK, but cronjob did not make his job, the customers path did not created.

 

Thanks for your help.

 

Regards,

 

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Hello d00p,

 

I reinstall all froxlor in a clean ubuntu distribuition and now almost all works fine. Cronjob fine, customers path fine, customers web space fine. But I have a new problem, the domains and subdomains point to my principal page var/www/html/index.php. I dont know what happend, I checked the apache config files /etc/apache2/sites-enabled/ all looks fine.

 

One year ago I installed froxlor on debian 7 and all worked great, no problems.

 

Please help me.

 

Thanks

 

Regards,

 

I fix it, probably the most noob error ever hahaha. When I installed froxlor in the first setup window I changed the server ip address and put my public ip. If anyone has the same problem. You can change again the ip system adding first the ip in the admin froxlor window --> IP AND PORTS. Then in settings --> system settings --> server ip.

Share this post


Link to post
Share on other sites
  • 0

Try: php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

Share this post


Link to post
Share on other sites
  • 0

Try: php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

 

 Hello d00p, with this command cronjob works fine, create a path costumers directory with out problem. But cronjob dont work automatically. Any suggestion?

 

Regards,

Share this post


Link to post
Share on other sites
  • 0

Looks fine to me, does the crond-daemon run?

Hello d00p,

 

I reinstall all froxlor in a clean ubuntu distribuition and now almost all works fine. Cronjob fine, customers path fine, customers web space fine. But I have a new problem, the domains and subdomains point to my principal page var/www/html/index.php. I dont know what happend, I checked the apache config files /etc/apache2/sites-enabled/ all looks fine.

 

One year ago I installed froxlor on debian 7 and all worked great, no problems.

 

Please help me.

 

Thanks

 

Regards,

Share this post


Link to post
Share on other sites
  • 0

Then check whether the generated vhost-configs are being included correctly

Share this post


Link to post
Share on other sites
  • 0

Then check whether the generated vhost-configs are being included correctly

 

Webserver vHost configuration file/dirname : /etc/apache2/sites-enabled/

Webserver diroptions configuration file/dirname: /etc/apache2/sites-available/

Webserver htpasswd dirname : /etc/apache2/htpasswd/

 

its still not working :(

 

Share this post


Link to post
Share on other sites
  • 0

did you verify that files from /etc/apache2/sites-enabled/ are being included in the apache.conf?

Share this post


Link to post
Share on other sites
  • 0

Don't know then. Would need to check the server, most likely some config issue, if you want, you can PM me the ip and root-credentials and I'll take a look

Share this post


Link to post
Share on other sites
  • 0

Don't know then. Would need to check the server, most likely some config issue, if you want, you can PM me the ip and root-credentials and I'll take a look

 

Ok, Thank you a lot. What could be the problem with the server?  I use a ec2 amazon web service instance with ubuntu 14.04.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By where2go
      Hi there,
      I'm running Froxlor 0.9.38.7 (DB: 201612110) and when executing php /var/www/froxlor/scripts/froxlor_master_cronjob.php I'm getting "Froxlor does not seem to be installed yet - skipping cronjobroot".
      My /etc/cron.d/froxlor file looks like
      # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null 5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --used_tickets_reset 1> /dev/null 7 0 1 * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --ticketarchive 1> /dev/null 10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null 15 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null  
      Cron is running as /usr/sbin/cron -f PHP Version5.6.30-0+deb8u1 Debian 8.9 Apache/2.4.10 Zend OPcache 7.0.6-dev System log is clean. Froxlor dashboard says: Outstanding cron-tasks: There are currently no outstanding tasks for Froxlor I do not have this php file: FROXLOR_INSTALL_DIR . '/lib/userdata.inc.php' as indicated here https://github.com/Froxlor/Froxlor/blob/master/lib/cron_init.php  

       
      I'd appreciate any help with this.
      Thanks a lot!
       
    • By nurtext
      Moin,
      anscheinend schlägt Let's Encrypt bei Subdomains fehl, weil es gerne auch eine weitere "www"-Subdomain an die bestehende hängen würde. Siehe Log:
      root@meine-tolle-domain:/root# /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating hilfe.meine-tolle-domain.de [information] Adding SAN entry: hilfe.meine-tolle-domain.de [information] Adding SAN entry: www.hilfe.meine-tolle-domain.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Creating new account key [information] letsencrypt Starting new account registration [information] letsencrypt Sending registration to letsencrypt server [information] letsencrypt Sending signed request to /acme/new-reg [information] letsencrypt New account registered. [information] letsencrypt Accepting lets encrypt Terms of Service [information] letsencrypt Accepting agreement at URL: https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf [information] letsencrypt Sending signed request to /acme/reg/18369331 [information] letsencrypt Lets encrypt Terms of Service accepted [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for hilfe.meine-tolle-domain.de [information] letsencrypt Token for hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY and should be available at http://hilfe.meine-tolle-domain.de/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/ZXmZ4SU2Oy0__ipk-ihaPtDq39OyNfBKAEHzfMvmO5U/1478709781 [information] letsencrypt Verification pending, sleeping 1s [information] letsencrypt Verification ended with status: valid [information] letsencrypt Requesting challenge for www.hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for www.hilfe.meine-tolle-domain.de [information] letsencrypt Token for www.hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE and should be available at http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE [error] letsencrypt Please check http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE): failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232} [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA/1478709934 [information] letsencrypt Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for hilfe.meine-tolle-domain.de: Verification ended with error: {"identifier":{"type":"dns","value":"www.hilfe.meine-tolle-domain.de"},"status":"invalid","expires":"2017-07-11T15:20:54Z","challenges":[{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:connection","detail":"DNS problem: NXDOMAIN looking up A for www.hilfe.meine-tolle-domain.de","status":400},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709934","token":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","keyAuthorization":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE.lzkNGm6yCkkELPqgqQ8h9v-MfPi-5gRkb9yf76fy86s","validationRecord":[{"url":"http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","hostname":"www.hilfe.meine-tolle-domain.de","port":"80","addressesResolved":[],"addressUsed":"","addressesTried":[]}]},{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709935","token":"S1kgT_jIG8reMxRvGEf9niDf4WIiPyr5XslKbIFQ6eY"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709936","token":"mp8J-ChoyV2gMPQyuJQoZaRlH2ePfcBYcb0v-cZ1zmU"}],"combinations":[[1],[0],[2]]} [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid root@meine-tolle-domain:/root/ Irgendwie sieht das für mich nicht gewollt aus, oder? ?
    • By MrMonkeyMan
      I am new to froxlor and i was wondering how do i create a cronjob for my server
    • By Stephan
      Hallo, ich habe vor ein paar Tagen auf die neueste Version geupdatet und alles wie beschrieben eingestellt.
      Allerdings arbeitet es meine Cronjobs nicht mehr ab. Bei Cronjob-Einstellungen zeigt es mir noch jeweils das Datum von Dezember bzw "01.01.1970 00:00" an. Es passiert auch nichts, wenn ich den Cron in der Kommandozeile von Hand ausf?hre mit  /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force 
       
      Unter /var/log habe ich nach Datum sortiert, finde aber keine Error-Log oder ?hnliches was zur Uhrzeit usw passt.
      Es passiert einfach nichts.

      Ich bin gerade etwas ratlos. Mein System ist: Linux RNMV001 3.2.0-4-amd64 #1 SMP Debian 3.2.63-2+deb7u1 x86_64
       
      K?nnt ihr mir bitte weiterhelfen?
    • By webass
      Hi,
      ich habe einen Kundenaccount.
      Da sollte Wordpress drin installiert werden.
       
      Die php settings je Domain ?berschreiben ja sicherlich /etc/php5/fpm/php.ini, daher habe ich dort das memory limit passend gemacht und gespeichert.
      Dann hab ich gewartet und gewartet und der cronjob lief nicht durch. Dann habe ich die config files erneuert und es hat immer noch nichts gebracht, die Werte wurden nicht geschrieben, der cronjob umfasst wohl bei mir diesen Kunden nicht.
       
      Dann habe ich ?berpr?ft wie es im Cron aussieht und da ich die Config ja anfangs gemacht hatte, sieht der normal aus.
      Woran k?nnte das denn noch liegen?
      Ich musste den Cron dann mit --force laufen lassen und konnte erst danach Worpdress fertig installieren.
       
      Alles ist in Sachen cron settings ist auf default, nichts, nie ge?ndert.
      Hier mal froxlor cronjob:
      # cat /etc/cron.d/froxlor # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php Hilfe...
      m?chte, dass es automatisch geht. (Hab auch schon gegoogelt und hier gesucht)
      LG
      Andre
×
×
  • Create New...