Jump to content
Froxlor Forum
  • 0
C0kkie

Sender address rejected: not logged in (in reply to RCPT TO command))

Question

Hey Leute,

 

ich habe mir heute mal froxlor installiert und soweit funktioniert auch alles, jedoch beim anlegen eines kundes wird die email an manche anbieter nicht versendet.

 

Apr 22 11:07:31 hosting postfix/smtp[1243]: F3BCF1041143: to=<info@elec***.de>, relay=vweb10.nitrado.net[194.169.211.8]:25, delay=0.21, delays=0.03/0/0.15/0.02, dsn=5.7.1, status=bounced (host vweb10.nitrado.net[194.169.211.8] said: 553 5.7.1 <a**.de>: Sender address rejected: not logged in (in reply to RCPT TO command))
 
 
hat da jemand eine Idee?
 
smtpd_sender_restrictions = permit_mynetworks,
#         reject_sender_login_mismatch,
 
 
geht auch nicht

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Bitte google und forensuche benutzen...das gab es schon etliche male

Share this post


Link to post
Share on other sites
  • 0

Ich kann nur sagen, dass das mit dem "Standard-Setup" und den "Standard-Configs" von Froxlor problemlos funktioniert...

Share this post


Link to post
Share on other sites
  • 0

Durch das verschleiern der Domains wird es leider oftmals etwas schwierig bei so etwas zu helfen.

 

Tausch am besten mal die Domains durch dummys aus (also z.b. abc.de oder 123.de) und gib an welche Domain nun bei dir liegt und welche Extern.

 

Ich kann dir aber jetzt schon sagen: Der Externe Server lehnt die Mail ab, weil denen deine (Ab- ) Sender Domain nicht passt. Da kannst du bei dir so viele Permits rein machen wie du willst, das wird sich nicht ändern. :P

Share this post


Link to post
Share on other sites
  • 0

Durch das verschleiern der Domains wird es leider oftmals etwas schwierig bei so etwas zu helfen.

 

Tausch am besten mal die Domains durch dummys aus (also z.b. abc.de oder 123.de) und gib an welche Domain nun bei dir liegt und welche Extern.

 

Ich kann dir aber jetzt schon sagen: Der Externe Server lehnt die Mail ab, weil denen deine (Ab- ) Sender Domain nicht passt. Da kannst du bei dir so viele Permits rein machen wie du willst, das wird sich nicht ändern. :P

 

Apr 22 11:07:31 hosting postfix/smtp[1243]: F3BCF1041143: to=<info@abc123.de>, relay=vweb10.nitrado.net[194.169.211.8]:25, delay=0.21, delays=0.03/0/0.15/0.02, dsn=5.7.1, status=bounced (host vweb10.nitrado.net[194.169.211.8] said: 553 5.7.1 <admin@abc.de>: Sender address rejected: not logged in (in reply to RCPT TO command))

 

Ich hab als Absendet halt admin@abc.de angegeben und die kundendaten sollten an info@abc123.de

Share this post


Link to post
Share on other sites
  • 0

Das beantwortet nicht meine frage...ist "abc.de" in der "Domainliste" von froxlor?

Share this post


Link to post
Share on other sites
  • 0

Müsste ich nicht die Domain dann einen Kunden zuweisen?

 

Und dann hab ich grad noch versucht einen mail account anzulegen, weiterleitung geht aber mailclient geht nicht

 

Apr 27 10:06:16 hosting postfix/smtpd[14021]: connect from ****e[91.8.1****]
Apr 27 10:06:16 hosting dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=*****, lip=1***.165, session=<wCH0n>
Apr 27 10:06:16 hosting postfix/smtpd[14021]: improper command pipelining after EHLO from****e[91.8.1****]: QUIT\r\n
Apr 27 10:06:16 hosting postfix/smtpd[14021]: disconnect from ****e[91.8.1****]
 
Wo aktivier ich nochmal plaintext? Und ist das nicht irgendwie ein sicherheitsrisiko oder so?

Share this post


Link to post
Share on other sites
  • 0

Nein diese domain sollte eben keinem Kunden zugewiesen sein...darum stell ich die frage doch.

 

tut mir leid, aber ich wiederhole es gerne nochmal: mit den standard-configtemplates von uns geht das problemlos, k.A. was du da treibst. Und ja, plaintext müsstest du entsprechend in der dovecot-config erlauben und ja das ist irgendwie ein sicherheitsrisiko, deswegen ist es ja default OFF

Share this post


Link to post
Share on other sites
  • 0

*augenroll* diese domain soll eben nicht angelegt sein, ich wollte nur wissen ob du das getan hast...anscheinend dann wohl nicht, dann ist doch alles gut

Share this post


Link to post
Share on other sites
  • 0

Ah ok gut :D ja keine ahnung, hab wiegesagt die configs so übernommen wie sie bei froxlor aufgelistet sind, dann versuch ichs mal mit dem smtp login

Share this post


Link to post
Share on other sites
  • 0

So hab mir nun zertifikat geholt.

 

SSL dann einfach so?

 

## TLS for outgoing mails from the server to another server
smtp_tls_security_level = may
smtp_tls_note_starttls_offer = yes
## TLS for incoming connections (clients or other mail servers)
smtpd_tls_security_level = may
smtpd_tls_cert_file = /etc/ssl/server/****.crt
smtpd_tls_key_file = /etc/ssl/server/***.key
smtpd_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
 
und halt plaintext wieder aus?

Share this post


Link to post
Share on other sites
  • 0

Also ich hab mir nun einen Kundenaccount gemacht, domain angelegt, email account mit ssl eingerichet, dann mail client eingerichtet, test email versendet an @web.de <-- geht

an eine andere email von mir, wo die email noch bei nitrado gehostet wird und es kommt imernoch:

 

<info@abc123>: host vweb10.nitrado.net[194.169.211.8] said: 553 5.7.1

<iinfo@abc.de>: Sender address rejected: not logged in (in reply to RCPT
TO command)

 

https://forum.froxlor.org/index.php/topic/13367-enable-auth-on-smtp/

 

hab ich jetzt noch nicht gemacht, kann das auch bei dem Problem helfen?

 

Apr 27 11:49:05 hosting dovecot: imap-login: Login: user=<info@abc123.de>, method=PLAIN, rip=91.8.125.39, lip=151.80.***5, mpid=1226, TLS, session=<t1bCH0n>
Apr 27 11:49:17 hosting postfix/smtpd[1227]: connect from ***pconnect.de[91.8.125.39]
 
angemeldet bin ich ja, seht ihr ja dort

Share this post


Link to post
Share on other sites
  • 0

<iinfo@abc.de>: Sender address rejected: not logged in (in reply to RCPT TO command)

 

Ich seh da ein zweites i am anfang...mal die settings checken?

Share this post


Link to post
Share on other sites
  • 0

<iinfo@abc.de>: Sender address rejected: not logged in (in reply to RCPT TO command)

 

Ich seh da ein zweites i am anfang...mal die settings checken?

 

war nur ein fehler beim kopieren :D

 

hats evtl. was mit:

 

# /etc/aliases
mailer-daemon: postmaster
postmaster: root
nobody: root
hostmaster: root
usenet: root
news: root
webmaster: root
www: root
ftp: root
abuse: root
noc: root
security: root
 
# change this to a valid e-mail address you can access
root:               root@abc.de
 
 
 
zutun? Inwiefern muss ich die mail ersetzen?
hab auch grad nochmal die main.conf neu gemacht aber hilft auch nichts

Share this post


Link to post
Share on other sites
  • 0

Also, du verschickst von abc.de an abc123.de richtig? Liegt die abc.de den wirklich bei dir, oder nimmst du nur als Absender? Liegt die vielleicht auch beim Empfänger?

 

Soweit mir bekannt bietet Nitrado nur Webhosting an, der vweb10.nitrado.net als Empfänger liegt also Extern und hat an sich nichts mit deinem Server zutun richtig?

Share this post


Link to post
Share on other sites
  • 0

Genau. Den mx dns eintrag von abc.de hab ich auf den server geleitet, wo froxlor liegt - der haupt dns eintrag von abc.de wird auf einen anderen server geleitet.

abc123.de ist mein Emailpostfach was momentan noch bei nitrado.de liegt

NItrado bietet webhosting an, ja und auch für emails - sie setzen selber froxlor ein :D

genau vweb10.nitrado.net ist der webserver von nitrado

 

der mailversand von den kundendaten geht btw mittlerweile :D

is nur noch das problem, mails vom email client zu versenden, der fehler mit sender address rejected

Share this post


Link to post
Share on other sites
  • 0

Okay, die abc123.de ist aber auch Korrekt mit E-Mail und Postfach bei Nitrado eingerichtet oder? Weil wenn das der Fall ist, weis ich echt nicht mehr weiter :D

Share this post


Link to post
Share on other sites
  • 0

also wenn abc.de auf die kiste zeigt, dann sollte die email adresse da aber nicht in der /etc/aliases auftauchen...das looped ja. Nimm da bitte was externes (gmx, gmail, whatever)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...