Jump to content
Froxlor Forum
d00p

Release candidate 0.9.35-rc1 - Let's Encrypt, auto-update and more

Recommended Posts

Dear Froxlor Community,
 
we are proud to announce the first release candidate for our upcoming version 0.9.35 which includes some new kick-ass features.
 
Support for Let's Encrypt
 
Many of you were waiting for this one for quite some time now. We finally managed to include ssl-certificate generation via Let's Encrypt directly within froxlor's interface. It's easy as a click on "use let's encrypt" when adding/editing a domain. The certificate will be created and renewed automatically.
Please keep in mind that this feature is in BETA state.
 
VHost-Templates
 
Froxlor now provides an editor for custom virtual-host configurations for you. Whenever you have special needs for specific domains or you want to have full control over the content of the generated virtual-hosts - this feature is what you want :-)

This feature was not fully operational and will not be included in the final version of 0.9.35
 
Multiple default IP addresses
 
You can now select multiple IP addresses you want to be set as default for new domains in the System-settings. Until now it was only possible to define one default IP address. This is especially handy if your server has an IPv4 and IPv6 address for example.
 
Auto-Update
 
As of this release candidate, you will be able to update to future releases from within the webinterface. It will automatically download the latest archive and extract it - and you're done - and yes, you can use that already to update to the final release of 0.9.35 when it's released.
 
Menu structure
 
We re-organized some menu-items to reflect their corresponding affinity. The former "Server" category is now called "System". PHP related settings / information are now in their own category. Also "IPs and Ports" and "Recalculate resource usage" were put in the "Resources" category (where they belong).
 
Set MYSQL_PASSWORD on configuration templates
 
It is now possible to set the MYSQL_PASSWORD value (via JavaScript, only client-side) when configurating services with our templates. This eases the process and you do not need to search and replace for MYSQL_PASSWORD in the config files again (also you are likely to not miss any of the occurences).
 
System-Log for customer
 
The customers are now able to see actions related to their account in the menu-item "System-Log", depending on the log-level set in the settings. This is also very helpful for response-messages from Let's Encrypt.
 
Changes in 0.9.35-rc1:
 
You can see all (minor) changes in our bugtracker at http://redmine.froxlor.org/versions/68

Download: 0.9.35-rc1

Note: Gentoo users might use the 9999 ebuild for a live-version. There will be no Debian packages for release-candidates.

Visit http://www.froxlor.org or join our IRC channel #froxlor on irc.freenode.net.

Thank you,
d00p

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By d00p
      Dear Froxlor Commuity,
      finally - the first release candidate of our new API based version 0.10.0! A lot of work has gone into this, many internal changes (you might miss any frontend-changes, but be patient...) most importantly the API backend which not only is used by froxlor frontend itself but can also be uses from within your website/scripts/etc.
      Froxlor now uses composer to include some of its requirements like phpMailer, Logger, IdnaConvert and TwoFactorAuth libraries.
      Here are some of the new features besides API that found their way in:
      - 2FA / TwoFactor Authentication for accounts - MySQL8 compatibility - new implementation of Let's Encrypt (acme.sh) - customizable error/access log handling for webserver (format, level, pipe-to-script, etc.) - lots and lots of bugfixes and small enhancements You can see all changes on Github at https://github.com/Froxlor/Froxlor/compare/0.9.40.1...0.10.0-rc2
      Download: 0.10.0-rc2

      Note: There will be no Debian packages for release-candidates.

      Visit http://www.froxlor.org or join our IRC channel #froxlor on irc.freenode.net.

      Thank you,
      d00p
    • By Yahal
      Hallo,
      ich bin gerade dabei alte Kundenkonten in meiner Organisation zu überprüfen und habe jetzt mit Ärger festgestellt, dass es scheinbar bei Älteren Kundenkonto, erstellt vor 2017, es reihenweise nicht mehr möglich ist, die Domaineinstellungen zu ändern, noch Let's Encrypt zu aktivieren.
      Das System läuft auf Debian 8.11 mit dem Froxlor Apache/2.4.10 (Debian), PHP 5.6.38-0+deb8u1, MySQL 5.5.62-0+deb8u1 , CGI-FCGI , 3.16.0-7-amd64 (x86_64) , 0.9.40.1 (DB: 201809280)
      Beim Update wurden wieder keine Fehler angezeigt, daher weiß ich leider nicht wo nach ich genau suchen soll.
      Des Weiteren sieht es so aus als wäre entweder bei einigen Domains, das Let's encrypt Zertifikat verloren gegangen, oder es wurde nie erfolgreich erstellt. In den Einstellungen der entsprechenden Domains, ist Let's encrypt angehakt, aber es ist kein SSL-Zertifikat vorhanden.
      Da Froxlor jetzt scheinbar ACME v2 unterstützt, über diesen Weg, für alle vorhanden Domains ein Let's encrypt Zertifikat zu erzwingen?
       

    • By megoo
      Hallo, ich habe in Problem mit dem Einrichten von SSL via  Let's Encrypt. Ich nutze
      froxlor 0.9.39.5-1
      Apache/2.2.22 (Debian)
      Ich möchte für alle Domains SSL mittels Let's Encrypt aktivieren. 
      domain1 dafür entsprechend konfigiert. Funktioniert alles.
      domain2 genauso wie Domain1 konfiguriert (gleiche IP:443, Benutze Let's Encrypt an, ServerAlias-Angabe für Domain: www), der Zugriff via https gibt allerdings den Fehler aus: SSL_ERROR_BAD_CERT_DOMAIN
      Der Browser sagt, das Zertifikat gilt nur für folgende Namen: domain1
      domain2 nutzt also das falsche Zertifikate. 
      Die Debug Ausgabe des froxlor master cronjob sagt:
      [Thu Jul 12 13:28:05 2018] [warn] VirtualHost meineip:443 overlaps with VirtualHost meineip:443, the first has precedence, perhaps you need a NameVirtualHost directive
      Ich hab mir die erzeugten conf Dateien in /etc/apache2/sites-enabled angesehen, dort ist keine NameVirtualHost Anweisung erhalten. Diese eingefügt, Apache neu gestartet, funktioniert alles. Nun überschreibt froxlor diese Einstellung wieder, folglich, wieder das oben beschriebene Problem.
      Wie/wo kann ich das in Froxlor einstellen, global? Oder muss ich für jede Domain eine "Eigene vHost-Einstellungen" festlegen?
      Auf einem anderen Server mit Apache 2.4 und der gleichen Vorgehensweise hat alles problemlos mit einer IP und über 10 Domains funktioniert. Und dort steht keine NameVirtualHost directive in den conf Dateien.
    • By Keon
      Hallo alle miteinander,
       
      ich bin derweil dabei mir Froxlor auf einem CentOS7 System zum laufen zu bringen. Hier mal kurz ein kleiner Überblick wie ich aktuell stehe:
      SSH Port ändern, sudo User, NTP, EPEL Release, FirewallD für http, https, ssh mit neuem Port frei, fail2ban für SSH Apache, MariaDB, PHPMyAdmin, mod_ssl inkl. config und self signed cert, Froxlor Grundinstallation, Webserver und SSL Einstellungen Admin Menü, (Pfade, reload Script etc.) IP/Port 443 hinzugefügt, Konfiguration -> CentOS -> sonstiges -> cronjob for froxlor Ebenso habe ich - auch wenn unter "Konfiguration" für "CentOS" nicht vorhanden, die acme.conf angelegt  
      Kommen wir zur Frage:
      Wie bekomme ich hin, dass ich folgende Einstellung setzen kann:
       
      Habe ich noch etwas vergessen? Etwas grundlegendes? Bin normalerweise seit Debian Etch bis Jessie gewöhnt - sammle grad die ersten Erfahrungen mit Froxlor & CentOS nach 2 Jahren Pause aus der Informatik.
       
      Beste Grüße




×
×
  • Create New...