Jump to content
Froxlor Forum
  • 0

[solved] Kein Zugriff via Browser auf symbolisch verlinkte Froxlor-Instanz


Question

Hey, 

 

ich habe mein Heimverzeichnis /home/kenneth/ mit den Ordnern /var/www/ und /var/customers/ symbolisch verlinkt, um nicht den Root-User nutzen zu müssen. 

Funktioniert im Grunde ganz gut, bis Froxlor das erste Mal die Apache Sites-Enabled Konfigurationen neu schreibt. 

Ab dann komme ich via Browser nicht mehr auf den Document-Root /var/www (Im Regelfall direkt Zugriff auf die IP-Adresse vom Browser) und daher auch nicht mehr auf Froxlor. Kunden-Domains funktionieren allerdings noch. 

Es kommt halt die Apache2-Typische 403 Forbidden Meldung.

# 10_froxlor_ipandport_127.0.0.1.80.conf
# Created 03.02.2016 19:45
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

<VirtualHost 127.0.0.1:80>
DocumentRoot "/home/kenneth/srv/webserver/www"
 ServerName froxlor.beispiel.de
</VirtualHost>

Statt Localhost und beispiel.de natürlich richtige Werte (Hab etwas bedenken was grade die Sicherheit angeht :ph34r: )

 

Dem DocumentRoot ist zu entnehmen, dass Froxlor dem symbolischem Link bis in mein Heimverzeichnis gefolgt ist. Einhergehend damit kann ich nun auch Froxlor nicht erreichen, weil der Zugriff von apache2 geblockt wird. 

Wenn ich den DocumentRoot nun manuell auf /var/www setze, geht wieder alles. (Die Nachricht oben ist natürlich unmissverständlich, weshalb Froxlor meine Änderung natürlich schnell überschreibt)

Bei der Kunden-Domain, wo alles funktioniert, habe ich nicht den Pfad zum Heimverzeichnis eingegeben sondern eben auf /var/customers/webs/Username/example.com/root.

So steht es dann auch in der Apache-Konfiguration.

 

Was kann ich nun tun, damit das mit den symbolischen Links funktioniert? 

Noch ein paar Infos:

  • Debian 8.3 - 64Bit 
  • apache2.4.10 (Froxlor-Einstellungen speziell für diese Version sind eingeschaltet)
  • Froxlor 0.9.34.2

 

Vielen Dank schon mal für eure Hilfe  :)

~ Kenneth

 

 

 

Edit

 

Entschuldigt meine Blindheit, habs hinbekommen  :unsure:

Für nachfolgende Hilfesuchenden zu diesem Thema:

 

Unter IPs und Ports einfach die IP-Einstellungen ändern und bei Benutzerdefinierter Docroot den /var/www Pfad eingeben. Nun wird dem symbolischem Link nicht mehr gefolgt und somit ist Froxlor auch wieder erreichbar. 
Schön dass es so eine Einstellung gibt  :)

 

Daher ist das Thema, für mich, erledigt. Trotzdem danke. 

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By Marcel -//- AdSoleWare
      Hello.
      I manually installed Froxlor on Debian 8 and tried setting up. i installed php 7.3 in as it was the only missing point. i restarted apache2 and now it wont start. I need help
       
      Error Log:
       
    • By Michael Groß
      Hallo,
      nachdem ich meinen Froxlor-Server neu aufgesetzt habe, habe ich nun ein anderes komisches Problem.
      Ich habe die Konfigurationsschritte vollständig durchgeführt - sicherheitshalber auch zuerst "automatisch" durchführen lassen und danach noch einmal verifiziert.
      Lege ich nun einen Kunden an (http://test.computer-stube.com), verweist dies auf den Root des Servers.
      Schaue ich in die vHost-Datei, steht dort folgendes:
      # 29_froxlor_normal_vhost_test.computer-stube.com.conf # Created 07.02.2020 16:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:80> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> # 29_froxlor_ssl_vhost_test.computer-stube.com.conf # Created 07.02.2020 17:26 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 (SSL) - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:443> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder off SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/certs/apache.crt SSLCertificateKeyFile /etc/ssl/private/apache.key <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=0" </IfModule> DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> Also an sich ist die richtige Konfiguration hinterlegt.
      Im Cron ist folgendes konfiguriert:

      # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null 5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null 10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null Auch das manuelle Ausführen mittels "
      php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force bringt bei mir leider keinen Erfolg.
      Die Ausgabe vom debug ist wie folgt:
      root@lx001:/etc/apache2/sites-enabled# php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting/renewing Let's Encrypt certificates [information] No new certificates or certificates due for renewal found [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:80 [notice] 178.63.105.174:80 :: namevirtualhost-statement no longer needed for apache-2.4 [debug] 178.63.105.174:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:443 [debug] 178.63.105.174:443 :: inserted vhostcontainer [information] apache::createVirtualHosts: creating vhost container for domain 3, customer test [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi [notice] Creating passwd file [notice] Writing 1 entries to passwd file [notice] Succesfully wrote passwd file [notice] Creating group file [notice] Writing 1 entries to group file [notice] Succesfully wrote group file [notice] Creating shadow file [notice] Writing 1 entries to shadow file [notice] Succesfully wrote shadow file [notice] Checking system's last guid  
      Ich fühle mich gerade echt dämlich, kann ja eigentlich nicht so schwer sein, da es eigentlich ja alles nur "Copy+Paste" ist
      Das Endverzeichnis wurde jedoch korrekt angelegt:
      root@lx001:/var/customers/webs# ls test root@lx001:/var/customers/webs# cd test root@lx001:/var/customers/webs/test# ls index.html webalizer Ich habe zusätzlich zur "Standardkonfiguration" noch libnss-extrausers und FCGID  eingerichtet, da ich ältere PHP Versionen benötige.
      Grüße
      Michael
    • By tmuecksch
      Guten Tag,
      ich habe einen Debian 9 Server mit Froxlor und Apache2 am laufen. Wenn ich mit dem Kunden FTP Zugang Dateien hochlade haben diese Ordnungsgemäß das ownership 10000:10000.
      Wenn jedoch in der PHP-Weboberfläche eine Datei hochgeladen wird, wird diese mit dem ownership www-data:www-data hochgeladen. Liegt hier ein Konfigurationsfehler vor oder ist das Verhalten sogar so gewünscht? Ich kann den Fehler leider nicht entdecken. Das Problem ist nur, dass das PHP-Script dann eine Permission Denied Fehlermeldung wirft, wenn versucht wird die Datei zu lesen.
       
      Liebe Grüße
      tmuecksch
    • By LostNIL
      Greetings,
      I have Froxlor installed with PHP7.2 and need to install/enable PHP7.2-fpm. I've reviewed the wiki, The Froxlor YouTube video on the subject, and reviewed/completed the instructions within the Panel > Configuration > DB Jessie > Other > FPM and am having difficulties getting the panel to work with FPM. 
      All available instructions are written for PHP5 and when I complete the instructions and substitute PHP7.2, when the panel generates configurations there are syntax errors and the websites go down. 
       
      Does anyone have any pointers or updated instructions on enabling FPM/PHP7+ with Froxlor. 
    • By tmuecksch
      Hallo liebe Community.
      Ich habe einen neuen Debian 9.4 Server aufgesetzt und Froxlor installiert (gemäß Wiki). Nach Durchführung aller notwendigen Konfigurationsschritte hat Froxlor wie gewohnt funktioniert. Anschließend habe ich ein SSL Zertifikat hochgeladen und in Froxlor, unter Einstellungen > SSL-Einstellungen  habe ich SSL aktiviert und die Pfade Zertifikatfiles angegeben. Anschließend habe ich eine einen neuen Eintrag unter IPs und Ports konfiguriert mit Port 443.
      Nach Generierung der neuen Config Files durch Froxlor ist folgender Fehler aufgetreten, der Apache nicht mehr starten lässt.
      May 17 09:50:14 X.de apachectl[1516]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address X:443 May 17 09:50:14 X.de apachectl[1516]: no listening sockets available, shutting down  
      Also würde ja nahe liegen, dass der Socket in Verwendung ist (was bei einem frischen Debian doch unwahrscheinlich ist)
      ➜ ~ netstat -tlpn | grep 443 ➜ ~ Der Port ist, wie wir sehen nicht in Verwendung. 
       
      ➜ ~ grep -r "Listen" /etc/apache2/ /etc/apache2/sites-enabled/10_froxlor_ipandport_X.443.conf:Listen X:443 /etc/apache2/ports.conf:Listen 80 /etc/apache2/ports.conf: Listen 443 /etc/apache2/ports.conf:# Listen 443 Man könnte nun vermuten, dass die beiden Listen 443 Einträge in der ports.conf den Fehler verursachen. Doch weit gefehlt. Wenn ich die beiden Einträge entferne ändert das nichts.
       
      Der Fehler lässt sich nur beheben wenn ich in der folgenden Datei die Zeile "Listen X:443" manuell lösche:
      # 10_froxlor_ipandport_X.443.conf # Created 17.05.2018 09:49 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Listen X:443 <VirtualHost X:443> DocumentRoot "/var/www/" ServerName Z.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/letsencrypt/live/Z.de/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/Z.de/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/Z.de/chain.pem </VirtualHost>  
      Wie kann das sein? Wieso generiert Froxlor eine nicht funktionierende VHost Config? Habe ich vielleicht was falsch gemacht? Ist der Fehler schon bekannt?
       
      P.S: Meine IP Adresse und Domain habe ich durch Großbuchstaben ersetzt.
       
×
×
  • Create New...