Jump to content
Froxlor Forum
  • 0

Apache2 not autotsarting after upgrade to Debian Jessie


llucps

Question

Hi everyone,

 

I recently upgraded my debian wheezy server to jessie right after I also upgraded Froxlor to the last version (0.9.34-1) and I have a problem that I couldn't find out the solution yet.

 

The problem is that the apache2 service doesn't start automatically when the server is rebooted, but it works if I do run the command (/etc/init.d/apache2 start) manually with root.

 

I checked the apache2 log file and it gives an error of bad user name "squeaky"... please note that squeaky is one of the virtual users created by Froxlor.

? apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
   Active: failed (Result: exit-code) since Mon 2015-09-21 13:31:09 CEST; 18s ago
  Process: 333 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Sep 21 13:31:09 xxxxxxx.com apache2[333]: Starting web server: apache2 failed!
Sep 21 13:31:09 xxxxxxx.com apache2[333]: The apache2 configtest failed. ... (warning).
Sep 21 13:31:09 xxxxxxx.com apache2[333]: Output of config test was:
Sep 21 13:31:09 xxxxxxx.com apache2[333]: [Mon Sep 21 13:31:09.323851 2015] [alias:warn] [pid 392] AH00671: The Alias directive in /etc/apache2/conf.d/owncloud....lier Alias.
Sep 21 13:31:09 xxxxxxx.com apache2[333]: AH00543: apache2: bad user name squeaky
Sep 21 13:31:09 xxxxxxx.com apache2[333]: Action 'configtest' failed.
Sep 21 13:31:09 xxxxxxx.com apache2[333]: The Apache error log may have more information.
Sep 21 13:31:09 xxxxxxx.com systemd[1]: apache2.service: control process exited, code=exited status=1
Sep 21 13:31:09 xxxxxxx.com systemd[1]: Failed to start LSB: Apache2 web server.
Sep 21 13:31:09 xxxxxxx.com systemd[1]: Unit apache2.service entered failed state.

Here you have my apache2.conf file:

# This is the main Apache server configuration file.  It contains the
# configuration directives that give the server its instructions.
# See http://httpd.apache.org/docs/2.2/ for detailed information about
# the directives and /usr/share/doc/apache2-common/README.Debian.gz about
# Debian specific hints.
#
#
# Summary of how the Apache 2 configuration works in Debian:
# The Apache 2 web server configuration in Debian is quite different to
# upstream's suggested way to configure the web server. This is because Debian's
# default Apache2 installation attempts to make adding and removing modules,
# virtual hosts, and extra configuration directives as flexible as possible, in
# order to make automating the changes and administering the server as easy as
# possible.

# It is split into several files forming the configuration hierarchy outlined
# below, all located in the /etc/apache2/ directory:
#
#    /etc/apache2/
#    |-- apache2.conf
#    |    `--  ports.conf
#    |-- mods-enabled
#    |    |-- *.load
#    |    `-- *.conf
#    |-- conf.d
#    |    `-- *
#     `-- sites-enabled
#         `-- *
#
#
# * apache2.conf is the main configuration file (this file). It puts the pieces
#   together by including all remaining configuration files when starting up the
#   web server.
#
#   In order to avoid conflicts with backup files, the Include directive is
#   adapted to ignore files that:
#   - do not begin with a letter or number
#   - contain a character that is neither letter nor number nor _-:.
#   - contain .dpkg
#
#   Yet we strongly suggest that all configuration files either end with a
#   .conf or .load suffix in the file name. The next Debian release will
#   ignore files not ending with .conf (or .load for mods-enabled).
#
# * ports.conf is always included from the main configuration file. It is
#   supposed to determine listening ports for incoming connections, and which
#   of these ports are used for name based virtual hosts.
#
# * Configuration files in the mods-enabled/ and sites-enabled/ directories
#   contain particular configuration snippets which manage modules or virtual
#   host configurations, respectively.
#
#   They are activated by symlinking available configuration files from their
#   respective *-available/ counterparts. These should be managed by using our
#   helpers a2enmod/a2dismod, a2ensite/a2dissite. See
#   their respective man pages for detailed information.
#
# * Configuration files in the conf.d directory are either provided by other
#   packages or may be added by the local administrator. Local additions
#   should start with local- or end with .local.conf to avoid name clashes. All
#   files in conf.d are considered (excluding the exceptions noted above) by
#   the Apache 2 web server.
#
# * The binary is called apache2. Due to the use of environment variables, in
#   the default configuration, apache2 needs to be started/stopped with
#   /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not
#   work with the default configuration.


# Global configuration
#

#
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the LockFile documentation (available
# at <URL:http://httpd.apache.org/docs/2.2/mod/mpm_common.html#lockfile>);
# you will save yourself a lot of trouble.
#
# Do NOT add a slash at the end of the directory path.
#
#ServerRoot "/etc/apache2"

#
# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#
#LockFile ${APACHE_LOCK_DIR}/accept.lock
Mutex file:${APACHE_LOCK_DIR} default

#
# PidFile: The file in which the server should record its process
# identification number when it starts.
# This needs to be set in /etc/apache2/envvars
#
PidFile ${APACHE_PID_FILE}

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 5

##
## Server-Pool Size Regulation (MPM specific)
##

# prefork MPM
# StartServers: number of server processes to start
# MinSpareServers: minimum number of server processes which are kept spare
# MaxSpareServers: maximum number of server processes which are kept spare
# MaxClients: maximum number of server processes allowed to start
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule mpm_prefork_module>
    StartServers          5
    MinSpareServers       5
    MaxSpareServers      10
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

# worker MPM
# StartServers: initial number of server processes to start
# MinSpareThreads: minimum number of worker threads which are kept spare
# MaxSpareThreads: maximum number of worker threads which are kept spare
# ThreadLimit: ThreadsPerChild can be changed to this maximum value during a
#              graceful restart. ThreadLimit can only be changed by stopping
#              and starting Apache.
# ThreadsPerChild: constant number of worker threads in each server process
# MaxClients: maximum number of simultaneous client connections
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule mpm_worker_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

# event MPM
# StartServers: initial number of server processes to start
# MinSpareThreads: minimum number of worker threads which are kept spare
# MaxSpareThreads: maximum number of worker threads which are kept spare
# ThreadsPerChild: constant number of worker threads in each server process
# MaxClients: maximum number of simultaneous client connections
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule mpm_event_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

# These need to be set in /etc/apache2/envvars
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

#
# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#

AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<Files ~ "^\.ht">
    Require all denied
</Files>

#
# DefaultType is the default MIME type the server will use for a document
# if it cannot otherwise determine one, such as from filename extensions.
# If your server contains mostly text or HTML documents, "text/plain" is
# a good value.  If most of your content is binary, such as applications
# or images, you may want to use "application/octet-stream" instead to
# keep browsers from trying to display binary files as though they are
# text.
#
# It is also possible to omit any default MIME type and let the
# client's browser guess an appropriate action instead. Typically the
# browser will decide based on the file's extension then. In cases
# where no good assumption can be made, letting the default MIME type
# unset is suggested  instead of forcing the browser to accept
# incorrect  metadata.
#
DefaultType None


#
# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., www.apache.org (on) or 204.62.129.132 (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
#
HostnameLookups Off

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log

#
# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel warn

# Include module configuration:
Include mods-enabled/*.load
Include mods-enabled/*.conf

# Include list of ports to listen on and which to use for name based vhosts
Include ports.conf

#
# The following directives define some format nicknames for use with
# a CustomLog directive (see below).
# If you are behind a reverse proxy, you might want to change %h into %{X-Forwarded-For}i
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see the comments above for details.

# Include generic snippets of statements
Include conf.d/

# Include the virtual host configurations:
Include sites-enabled/

# Disable Apache Web Server Signature
ServerSignature Off
ServerTokens Prod

<Directory />
      Options -Indexes
      AllowOverride All
</Directory>

I tried different things like defining statically the User and Group for www-data, www-data instead of gettings the variables set on /etc/apache2/envvars but with no luck.. and I have no clue why this is happening when before with weezy it worked just fine..

 

I only have packages installed from the stable branch... so I didn't have any problem to upgrade to jessie except this one..

 

Anyone can help me with this?

 

Thanks in advance.

Link to comment
Share on other sites

13 answers to this question

Recommended Posts

Yes I did that.. I checked the option "Use modifications for apache 2.4" on settings/apache.

 

I found that if I run "apache2 -V" I get this:

[Mon Sep 21 15:16:00.924565 2015] [core:warn] [pid 2115] AH00111: Config variable ${APACHE_LOCK_DIR} is not defined
[Mon Sep 21 15:16:00.924643 2015] [core:warn] [pid 2115] AH00111: Config variable ${APACHE_PID_FILE} is not defined
[Mon Sep 21 15:16:00.924699 2015] [core:warn] [pid 2115] AH00111: Config variable ${APACHE_RUN_USER} is not defined
[Mon Sep 21 15:16:00.924706 2015] [core:warn] [pid 2115] AH00111: Config variable ${APACHE_RUN_GROUP} is not defined
[Mon Sep 21 15:16:00.924732 2015] [core:warn] [pid 2115] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Mon Sep 21 15:16:00.956456 2015] [core:warn] [pid 2115] AH00111: Config variable ${APACHE_RUN_DIR} is not defined
[Mon Sep 21 15:16:00.957843 2015] [core:warn] [pid 2115] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Mon Sep 21 15:16:00.957880 2015] [core:warn] [pid 2115] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Mon Sep 21 15:16:00.961476 2015] [core:warn] [pid 2115] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Mon Sep 21 15:16:00.961506 2015] [core:warn] [pid 2115] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
AH00526: Syntax error on line 92 of /etc/apache2/apache2.conf:
Invalid Mutex directory in argument file:${APACHE_LOCK_DIR}

It seems like that this variables are not defined.. could it be because the /etc/apache2/envvars is not loaded? If I run "source /etc/apache2/envvars" does the trick and then I running the "apache2 -V" I get this:

ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex fcgid-proctbl: using_defaults
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/lock/apache2" mechanism=fcntl
Mutex mpm-accept: using_defaults
Mutex fcgid-pipe: using_defaults
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
PidFile: "/var/run/apache2/apache2.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
Define: MODSEC_2.5
Define: MODSEC_2.8
User: name="www-data" id=33
Group: name="www-data" id=33

But if I reboot the server.. the variables are not loaded..

 

umm.. I'm really confused.

 

Thanks for your help d00p.

Link to comment
Share on other sites

Alternatively, if you want to do "apache2 -V" you need to do the following:

source /etc/apache2/envvars
/usr/sbin/apache2 -V

(the first command set's the environment variables for apache in your current shell-session, that's why the command will work afterwards)

Link to comment
Share on other sites

eh, please start apache using the init-startscript, it loads the environment variables needed there...

 

Sorry I don't understand what you mean, can you be more specific?

 

I guess all this problems come from the variables not being loaded when the system is booted.. and that's why I get the "bad user name".

 

Thanks!

Link to comment
Share on other sites

Alternatively, if you want to do "apache2 -V" you need to do the following:

source /etc/apache2/envvars
/usr/sbin/apache2 -V

(the first command set's the environment variables for apache in your current shell-session, that's why the command will work afterwards)

 

Thanks, I figured that out later :D see my previous message.

Link to comment
Share on other sites

eh, please start apache using the init-startscript, it loads the environment variables needed there...

 

I guess you mean running apache through /etc/init.d/apache2 start? If so, when I do it manually it works perfectly but not when the system is rebooted.. in that case apache2 doesnt' start and gives the "bad user name" error according to the apache2.log file.

 

And because of this I've no clue where to look or check.

 

Thanks.

Link to comment
Share on other sites

Do you reboot that often? Well we are not responsible for the services start-script, in all the Jessie systems i've setup froxlor this worked without any problems.

 

I usaually never reboot my VPS, but once in a while I have found that it has been rebooted obviously no for me but maybe for the hosting provider due an update or any othe reason.. so when that happens I'm not aware of it and apache2 doesn't start automatically..

 

I mean, it's not the end of the world but it would be great to find the reason why of this and better if I could fix it..

 

I imagine tha start-script runs the same /etc/init.d/apache2 start command.. Do you know where I could check this?

 

Thanks.

Link to comment
Share on other sites

I think your problem is the following:

Your server ist configured with Apache, Suexec, PHP-FCGI or PHP-FPM and NSCD (Name Service Cache Daemon).

 

If you reboot the system and in boot sequence the apache starts before nscd is running, the start fails. That?s why the apache doesnt know the defined user in vhost directive "SuexecUserGroup ..." if nscd is not loaded before apache.

 

To solve this you should add "nscd" in apache init script: /etc/init.d/apache2

Change the line:

# Required-Start:    $local_fs $remote_fs $network $syslog $named

to

# Required-Start:    $local_fs $remote_fs $network $syslog $named nscd

After that edit the init script: /etc/init.d/nscd

The line from

# Required-Start:    $remote_fs $syslog

change to

# Required-Start:    $remote_fs $syslog mysql

These little changes should solve your problem.

 

EDIT:

Another solution is to add restart commands for mysql, nscd, apache2/nginx and php5-fpm to /etc/rc.local

Note: Leave "exit 0" at the end of file, insert BEFORE:

 

/etc/init.d/mysql restart
/etc/init.d/nscd restart
/etc/init.d/php5-fpm restart
/etc/init.d/nginx restart

Last command should be replaced bei apache2 instead of nginx, if you have apache installed.

Link to comment
Share on other sites

Very, very dirty!

 

Better:

 

/etc/init.d/capisuite:

 

#! /bin/sh

### BEGIN INIT INFO

# Provides: capisuite

# Required-Start: $remote_fs $syslog

# Required-Stop: $remote_fs $syslog

# Default-Start: 2 3 4 5

# Default-Stop: 0 1 6

# Short-Description: Capisuite daemon

### END INIT INFO

...

 

-->

 

/etc/insserv/overrides/capisuite:

 

#! /bin/sh

### BEGIN INIT INFO

# Provides: capisuite

# Required-Start: $remote_fs $syslog capiutils

# Required-Stop: $remote_fs $syslog capiutils

# Default-Start: 2 3 4 5

# Default-Stop: 0 1 6

# Short-Description: Capisuite daemon

### END INIT INFO

 

then insserv [-v]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...