Jump to content
Froxlor Forum
  • 0
Davlyin Lafitte

VPS reboot > 502 Bad Gateway

Question

Hello,

 

While I finally got everything working correctly, I rebooted the VPS with the following command: "sudo reboot". But now I'm having an another frustrating issue as I can't access the C.P. anymore "502 Bad Gateway". I've tried to troubleshooting this issue for 2 hours now, with various commands.. I've tried to understand some German posts here without success.

/etc/init.d/php5-fpm start
/usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force
/etc/init.d/nginx restart

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I actually installed PHP-FPM since I've been following a tutorial online, I wasn't aware this was installed on my machine actually until now as weird as it sounds. I didn't follow the following: http://redmine.froxlor.org/projects/froxlor/wiki/HandbookNginx_phpfpm and I simply guess that this is the reason I'm having an error after the reboot. Is that more or less correct ? 

 

After re-installing and following the handbook that covers php-fpm, I'm not having any issues anymore.

 

Sorry for the inconvenience.  

Share this post


Link to post
Share on other sites
  • 0

Bad Gateway mostly means that fpm is Not running. For more we need some logs

Share this post


Link to post
Share on other sites
  • 0
/var/log/php5-fpm.log
[11-Mar-2015 09:41:39] NOTICE: Finishing ...
[11-Mar-2015 09:41:39] NOTICE: exiting, bye-bye!
[11-Mar-2015 09:41:39] NOTICE: fpm is running, pid 3117
[11-Mar-2015 09:41:39] NOTICE: ready to handle connections
[11-Mar-2015 09:49:22] NOTICE: Terminating ...
[11-Mar-2015 09:49:22] NOTICE: exiting, bye-bye!
[11-Mar-2015 09:49:43] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful

[11-Mar-2015 09:49:43] NOTICE: fpm is running, pid 2575
[11-Mar-2015 09:49:43] NOTICE: ready to handle connections
[11-Mar-2015 09:54:57] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful

[11-Mar-2015 10:22:36] NOTICE: Finishing ...
[11-Mar-2015 10:22:36] NOTICE: exiting, bye-bye!
[11-Mar-2015 10:22:36] NOTICE: fpm is running, pid 3040
[11-Mar-2015 10:22:36] NOTICE: ready to handle connections
[11-Mar-2015 10:22:47] NOTICE: Finishing ...
[11-Mar-2015 10:22:47] NOTICE: exiting, bye-bye!
[11-Mar-2015 10:22:47] NOTICE: fpm is running, pid 3075
[11-Mar-2015 10:22:47] NOTICE: ready to handle connections
/var/log/nginx/error.log
2015/03/11 10:14:06 [error] 2894#0: *28 connect() failed (111: Connection refused) while connecting to upstream, client: 83.134.148.97, server: ontweerp.com, request: "GET /froxlor/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:8888", host: "81.4.125.219"
2015/03/11 10:22:40 [error] 2894#0: *31 connect() failed (111: Connection refused) while connecting to upstream, client: 83.134.148.97, server: ontweerp.com, request: "GET /froxlor/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:8888", host: "81.4.125.219"
2015/03/11 10:22:43 [error] 2894#0: *31 connect() failed (111: Connection refused) while connecting to upstream, client: 83.134.148.97, server: ontweerp.com, request: "GET /froxlor/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:8888", host: "81.4.125.219"
2015/03/11 10:22:48 [error] 2894#0: *31 connect() failed (111: Connection refused) while connecting to upstream, client: 83.134.148.97, server: ontweerp.com, request: "GET /froxlor/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:8888", host: "81.4.125.219"

Is there any specific log files I should upload ? 

 

Thank you.

Share this post


Link to post
Share on other sites
  • 0

You are using tcp connection, froxlors implementation of php-fpm uses sockets. are you not using php-fpm? Did you forget to enable it in the setting?

Share this post


Link to post
Share on other sites
  • 0

are you not using php-fpm? Did you forget to enable it in the setting?

 

I didn't anticipate the fact that  it would have such effect "simply" after a reboot, is there a way to fix this via a config file ? Or should I re-install everything for the fourth time ?  ^_^ (I don't mind as this is for me an excellent exercise). 

 

appreciated.

 

 

Sorry: If you now chose to use PHP via FCGID or FPM, then you should also read our fcgid/php-fpm handbooks: http://redmine.froxlor.org/projects/froxlor/wiki/#3-Different-PHP-interfaces-optional

 

(The (LEMP) Stack on Debian 7 tutorial from digitalocean makes you install php-fpm..)

Share this post


Link to post
Share on other sites
  • 0

This is in no way an answer to my questions...sorry, this makes helping really hard. 

 

You need to know what you are using and what you've setup...a reboot has nothing to do with that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By DYNASTIE
      Hi,
       
      OS: Ubuntu 15.04, Webserver: nginx, PHP-FPM aktiviert? Ja!
       
      Soweit funktioniert alles, Kunden werden angelegt und man kann problemlos auf deren Seite verbinden und sieht die index.html.
      Wenn ich jetzt aber die index.html in index.php umbenenne, erhalte ich einen 502 gateway timed out fehler.
       
      Errorlog vom Kunden:
       
      Das Gleiche passiert bei einem Reboot.
       
      Ein simples "service nginx reload" behebt den Fehler.
       
      Kunde ist in der Webservergruppe vorhanden.
       
       
      nscd etc. sind richtig konfiguriert, bin nach dem offiziellen Howto gegangen.
       
      Einstellungen sollten richtig sein:

       
      Die Sockets von PHP-FPM werden auch angelegt.
       
       
       
      vhost.conf vom Kunden:
       
      php-fpm.conf (/etc/php5/fpm):
       
      Den Fehler kann ich mit: "service nginx reload" wie erw?hnt beheben. Ein "chmod 666" auf den php-fpm.socket l?st das Problem nach dem Reboot ebenfalls, jedoch m?chte ich ungern an den Rechten rumschrauben. Ebenfalls wird das problem gel?st indem ich den Master-Cronjob ausf?hre. Wobei, wenn nginx restarted/reloaded wird, ?ndert der ja nichts an den Rechten vom php-fpm.socket - also kann es nicht die L?sung sein, die chmod-Rechte auf jeden socket zu erh?hen.
       
      Edit:
       
      Habe gerade mal das System neu gestartet und sehe in der syslog folgendes:
       
       
      Habe aber in der nscd in der Zeile bei required-start mysql eingetragen, also d?rfte es zu dem Fehler nicht kommen. Die Daten stimmen 100% ?berein, ein manuelles Einloggverfahren mit den gleichen Daten funktioniert problemlos.
    • By Badumts
      Guten Tag,
      ich habe nach einer etwas l?ngeren Zeit den Server neugestartet. Nun besteht jedoch das riesige Problem, das der Server nicht mehr neustartet und ausschlie?lich ein Prozess gestartet wird (init).
      Es ist schwierig das Problem einzugrenzen. Die Logs haben mich leider auch nicht weiter gebracht.
      Also ich ein Rettungssystem gestartet habe sind mir jedoch ein Paar Dinge aufgefallen.
      Im Verzeichnis habe ich nun n?mlich die Datei "froxlordir_www-data_www-data.tmp" und die Dateien "aquota.group" und "aquota.user".
      Aufgrund der Zeitspanne ist es schwierig genaue Ausk?nfte ?ber Softwareaktualisierungen zu geben, die m?glicherweise den Schaden angerichtet haben k?nnten. 
       
      Ich kann mich eigentlich nicht entsinnen quota im Zusammenhang mit Froxlor installiert zu haben. Wenn ich es doch mal gemacht haben sollte, wie k?nnte ich das am besten R?ckg?ngig machen?
      Das ist nur eine Idee von mir...
       
      Ich hoffe ihr k?nnt mir helfen und das die schwammigen Aussagen irgendwie helfen k?nnen.
      Ich bedanke mich schon mal im Voraus.
       
      Gr??e,
      Julius
×
×
  • Create New...