Jump to content
Froxlor Forum
  • 0
DYNASTIE

502 bei Kunden nach Reboot

Question

Hi,

 

OS: Ubuntu 15.04, Webserver: nginx, PHP-FPM aktiviert? Ja!

 

Soweit funktioniert alles, Kunden werden angelegt und man kann problemlos auf deren Seite verbinden und sieht die index.html.

Wenn ich jetzt aber die index.html in index.php umbenenne, erhalte ich einen 502 gateway timed out fehler.

 

Errorlog vom Kunden:

 

2015/07/02 02:02:25 [crit] 1026#0: *14 connect() to unix:/var/run/nginx/customer2-customer2.domain.tld-php-fpm.socket failed (13: Permission denied) while connecting to upstream, client: 84.154.77.71, server: customer2.domain.tld, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/nginx/customer2-customer2.domain.tld-php-fpm.socket:", host: "customer2.domain.tld"
2015/07/02 02:02:27 [crit] 1026#0: *14 connect() to unix:/var/run/nginx/customer2-customer2.domain.tld-php-fpm.socket failed (13: Permission denied) while connecting to upstream, client: 84.154.77.71, server: customer2.domain.tld, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/nginx/customer2-customer2.domain.tld-php-fpm.socket:", host: "customer2.domain.tld"
 

 

Das Gleiche passiert bei einem Reboot.

 

Ein simples "service nginx reload" behebt den Fehler.

 

Kunde ist in der Webservergruppe vorhanden.

 

 

root@web01:~# groups www-data
www-data : www-data froxlorlocal customer1 customer2

 

nscd etc. sind richtig konfiguriert, bin nach dem offiziellen Howto gegangen.

 

Einstellungen sollten richtig sein:

e274a5c1b5.png

 

Die Sockets von PHP-FPM werden auch angelegt.

 

 

root@web01:~# ll /var/run/nginx
total 0
drwxr-xr-x  2 www-data     www-data     100 Jul  2 02:02 ./
drwxr-xr-x 24 root         root         800 Jul  2 02:05 ../
srw-rw----  1 customer1    customer1      0 Jul  2 02:02 customer1-customer1.domain.tld-php-fpm.socket=
srw-rw----  1 customer2    customer2      0 Jul  2 02:02 customer2-customer2.domain.tld-php-fpm.socket=
srw-rw----  1 froxlorlocal froxlorlocal   0 Jul  2 02:02 froxlor.panel.domain.tld-php-fpm.socket=

 

 

vhost.conf vom Kunden:

 

# 20_froxlor_normal_vhost_customer3.domain.tld.conf
# Created 02.07.2015 02:22
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

server {
    listen 5.196.34.113:80;
    server_name customer3.domain.tld *.customer3.domain.tld;
    access_log /var/customers/logs/customer3-access.log combined;
    error_log /var/customers/logs/customer3-error.log error;
    root /var/customers/webs/customer3/;
    
    location / {
        index index.php index.html index.htm;
        try_files $uri $uri/ @rewrites;
    }

    
    location @rewrites {
        rewrite ^ /index.php last;
    }

    location /webalizer {
        alias /var/customers/webs/customer3/webalizer/customer3.domain.tld/;
        auth_basic "Restricted Area";
        auth_basic_user_file /etc/nginx/froxlor-htpasswd/3-4a4c668b764c566349982f0bfc26a1cc.htpasswd;
    }

    location ~ ^(.+?\.php)(/.*)?$ {
        try_files $1 = 404;

        include /etc/nginx/fastcgi_params;
        fastcgi_split_path_info ^(.+\.php)(/.+)\$;
        fastcgi_param SCRIPT_FILENAME $document_root$1;
        fastcgi_param PATH_INFO $2;
        fastcgi_pass unix:/var/run/nginx/customer3-customer3.domain.tld-php-fpm.socket;
        fastcgi_index index.php;
    }


}
 

 

php-fpm.conf (/etc/php5/fpm):

 

;;;;;;;;;;;;;;;;;;;;;
; FPM Configuration ;
;;;;;;;;;;;;;;;;;;;;;

; All relative paths in this configuration file are relative to PHP's install
; prefix (/usr). This prefix can be dynamically changed by using the
; '-p' argument from the command line.

; Include one or more files. If glob(3) exists, it is used to include a bunch of
; files from a glob(3) pattern. This directive can be used everywhere in the
; file.
; Relative path can also be used. They will be prefixed by:
;  - the global prefix if it's been set (-p argument)
;  - /usr otherwise
;include=/etc/php5/fpm/*.conf

;;;;;;;;;;;;;;;;;;
; Global Options ;
;;;;;;;;;;;;;;;;;;

[global]
; Pid file
; Note: the default prefix is /var
; Default Value: none
pid = /run/php5-fpm.pid

; Error log file
; If it's set to "syslog", log is sent to syslogd instead of being written
; in a local file.
; Note: the default prefix is /var
; Default Value: log/php-fpm.log
error_log = /var/log/php5-fpm.log

; syslog_facility is used to specify what type of program is logging the
; message. This lets syslogd specify that messages from different facilities
; will be handled differently.
; See syslog(3) for possible values (ex daemon equiv LOG_DAEMON)
; Default Value: daemon
;syslog.facility = daemon

; syslog_ident is prepended to every message. If you have multiple FPM
; instances running on the same server, you can change the default value
; which must suit common needs.
; Default Value: php-fpm
;syslog.ident = php-fpm

; Log level
; Possible Values: alert, error, warning, notice, debug
; Default Value: notice
;log_level = notice

; If this number of child processes exit with SIGSEGV or SIGBUS within the time
; interval set by emergency_restart_interval then FPM will restart. A value
; of '0' means 'Off'.
; Default Value: 0
;emergency_restart_threshold = 0

; Interval of time used by emergency_restart_interval to determine when
; a graceful restart will be initiated.  This can be useful to work around
; accidental corruptions in an accelerator's shared memory.
; Available Units: s(econds), m(inutes), h(ours), or d(ays)
; Default Unit: seconds
; Default Value: 0
;emergency_restart_interval = 0

; Time limit for child processes to wait for a reaction on signals from master.
; Available units: s(econds), m(inutes), h(ours), or d(ays)
; Default Unit: seconds
; Default Value: 0
;process_control_timeout = 0

; The maximum number of processes FPM will fork. This has been design to control
; the global number of processes when using dynamic PM within a lot of pools.
; Use it with caution.
; Note: A value of 0 indicates no limit
; Default Value: 0
; process.max = 128

; Specify the nice(2) priority to apply to the master process (only if set)
; The value can vary from -19 (highest priority) to 20 (lower priority)
; Note: - It will only work if the FPM master process is launched as root
;       - The pool process will inherit the master process priority
;         unless it specified otherwise
; Default Value: no set
; process.priority = -19

; Send FPM to background. Set to 'no' to keep FPM in foreground for debugging.
; Default Value: yes
;daemonize = yes
 
; Set open file descriptor rlimit for the master process.
; Default Value: system defined value
;rlimit_files = 1024
 
; Set max core size rlimit for the master process.
; Possible Values: 'unlimited' or an integer greater or equal to 0
; Default Value: system defined value
;rlimit_core = 0

; Specify the event mechanism FPM will use. The following is available:
; - select     (any POSIX os)
; - poll       (any POSIX os)
; - epoll      (linux >= 2.5.44)
; - kqueue     (FreeBSD >= 4.1, OpenBSD >= 2.9, NetBSD >= 2.0)
; - /dev/poll  (Solaris >= 7)
; - port       (Solaris >= 10)
; Default Value: not set (auto detection)
;events.mechanism = epoll

; When FPM is build with systemd integration, specify the interval,
; in second, between health report notification to systemd.
; Set to 0 to disable.
; Available Units: s(econds), m(inutes), h(ours)
; Default Unit: seconds
; Default value: 10
;systemd_interval = 10

;;;;;;;;;;;;;;;;;;;;
; Pool Definitions ;
;;;;;;;;;;;;;;;;;;;;

; Multiple pools of child processes may be started with different listening
; ports and different management options.  The name of the pool will be
; used in logs and stats. There is no limitation on the number of pools which
; FPM can handle. Your system will tell you anyway :)

; To configure the pools it is recommended to have one .conf file per
; pool in the following directory:
include=/etc/php5/fpm/pool.d/*.conf
 

 

Den Fehler kann ich mit: "service nginx reload" wie erw?hnt beheben. Ein "chmod 666" auf den php-fpm.socket l?st das Problem nach dem Reboot ebenfalls, jedoch m?chte ich ungern an den Rechten rumschrauben. Ebenfalls wird das problem gel?st indem ich den Master-Cronjob ausf?hre. Wobei, wenn nginx restarted/reloaded wird, ?ndert der ja nichts an den Rechten vom php-fpm.socket - also kann es nicht die L?sung sein, die chmod-Rechte auf jeden socket zu erh?hen.

 

Edit:

 

Habe gerade mal das System neu gestartet und sehe in der syslog folgendes:

 

 

Jul  2 03:04:16 web01 ter process /usr/sbin/nginx -g daemon on; master_process on;: libnss-mysql: Connection to server '127.0.0.1' failed: Can't connect to MySQL server on '127.0.0.1' (111)
Jul  2 03:04:16 web01 ter process /usr/sbin/nginx -g daemon on; master_process on;: libnss-mysql: Connection to server '127.0.0.1' failed: Can't connect to MySQL server on '127.0.0.1' (111)
Jul  2 03:04:16 web01 ter process /usr/sbin/nginx -g daemon on; master_process on;: libnss-mysql: Connection to server '127.0.0.1' failed: Can't connect to MySQL server on '127.0.0.1' (111)
Jul  2 03:04:16 web01 ter process /usr/sbin/nginx -g daemon on; master_process on;: libnss-mysql: Connection to server '127.0.0.1' failed: Can't connect to MySQL server on '127.0.0.1' (111)

 

Habe aber in der nscd in der Zeile bei required-start mysql eingetragen, also d?rfte es zu dem Fehler nicht kommen. Die Daten stimmen 100% ?berein, ein manuelles Einloggverfahren mit den gleichen Daten funktioniert problemlos.

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Pers?nlich dr?berschauen -> https://froxlor.support/

 

Ansonsten schau mal nach seiner Startreihenfolge der init-scripts (MySQL vor nscd), wurde auch hier schon h?ufiger im forum behandelt.

Share this post


Link to post
Share on other sites
  • 0

Naja, in /etc/init.d/nscd habe ich bei # Required-Start:    $remote_fs $syslog mysql eingetragen. Sollte ja eigentlich reichen, werde es gleich mal probieren und mich dann nochmal melden.

Sind meine Konfigurationen etc. wie oben geposted richtig soweit?

Share this post


Link to post
Share on other sites
  • 0

An nscd bzw. libnss-mysql liegt es nicht. Nochmal kurz die Fakten: Froxlorpanel funktioniert, Kundenseiten nicht (502 bad gateway, nur bei .php-Dateien, logisch) - h?here chmod-Rechte auf den php-fpm.socket behebt das Problem, ebenfalls ein Ausf?hren des Cronjobs (Master) ebenfalls ein simples "service nginx reload" - woran kann es denn noch liegen? Konfigurationen m?ssen ja stimmen, Anleitung auch x mal durchgegangen.

Share this post


Link to post
Share on other sites
  • 0

System mehrfach neu aufgesetzt, gleiche Fehler. Die Anleitungen sind auch mehr als undurchsichtig, irgendwo wird immer etwas anderes geschrieben, dann funktionieren wiederum mal Seiten nicht und dann wird f?r Support noch Geld verlangt? Muss man nicht verstehen. Kann ja nicht sein, dass ich der Einzige mit dem Problem bin.

Share this post


Link to post
Share on other sites
  • 0

System mehrfach neu aufgesetzt, gleiche Fehler.

Dann machst du vermutlich immer den gleichen Fehler...

 

Die Anleitungen sind auch mehr als undurchsichtig,

Ansichtssache

 

irgendwo wird immer etwas anderes geschrieben,

Ich w?sste nicht das wir mehrere Anleitungen f?r die gleichen Sachen haben

 

dann funktionieren wiederum mal Seiten nicht

Aha...welche denn z.B.?

 

und dann wird f?r Support noch Geld verlangt?

Hast du bisher im Forum wasbezahlen m?ssen? Ich glaube nicht. Hast du f?r Froxlor was bezahlen m?ssen? Ich glaube nicht.

Du hast enorm falsche Vorstellungen...Andere sind dankbar ?ber kostenfreie Unterst?tzung. Wenn du so fordernd bist, solltest du daf?r bezahlen k?nnen.

 

Muss man nicht verstehen.

Korrekt.

 

Kann ja nicht sein, dass ich der Einzige mit dem Problem bin.

Bist du auch nicht, andere haben aber Geduld, fragen freundlich nach, beantworten unsere Gegenfragen und sind am Ende gl?cklich. Vielleicht benutzt du einfach mal die Forensuche...

Share this post


Link to post
Share on other sites
  • 0

Die Forensuche habe ich mehrfach genutzt, alle n?tzlichen Eintr?ge, die Google mir ausgespuckt hat, sind bereits markiert und wurden mehrfach durchgelesen. Das Problem besteht nicht nur seit gestern, ich versuche das System schon ?ber Wochen richtig aufzusetzen - ohne Erfolg, nat?rlich ist es sch?n, dass Froxlor kostenlos ist und das Forum auch kostenlosen Support gibt, jedoch ist es merkw?rdig, dass es einfach nicht funktioniert, obwohl ich nach mehreren Anleitungen (auch auf anderen Seiten) gegangen bin, also bitte die Kritik nicht zu pers?nlich nehmen ;)

 

Ansich habe ich alle Informationen geposted, wenn noch etwas ben?tigt werden sollte w?re ich dankbar, wenn mir dies mitgeteilt wird.

 

Liebe Gr??e!

Share this post


Link to post
Share on other sites
  • 0

Deine Fehlermeldung weiter oben ist doch klar:

Can't connect to MySQL server on '127.0.0.1'

Schau doch da mal rein, ggfls ?ndere mal 127.0.0.1 in 'localhost' - wirkt manchmal Wunder.

Share this post


Link to post
Share on other sites
  • 0

Dann muss es ja wohl neue Fehler Meldungen geben bei dem 502er Fehler. Bitte schaue in die logs.

Share this post


Link to post
Share on other sites
  • 0

Hallo!

Ich hatte nach dem Update auf Jessie auch dieses Problem. Die Zeile "host" kann man getrost g?nzlich entfernen, wenn der (mysqlSocket vorhanden ist und gen?tzt wird.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Schutzgeist
      Hallo, 
      vielleicht kann mir jemand hier ja einen kleinen Tipp geben.
      Es ist mehr eine nginx-Konfiguration. 
      PHP-404-Rückmeldungen sollen "sauber" an Joomla übergeben werden.
       
      Mein 'Froxlor-Standardvhost sieht wie folgt aus

      Allerdings kann ich über das Joomla eigene REDIRECT Modul keine .php - Erweiterungen intern umleiten. 
      Anstatt  die joomla-eigene 404 Seite zu erhalten, bekomme ich die von nginx, da  die Abfrage hier als erstes ausgeführt wird. 
      Also habe ich meine vhost stümperhaft umgeschrieben, s.d. ein Teil seinen Soll erfüllt. 

      Teilweise kann ich nun die Redirects über Joomla verwalten lassen, aber oft erhalte ich LOOPs, da ich ja immer auf die index.php verweise. 
      So, warum nutze ich nicht die nginx-Weiterleitungen ? 

      Ich nutze ein Multi-Sitemodul  sowie ein Modul, um eine php-Endung  zu simulieren. 
      Beide haben mit meiner und der Standardvhost-Konfiguration leichte Schwierigkeiten. 

       
      Welche Vhost-Anpassungen nutzt ihr bei Eurer Joomla-Webseite ? 
      Der Fehler sitzt vermutlich 30 cm vor meinem Bildschirm. 
      Innerhalb meiner letzten 30 Versuche habe ich wohl  oft alte Cache-Webseiten geladen und ggf. die richtige Konfig übersehen.
       

       
       
       
       
       
    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
    • By princeofnaxos
      Wenn running "froxlor_master_cronjob.php -- tasks", it produces this error at the end:
      sh: 1: /etc/init.d/php-fpm: not found
      On Debian Stretch with PHP 7.2, this should be "/etc/init.d/php7.2-fpm". Is this a configuration setting? I can't find it.




×
×
  • Create New...