Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Patrick1993

Domain leitet auf falschen Pfad

Question

Hallo Leute,

Ich bin seit ein paar Minuten hier Mitglied und Verwalte einige Server.

Seit kurzem habe ich einen neuen Root Server bekommen und dieser hat nun Froxlor als Webinterface.

 

Nun habe ich auf dem Root eine Domain laufen die ich auf einen gewissen Pfad leiten will.

Laut den Einstellungen in Froxlor sollte die Domain auf den richtigen Pfad zeigen was sie jedoch nicht tut.

 

Woran kann das liegen oder ist einfach irgendwas falsch eingestellt

 

Freue mich auf eure Antworten

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

Ich habe den Pfad im Adminmen? in Froxlor bei der Domain eingetragen.

 

Ich habe die Domain bei Froxlor eingepflegt und die Domain einem Kunden zugewiesen und beim zuweisen wurde der Domain der Pfad des Kunden automatisch zugewiesen

Share this post


Link to post
Share on other sites

Fakten bitte, was f?r Werte hast du wo eingetragen? Gerne auch einen Screenshot. So kann keiner helfen.

Share this post


Link to post
Share on other sites

Domain: multi-webhosting.de (also meine Domain)

Alias f?r Domain: Kein Alias

Document-Root: Pfad auf die die Domain zeigen soll (/var/customers/webs/patrick1993/)

IP adresse: meine IP vom Server

PHP Konfiguration: Default COnfig

Nameserver: Hacken drine

Zone File: Alles was in der Zone File des Server stand rein Kopiert

 

Das sind die Einstellungen die ich in Froxlor habe

Share this post


Link to post
Share on other sites

Und jetzt den passenden Vhost der Domain (von froxlor generiert) noch bitte

Share this post


Link to post
Share on other sites

Hoffe es ist das Richtige.

 

Ich habe 2 Config Datein.

 

Defaut Config Froxlor:

PHP-Binary: /usr/bin/php-cgi

Dateiendungen: php

PHP-Prozesse f?r diese Domain (leer f?r Standardwert): leer

Maxmale PHP-Requests f?r diese Domain (leer f?r Standardwert): leer

FPM slowlog pro Domain aktivieren: Nicht Aktiviert

Request terminate-timeout: 60s

Request slowlog-timeout: 5s

php.ini-Einstellungen:

allow_call_time_pass_reference = Off

allow_url_fopen = On
asp_tags = Off
disable_classes =
disable_functions = curl_multi_exec,exec,parse_ini_file,passthru,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,shell_exec,show_source,system
display_errors = Off
display_startup_errors = Off
enable_dl = Off
error_reporting = E_ALL & ~E_NOTICE
expose_php = Off
file_uploads = On
cgi.force_redirect = 1
gpc_order = "GPC"
html_errors = Off
ignore_repeated_errors = Off
ignore_repeated_source = Off
include_path = ".:{PEAR_DIR}"
log_errors = On
log_errors_max_len = 1024
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
max_execution_time = 60
max_input_time = 60
memory_limit = 16M
noutput_buffering = 4096
post_max_size = 16M
precision = 14
register_argc_argv = Off
register_globals = Off
report_memleaks = On
sendmail_path = "/usr/sbin/sendmail -t -i -f {CUSTOMER_EMAIL}"
session.auto_start = 0
session.bug_compat_42 = 0
session.bug_compat_warn = 1
session.cache_expire = 180
session.cache_limiter = nocache
session.cookie_domain =
session.cookie_lifetime = 0
session.cookie_path = /
session.entropy_file = /dev/urandom
session.entropy_length = 16
session.gc_divisor = 1000
session.gc_maxlifetime = 1440
session.gc_probability = 1
session.name = PHPSESSID
session.referer_check =
session.save_handler = files
session.save_path = "{TMP_DIR}"
session.serialize_handler = php
session.use_cookies = 1
session.use_trans_sid = 0
short_open_tag = On
suhosin.mail.protect = 1
suhosin.simulation = Off
track_errors = Off
upload_max_filesize = 32M
upload_tmp_dir = "{TMP_DIR}"
variables_order = "GPCS"

Share this post


Link to post
Share on other sites

Nein, das ist die PHP-Config. Was ich brauche ist die von froxlor generierte "Vhost-Konfiguration" f?r den Webserver, ?blicherweise in /etc/apache2/sites-enabled/*

Share this post


Link to post
Share on other sites

Dann ist es nicht korrekt, denn der Cronjob lief nicht, wenn es keine Vhost-Configs gibt. Bitte ?berpr?fe deine Einstellungen und die Konfigurationen der entsprechenden Services

Share this post


Link to post
Share on other sites

Hat damit nichts zu tun, du musst die Services alle konfigurieren. Admin -> Men? links -> "Configuration", dort deine Distro und Kategorie und die ben?tigten/gew?nschten Services ausw?hlen und den Befehlen folgen

Share this post


Link to post
Share on other sites

Habe gestern Cron mal auf meinem Server gestartet der lief nicht nun habe ich die ganzen Datein.

Rufe ich 1 der 2 Domains auf bekomme ich folgende Meldung:

 

Forbidden

You don't have permission to access / on this server.

 

kann es an den CHMODs liegen das der Ordner gewisse Rechte braucht ?

Share this post


Link to post
Share on other sites

Also nun habe ich folgende Datein:

05_froxlor_dirfix_nofcgid.conf

10_froxlor_ipandport_46.4.59.21.80.conf

22_froxlor_normal_vhost_multi-webhosting.de.conf

22_froxlor_normal_vhost_original-landschaftsbilder.de.conf

40_froxlor_diroption_35f450244b889712e8179e6dc770f94c.conf

40_froxlor_diroption_bf3e15b1603dff7ac4bd872703c2a8a5.conf

 

Die wichtigste Domain ist multi-webhosting und die vHost datei sieht si aus:

 

# 22_froxlor_normal_vhost_multi-webhosting.de.conf
# Created 02.02.2014 21:35
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.
 
# Domain ID: 3 - CustomerID: 2 - CustomerLogin: multihosting
<VirtualHost 46.4.59.21:80>
  ServerName multi-webhosting.de
  ServerAlias *.multi-webhosting.de
  ServerAdmin p.brockmann@yahoo.de
  DocumentRoot "/var/customers/webs/multihosting/"
  php_admin_value open_basedir "/var/customers/webs/multihosting:/tmp"
  ErrorLog "/var/customers/logs/multihosting-error.log"
  CustomLog "/var/customers/logs/multihosting-access.log" combined
</VirtualHost>
 
 
ruft man nun multi-webhosting.de auf bekommt man den oben genannten Forbidden

Share this post


Link to post
Share on other sites





×
×
  • Create New...