Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
schnackel

[solved] Apache leitet nicht korrekt weiter

Question

Hallo,

ich hab das Problem, dass mein Apache nicht auf den richtigen vHost weiterleitet.

Habe eine Domain angelegt im Forxlor. Sobald ich diese mit dem Browser aufrufe kommt die Meldung

 

 

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.

 

im Pfad der Domain ist eine PHP Dtei hinterlegt mit einem echo Befehl.

 

Hat jemand eine Idee wie ich hier weitermachen kann?

 

Gr??e

Share this post


Link to post
Share on other sites

Recommended Posts

Installiert hab ich es. Ob die Konfig richtig ist kann ich nicht sagen. Der Apache startet nicht mehr. So kann ich nicht im froxlor unter Konfiguration nachschauen.

 

 

[....] Starting web server: apache2Syntax error on line 9 of /etc/apache2/sites-enabled/10_froxlor_ipandport_10.21.9.236.80.conf:
Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration
Action 'start' failed.

 

Edit: Wie bekomm ich denn den Apacha wieder sauber zum laufen ohne das Modul. Ich denke es wird am Anfang nicht n?tig sein.

Hauptsache ich kann mit einer Domain auf einen Space drauf zugreifen

Share this post


Link to post
Share on other sites

 

# add "non-free" after all occurances of "main" in /etc/apt/sources.list

# this is needed for libapache2-mod-fastcgi to install
apt-get install apache2-suexec libapache2-mod-fastcgi php5-fpm
rm /etc/php5/fpm/pool.d/www.conf
a2enmod suexec fastcgi actions

Share this post


Link to post
Share on other sites

 

 

# add "non-free" after all occurances of "main" in /etc/apt/sources.list

# this is needed for libapache2-mod-fastcgi to install
apt-get install apache2-suexec libapache2-mod-fastcgi php5-fpm
rm /etc/php5/fpm/pool.d/www.conf
a2enmod suexec fastcgi actions

 

 

Jo das hab ich gemacht gehabt mir folgender Meldung gerade erneut.

 

Module suexec already enabled

ERROR: Config file fastcgi.conf not properly enabled: /etc/apache2/mods-enabled/fastcgi.conf is a real file, not touching it

Module actions already enabled

 

Share this post


Link to post
Share on other sites

Dann halt so:

mv /etc/apache2/mods-available/fastcgi.conf /etc/apache2/mods-available/fastcgi.conf.alt
mv /etc/apache2/mods-enabled/fastcgi.conf /etc/apache2/mods-available/
a2enmod fastcgi

Share this post


Link to post
Share on other sites

Wenn du die aktuelle Stable version benutzt (0.9.30) dann:

chown -R www-data:www-data /var/run/apache2

Im GIT ist das schon behoben und wieder etwas anders.

Share this post


Link to post
Share on other sites

Also dieses CGI Problem ist behoben. Der Apache ist gestartet. --> Danke

Das Urproblem bleibt.

Rufe ich die Ip oder die Domain im Browser auf kommt die "It works" Seite.

Share this post


Link to post
Share on other sites

Na das kann doch nich sein...da stimmt doch bei dir was nicht. ich kann mir das gerne mal anschauen wenn du willst, einfach per PM die zugangsdaten schicken, dann k?nnen wir gemeinsam mal schauen was da bei dir faul ist.

Share this post


Link to post
Share on other sites

Evtl. bin ich n?her dran.

Ich hab Froxlor direkt via Hostnamen erreichbar machen aktiviert und siehe da, ruf ich den Hostname oder die IP auf kommt auch die Anmeldemaske.

Nur die vHosts werden noch nicht angesteuert.

Share this post


Link to post
Share on other sites

Pr?fe jetzt mal mit folgendem Befehl, ob die vhosts ?berhaupt korrekt eingebunden sind. Bitte nopaste die Ausgabe des Befehls:

apache2ctl -S

Share this post


Link to post
Share on other sites

und die domains zeigen 100% auf den korrekten Server? Das habe ich auch schon ?fter erlebt, dass die leute sich wundern, warum die domains nicht gehen und dann lag es an falschen DNS einstellungen.

Share this post


Link to post
Share on other sites

Ja wenn ich zB "test" pinge bekomm ich antwort vom Server (die richtige IP kommt zur?ck)

?ndere ich unter /var/www/ die index dann bekomm ich die ?nderungen auch angezeigt

 

Edit:

Nun bekomm ich kein "It works!" mehr sondern "Internal Server Error"

Share this post


Link to post
Share on other sites

Hast du was an der default-config von apache2 ge?ndert? das kann ja eigentlich nicht sein, dass die alle auf /var/www/ zeigen...deine vhost-conf die du uns gezeigt hast sagt ja was anderes.

 

Kollidiert hier vllt der Froxlor-Hostname mit der Kunden-Domain? Sind die gleich oder sowas?

Share this post


Link to post
Share on other sites
Edit:

Nun bekomm ich kein "It works!" mehr sondern "Internal Server Error"

 

/etc/apache2/sites-enabled/000-default

http://nopaste.info/e30c6b739d.html

 

Die Domain "test" ist dem Kunde zugewiesen

/etc/apache2/sites-enabled/22_froxlor_normal_vhost_test.conf

http://nopaste.info/b01241fc56.html

 

/etc/apache2/apache2.conf

http://nopaste.info/c0660d74d2.html

 

Es gibt aktuell nur einen Kunden

der hat 3 Domains.

- Die Standarddomain: KUNDENNAME.FQDN  (Standardsubdomain)

- test (zeigt auf /events/)

- events.test.de (zeigt auf /events/)

 

Hoffentlich hab ich jetzt nix vergessen

 

 

Share this post


Link to post
Share on other sites

Sag doch bitte gleich, dass du einen Fehler bekommst und nicht mehr die "It works" Seite. Das sind doch v?llig verschiedene Dinge.

 

Dann schau jetzt doch einfach mal in die error_log (vom apache UND vom kunden) - da sollte nun drinstehen was sache ist.

Share this post


Link to post
Share on other sites

Beim Aufruf der Domain "test"  kommt kein Eintrag im Apache Log hinzu.

Im Kundenlog sind die letzten Zeilen.

 

[Tue Nov 26 10:10:29 2013] [error] [client 10.21.8.124] (2)No such file or directory: FastCGI: failed to connect to server "/var/www/php-fpm/KUNDENNAME/test/fpm.external": connect() failed
[Tue Nov 26 10:10:29 2013] [error] [client 10.21.8.124] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/KUNDENNAME/test/fpm.external"
[Tue Nov 26 10:10:29 2013] [error] [client 10.21.8.124] (2)No such file or directory: FastCGI: failed to connect to server "/var/www/php-fpm/KUNDENNAME/test/fpm.external": connect() failed
[Tue Nov 26 10:10:29 2013] [error] [client 10.21.8.124] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/KUNDENNAME/test/fpm.external"
[Tue Nov 26 10:12:00 2013] [error] [client 10.21.8.124] (2)No such file or directory: FastCGI: failed to connect to server "/var/www/php-fpm/KUNDENNAME/test/fpm.external": connect() failed
[Tue Nov 26 10:12:00 2013] [error] [client 10.21.8.124] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/KUNDENNAME/test/fpm.external"
[Tue Nov 26 10:24:16 2013] [error] [client 10.21.8.124] (2)No such file or directory: FastCGI: failed to connect to server "/var/www/php-fpm/KUNDENNAME/test/fpm.external": connect() failed
[Tue Nov 26 10:24:16 2013] [error] [client 10.21.8.124] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/KUNDENNAME/test/fpm.external"

Share this post


Link to post
Share on other sites

Was hab ich gesagt? Wenn es einen Fehler gibt -> LOGS

 

So kommen wir doch echt nicht weiter. Ein bisschen Eigeninitiative muss schon sein. Du wolltest mich ja nicht auf den Server schauen lassen

Share this post


Link to post
Share on other sites

 

[26-Nov-2013 10:37:04] ERROR: No pool defined. at least one pool section must be specified in config file

[26-Nov-2013 10:37:04] ERROR: failed to post process the configuration

[26-Nov-2013 10:37:04] ERROR: FPM initialization failed

[26-Nov-2013 10:37:04] ERROR: No pool defined. at least one pool section must be specified in config file

[26-Nov-2013 10:37:04] ERROR: failed to post process the configuration

[26-Nov-2013 10:37:04] ERROR: FPM initialization failed

 

Share this post


Link to post
Share on other sites

Du hast die von Froxlor erstellten Pools nicht korrekt eingebunden, d.h. deine include-Anweisung in der php-fpm.conf zeigt wohl auf den falschen Ordner.

 

Jetzt schau bitte nach:

 

1) welchen Ordner hast du f?r die PHP-Konfigurationen in Froxlor angegeben?

2) Sind in diesem Ordner auch Konfigurationsdateien [domain].conf?

3) Hast du diesen Ordner in der Include-Anweisung in der php-fpm.conf angegeben? (z.B. include=/etc/php/fpm-php5.4/fpm.d/*.conf)

Share this post


Link to post
Share on other sites

Zu 1:

Pfad zu php-fpm-Konfigurationen: /etc/php-fpm.d/

Configuration Alias-directory of php-fpm:  /var/www/php-fpm/

Zu 2:

Ja, in /etc/php-fpm.d liegen 3 xy.conf Dateien. F?r jede Domain eine

Zu 3:

ich hab jetzt die Zeile

include=/etc/php5/fpm/*.conf

vom ";" in

/etc/php5/fpm/php-fpm.conf

entfernt. Ist das die richtige Datei und auch die richtige Zeile?

Starten vom Dienst funktioniert nicht. Im Log tut sich nichts mehr. Keine neue Meldung dazu.

Share this post


Link to post
Share on other sites

×
×
  • Create New...