Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
schnackel

[solved] Apache leitet nicht korrekt weiter

Question

Hallo,

ich hab das Problem, dass mein Apache nicht auf den richtigen vHost weiterleitet.

Habe eine Domain angelegt im Forxlor. Sobald ich diese mit dem Browser aufrufe kommt die Meldung

 

 

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.

 

im Pfad der Domain ist eine PHP Dtei hinterlegt mit einem echo Befehl.

 

Hat jemand eine Idee wie ich hier weitermachen kann?

 

Gr??e

Share this post


Link to post
Share on other sites

Recommended Posts

Was genau meinst du mit "im Pfad der Domain ist eine PHP Datei hinterlegt"? Hast du als Documentroot direkt "/var/bla/index.php" reingeschrieben? Das geht n?mlich nicht, er erwartet dort eine URL oder einen PFAD! Keine Datei.

 

Zus?tzlich, pr?fe bitte, ob der Cronjob gelaufen ist und ob entsprechende Vhost-Configs errstellt wurden, wenn ja, bitte nopasten (domains + ips kannst du gern verfremden nat?rlich)

Share this post


Link to post
Share on other sites

Ich habe der Domain einen Ordner zugewiesen /test/ dieser wurde auch erstellt, mit der standard index.html.

Diese index.html hab ich durch einen index.php getauscht.

Da der Ordner stellt wurde, laufen auch die Crons

 

Die Domain ist events.test.de

Ruf ich diese auf kommt das Ergebniss wie oben beschrieben und rufe ich nur die IP auf kommt die gleiche Seite.

 

Was genau h?ttest du gerne im nopaste?

Share this post


Link to post
Share on other sites

Ja dann schau bitte, welchen Ordner du in den Einstellungen hinterlegt hast, und pr?fe den. Irgendwelche Vhosts m?ssen ja erstellt werden, sonst w?rde ja nichts funktionieren. Du sagtest ja, der Cronjob l?uft.

Share this post


Link to post
Share on other sites

Das sind keine Vhost-Konfigurations-Dateien. Das sind Eintr?ge in Froxlor. Bitte schaue in den Konfigurations-Ordner von deinem Webserver auf dem Dateisystem (meist in /etc/apache2)

Share this post


Link to post
Share on other sites

Da k?nnte der Fehler sein. Die einzigen Datein die ich dort hab sind

 

apache2.conf  conf.d  envvars  magic  mods-available  mods-enabled  ports.conf  sites-available  sites-enabled
 

Wie soll ich die bennen und wie sieht die Config daf?r denn aus?

Share this post


Link to post
Share on other sites

Lass dir doch bitte nicht alles aus der Nase ziehen. Du hast doch einen Ordner f?r die Konfigurations-Dateien in den Einstellungen angegeben und genau in dem schaust du jetzt nach, was da so drin ist.

Share this post


Link to post
Share on other sites

Irgendwie steh ich aufem Schlauch.

 

die /etc/apache2/sites-enabled/000-default sieht so aus

 

 

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
 

 

Der Pfad der in den Einstellungen hinterlegt ist:

Webserver vHost-Konfigurations-Datei/Verzeichnis-Name

 

/etc/apache/vhosts.conf

 

Das hab ich jetzt auf

 

/etc/apache2/sites-enabled/

 

ge?ndert. Cron ist schon gelaufen. Leider kein Erfolg.

Share this post


Link to post
Share on other sites

Das hatten wir doch vorhin alles schon, bitte ?berpr?fe deine Einstellungen, dass alle Pfade korrekt sind (z.B. /etc/apache2/ statt /etc/apache/). und wenn der cron gelaufen ist sollten da konfigurationen drin sein. Sonst hast du definitiv was falsch gemacht. Du kannst den cron auch manuell mit dem parameter "--force" aufrufen, dann musst du nicht immer 5 minuten warten.

Share this post


Link to post
Share on other sites

Angelegt wurden die Datein. Aber es ?ndert an dem Urproblem nichts.

Die Datei f?r die Domain sieht so aus

 

 

# 22_froxlor_normal_vhost_events.xy.de.conf
# Created 25.11.2013 13:55
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 2 - CustomerID: 1 - CustomerLogin: username
<VirtualHost 10.21.9.236:80>
  ServerName events.xy.de
  ServerAdmin asdf@xy.de
  DocumentRoot "/var/customers/webs/username/events/"
  FastCgiExternalServer /var/www/php-fpm/username/events.xy.de/fpm.external -socket /var/run/apache2/username-events.xy.de-php-fpm.socket -idle-timeout 30
  <Directory "/var/customers/webs/username/events/">
    <FilesMatch "\.php$">
      SetHandler php5-fastcgi
      Action php5-fastcgi /fastcgiphp
      Options +ExecCGI
    </FilesMatch>
    Order allow,deny
    allow from all
  </Directory>
  Alias /fastcgiphp /var/www/php-fpm/username/events.xy.de/fpm.external
  Alias /webalizer "/var/customers/webs/username/webalizer"
  ErrorLog "/var/customers/logs/username-error.log"
  CustomLog "/var/customers/logs/username-access.log" combined
</VirtualHost>
 

Username und xy wurden von mir abge?ndert.

Bei Username steht der Kundenname dem die Domain geh?rt

Share this post


Link to post
Share on other sites

ja also wurde ja doch was erstellt, du sagtest doch am anfang da w?r alles leer. Also die config ist korrekt. Und jetzt besteht weiterhin das Problem, dass die Domain nur auf "It works" zeigt oder wie?

Share this post


Link to post
Share on other sites

Richtig. Die Domain zeigt auf It works.

Aber nicht nur die Domain. Sondern auch wenn ich direkt ?ber die IP gehe.

 

Der Ordner war die ganze Zeit auch leer bis ich die Pfade eben ge?ndert habe, dann wurden die Dateien mit dem o.g. Inhalt erstellt.

Share this post


Link to post
Share on other sites

Ja nat?rlich war der Ordner leer, wenn die Pfade in den Einstellungen nicht gestimmt haben. Da h?tte dir der Cronjob auch entsprechende Fehler ausspucken m?ssen, dass er den Ordner nicht finden kann, bzw. nichts reinschreiben kann. Haste ja nie was von gesagt.

 

Pr?fe jetzt mal mit folgendem Befehl, ob die vhosts ?berhaupt korrekt eingebunden sind. Bitte nopaste die Ausgabe des Befehls:

apache2ctl -S

Share this post


Link to post
Share on other sites

Und da wunderst du dich? Wieso sagst du denn nicht, dass beim Neustart des Webservers ein Fehler auftaucht? Woher sollen das Au?enstehende denn wissen, so wird einem Helfen wirklich unglaublich erschwert.

 

Du hast nicht alles installiert, um PHP-FPM zu nutzen. Folge daf?r doch bitte den Konfigurationsanweisungen von Froxlor "Others (system) => PHP-FPM"

Share this post


Link to post
Share on other sites

Das war gewiss keine Absicht, diesen Error zu Unterschlagen. Bin selbst daran interessiert dieses Problem so schnell wie m?glich zu beheben, da liegt mir nichts daran Infos dem Forum vorzuenthalten.

 

Habe PHP-FPM installiert.

Fehlermeldung beim Restart

 

 

/etc/init.d/apache2 restart
Syntax error on line 9 of /etc/apache2/sites-enabled/10_froxlor_ipandport_10.21.9.236.80.conf:
Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
 failed!
 

Share this post


Link to post
Share on other sites

Du hast nicht alles installiert, um PHP-FPM zu nutzen. Folge daf?r doch bitte den Konfigurationsanweisungen von Froxlor "Others (system) => PHP-FPM"

Share this post


Link to post
Share on other sites

wie sieht die /etc/apache2/mods-available/fastcgi.conf aus?

 

(bzw. mods-enabled statt mods-available)

Share this post


Link to post
Share on other sites

wie sieht die /etc/apache2/mods-available/fastcgi.conf aus?

 

 

<IfModule mod_fastcgi.c>

  AddHandler fastcgi-script .fcgi

  #FastCgiWrapper /usr/lib/apache2/suexec

  FastCgiIpcDir /var/lib/apache2/fastcgi

</IfModule>

 

 

/etc/apache2/mods-enabled

 

 

<IfModule mod_fastcgi.c>

    FastCgiIpcDir /var/run/apache2/

 

    <Location "/fastcgiphp">

        Order Deny,Allow

        Deny from All

        # Prevent accessing this path directly

        Allow from env=REDIRECT_STATUS

    </Location>

</IfModule>

 

Share this post


Link to post
Share on other sites

Die in /etc/apache2/mods-enabled sollte die korrekte sein. Was sagt ein /etc/init.d/apache stop mit anschlie?endem start? Bewusst KEIN reload/restart

Share this post


Link to post
Share on other sites

Hast du denn jetzt auch via apt das Paket libapache2-mod-fastcgi installiert? Bzw. hast du alle Konfigurations-Vorgaben ausgef?hrt?

Share this post


Link to post
Share on other sites





×
×
  • Create New...