Jump to content
Froxlor Forum
  • 0

[solved] Apache2 vHost


Androx

Question

Hallo,

 

ich habe ein kleines Problem und zwar aktiviert Froxlor die vHost der Domaines und Subdomaines nicht. Verwende Froxlor schon seid ?ber zwei Jahren.  Froxlor erstellt nur die vHost im Ordner /etc/apache2/sites-available/ aber aktiviert diese nicht. Wenn ich die vHost via SSH mit a2ensite <vhost> aktiviere geht alles. Und es gibt ein Fehler Einstellungen -> Webservereinstellungen dort stand ?berall Apache statt Apache2 ich habe es mal angepasst, au?erdem waren die Ordner auch komplett anders (Und mit den nicht angepassten Webservereinstellungen wurden nichtmal die vHost erstellt):

 

Webserver vHost-Konfigurations-Datei/Verzeichnis-Name: /etc/apache2/sites-available/

Webserver Verzeichnisoption-Konfigurations-Datei/Verzeichnis-Name: /etc/apache2/sites-available/

Webserver htpasswd Verzeichnisname: /etc/apache2/froxlor-htpasswd/

Webserver-Reload-Command: /etc/init.d/apache2 reload

 

Ich habe einen vServer (OS Debain 6) mit der aktuellen Froxlor Version (0.9.30-1+squeeze1), PHP Version 5.3.3-7+squeeze17, Apache/2.2.16 (Debian) und FCGID. 

 

Ich hoffe ihr k?nnt mir helfen :blink:

 

Gru?

Androx

Link to post
Share on other sites

13 answers to this question

Recommended Posts

Froxlor benutzt nur die Ordner die du in den Einstellungen angibst. Bei einem update bleiben deine Einstellungen aus der Datenbank nat?rlich erhalten. Ansonsten inkludiert Apache default m??ig alle .conf Dateien in dem Ordner sites-enabled

Link to post
Share on other sites

Also ich verstehe gerade dein konkrektes Problem nicht. Du sagst die Configs werden erstellt, dann werden Sie wieder nicht erstellt. 

 

1) erstellt der Cronjob die Kunden-Vhosts in /etc/apache2/sites-enabled/  (bzw. dem angegebenen Ordner)?

2) Hast du die ggfls. die Default-Config von Apache angepasst (Froxlor ist daf?r ausgelegt, dass dort nichts angepasst wurde!)

3) genauerer Fehlerbeschreibung und Logs

Link to post
Share on other sites

Was heisst "Froxlor aktiviert sie nicht"? froxlor erstellt sie ja auch nur. Integriert werden diese automatisch von Apache, da Apache defaultm??ig alle .conf Dateien im Ordner /etc/apache2/sites-enabled/ inkludiert. Wenn das nicht gemacht wird, stimmt was an deiner apache-config nicht (die von Froxlor nicht angefasst wird).

Link to post
Share on other sites

Vielleicht w?re es sinnvoller, die Apache Konfigurationsdateien und die von Froxlor zu trennen.

Solange die Konfigurationen in sites-available liegen werden sie sowieso nicht geladen, sondern erst wenn sie in sites-enabled liegen. Froxlor verschiebt oder aktiviert diese aber nicht ?ber a2ensite (wie es beim Apache2 eigentlich gemacht wird).

 

Bei mir hab ich das folgenderma?en gel?st:

 

Webserver vHost-Konfigurations-Datei/Verzeichnis-Name: /etc/apache2/sites-froxlor/

Webserver Verzeichnisoption-Konfigurations-Datei/Verzeichnis-Name: /etc/apache2/vhosts_options-froxlor/

 

und in apache2.conf noch ganz am Ende folgendes eingetragen:

# Include the Froxlor host configurations:
Include sites-froxlor/
Include vhosts_options-froxlor/

Damit werden die "normalen" Apache Konfigurationen vor den Froxlor-Sites geladen.

Link to post
Share on other sites

@d00p: Ich kann bestaetigen, dass die default settings in 0.9.30 buggy sind, so wie es Androx vermutlich drueber gestolpert ist, und im originallen Post zu erklaeren versucht hat. Die Standard-Einstellungen bei einer Neuinstallation mit 0.9.30 verhindern das erstellen der vHost-Einstellungen.

 

Ich habe eine frische Installation auf Debian Wheezy gemacht. Die Pfade zu den Apache vHost Dateien/Verzeichnissen zeigen per default auf Dateien in einem nicht existierenden

/etc/apache/...

Ordner, anstatt

/etc/apache2/...

Mit der pre-0.9.30 Einstellung

/etc/apache2/sites-enabled/

funktioniert es.

 

Das reload command steht faelschlichweise auf

/etc/init.d/apache reload

anstatt

/etc/init.d/apache2 reload
Link to post
Share on other sites

The defaults were the same as they were the last time (no change since 2011, don't need to look further). They just have been updated for the upcoming 0.9.31. So, I don't know what happened there, this was never a problem. Also - you should not rely on default-settings. that's whay these paths are settings, to adjust them to your needs/system.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...