Jump to content
Froxlor Forum

All Activity

This stream auto-updates     

  1. Today
  2. Yesterday
  3. Last week
  4. oh man, so einfach kann es sein. Vielen Dank.
  5. Welche der beiden Möglichkeiten? MySQL oder extrausers? Bei letzterem muss man das auch in den Froxlor Einstellungen angeben, damit froxlor weiss das er die Dateien dafür generieren soll
  6. Danke für deine schnelle Antwort Eigentlich habe ich das nach der Konfigurationsanleitung eingerichtet. Also bisher habe ich folgendes: Debian-98-stretch-64-minimal Webserver: Apache/2.4.25 (Debian) PHP-Version: 7.3.4
  7. Na weil das Sinn der Sache ist, dass die PHP Prozesse unter dem entsprechenden User ausgeführt werden Hast du ggfls libnss-mysql (alternativ libnss-extrausers) vergessen einzurichten?
  8. Hallo, ich richte gerade einen Server mit Froxlor ein und bin auf folgendes Problem gestoßen: Apr 18 09:51:17 Debian-98-stretch-64-minimal systemd[1]: Starting The PHP 7.3 FastCGI Process Manager... Apr 18 09:51:17 Debian-98-stretch-64-minimal php-fpm7.3[4522]: [18-Apr-2019 09:51:17] ERROR: [pool USER.DOMAIN.de] cannot get uid for user 'USER' Apr 18 09:51:17 Debian-98-stretch-64-minimal php-fpm7.3[4522]: [18-Apr-2019 09:51:17] ERROR: FPM initialization failed Apr 18 09:51:17 Debian-98-stretch-64-minimal systemd[1]: php7.3-fpm.service: Main process exited, code=exited, status=78/n/a Apr 18 09:51:17 Debian-98-stretch-64-minimal systemd[1]: Failed to start The PHP 7.3 FastCGI Process Manager. Apr 18 09:51:17 Debian-98-stretch-64-minimal systemd[1]: php7.3-fpm.service: Unit entered failed state. Apr 18 09:51:17 Debian-98-stretch-64-minimal systemd[1]: php7.3-fpm.service: Failed with result 'exit-code'. Was ich jetzt nicht weiß, warum braucht der eine uid von einem Kunden?
  9. just activated from system>settings>system settings
  10. Tried to find out what issues you have had, but you just complained about how you wasted two days....not very helpful and not a real question.
  11. Hi i tried to install it on Digital Ocean server , tried ubuntu , debian and centOs as well . I wasted my two days , can i get any tutorial as i could't find any proper one .
  12. and also activated explicitly in the settings? Froxlor needs to know whether you are using libnss-extrausers or not...
  13. libnss-extrausers configured as per direction in system>configuration fgcid enabled under settings also i checked https://github.com/Froxlor/Froxlor/wiki/apache2-with-fcgid but it is including commands for debian old versions.
  14. forgot to setup/configure libnss-mysql or libnss-extrausers?
  15. Hello all, I deleted my old debian 7 and updated everything to new versions. However some problems exists and i cannot access my webpages. I did everything according to wiki pages and froxlor configurations but still some errors exists in below and not showing pages properly - only froxlor default page shown ● apache2.service - The Apache HTTP Server Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled) Active: active (running) (Result: exit-code) since Tue 2019-04-16 23:48:14 +03; 53min ago Process: 4850 ExecStop=/usr/sbin/apachectl stop (code=exited, status=0/SUCCESS) Process: 5958 ExecReload=/usr/sbin/apachectl graceful (code=exited, status=1/FAILURE) Process: 4858 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS) Main PID: 4862 (apache2) Tasks: 13 (limit: 4915) CGroup: /system.slice/apache2.service ├─4862 /usr/sbin/apache2 -k start ├─4863 /usr/sbin/apache2 -k start ├─4864 /usr/sbin/apache2 -k start ├─4867 /usr/sbin/apache2 -k start ├─4868 /usr/sbin/apache2 -k start ├─4869 /usr/bin/php-cgi -c /var/www/php-fcgi-scripts/froxlor.panel/v22000.local/ ├─4874 /usr/sbin/apache2 -k start ├─4877 /usr/sbin/apache2 -k start ├─4878 /usr/sbin/apache2 -k start ├─4879 /usr/sbin/apache2 -k start ├─4880 /usr/sbin/apache2 -k start ├─4940 /usr/sbin/apache2 -k start └─5740 /usr/sbin/apache2 -k start Apr 16 23:48:14 v2201412723521843 systemd[1]: Started The Apache HTTP Server. Apr 17 00:33:51 v2201412723521843 Froxlor[4869]: [Administrator Action admin] [information] rebuild configfiles due to changed setting Apr 17 00:34:45 v2201412723521843 Froxlor[4869]: [Administrator Action admin] [information] added user 'kaptan' Apr 17 00:35:16 v2201412723521843 Froxlor[4869]: [Administrator Action admin] [information] added domain 'kaptan.xyz' Apr 17 00:36:28 v2201412723521843 systemd[1]: Reloading The Apache HTTP Server. Apr 17 00:36:29 v2201412723521843 apachectl[5958]: AH00543: apache2: bad user name kaptan Apr 17 00:36:29 v2201412723521843 apachectl[5958]: Action 'graceful' failed. Apr 17 00:36:29 v2201412723521843 apachectl[5958]: The Apache error log may have more information. Apr 17 00:36:29 v2201412723521843 systemd[1]: apache2.service: Control process exited, code=exited status=1 Apr 17 00:36:29 v2201412723521843 systemd[1]: Reload failed for The Apache HTTP Server. ls -al /var/customers/webs/ total 1494612 drwxr-xr-x 9 root root 4096 Apr 17 00:36 . drwxr-xr-x 6 root root 4096 Apr 13 11:00 .. -rw-r--r-- 1 root root 1530439729 Apr 12 20:09 all_backup.zip drwxr-x--- 3 10009 10009 4096 Apr 17 00:39 kaptan drwxr-x--- 7 10002 10002 4096 Apr 13 18:41 kaptans drwxr-xr-x 8 root root 4096 Apr 13 18:55 NOTactiveWEB drwxr-x--- 3 10007 10007 4096 Apr 14 19:24 test
  16. Hallo cardman, habs so gemacht, wie du gesagt hast. Funktioniert wieder. Vielen Dank. feiaweng
  17. Hallo, das klingt für mich danach, als ob die Datenbanken aus der Tabelle "panel_databases" gelöscht wurden. Möglich, das die Kunden die Datenbanken im System, sprich in Froxlor und der entsprechenden Tabelle, gelöscht haben, die Datenbank ansich aber nicht gelöscht wurde. Rein theoretisch müsstest du die Datenbanken wieder in die Übersicht bekommen, wenn du die entsprechenden Einträge in der Tabelle "panel_databases" wieder von Hand herstellst. Das die Kunden keine neuen Datenbanken mehr anlegen können, weil diese schon existieren liegt wahrscheinlich daran, das der Wert "mysql_lastaccountnumber" in der Tabelle "panel_customers" den falschen Wert hat und der daraus resultierende Datenbankname schon vorhanden ist. Wenn du die Datenbanken wie oben beschrieben wieder herstellst, musst du auch diesen Wert anpassen, auf die nächste freie Nummer (oder irgendeine beliebige weit entfernte Nummer. Gruss cardman
  18. Hallo Community, ich habe das jetzt bei mehreren Kunden festgestellt. Diese haben als Beispiel 6 DBs angelegt. Sieht man auch im phpmyadmin. In der Übersicht sehe ich aber nur 2. Eine neue anlegen über froxlor geht nicht. Dann kommt die Meldung, dass es diese schon gibt. Wie bekomme ich diese in die bestehenden in die Übersicht zurück? Sie waren ja schon mal da. Danke feiaweng
  19. Nö funktioniert alles wunderbar...Der Froxlor-Vhost (die configs mit 10_*) hat per default eine EIGENE php-fpm config, kannst du unter PHP Konfigurationen ja einfach sehen welche config von welcher domain genutzt wird....vllt findest du da die Ursache
  20. Das wollte ich meinen Kunen am Montag Morgen nicht unbedingt antun Habe dan doch noch einen anderen weg gefunden... Die alte .conf für den Froxlor Host aus "/etc/php5/fpm/pool.d/" von einem Backup nach "/etc/php/7.0/fpm/pool.d" hochgeladen und dann ein "systemctl restart php7.0-fpm" und das Controlpanel lief (der rest hatte dann gepasst). Dann im Controlpanel den php-fpm Hacken gesetzt, den Cronjob ausgeführt und die hochgeladene Datei aus dem Backup wurde nun von Froxlor überschrieben, also neu angelegt, was ja auch so sein soll. Irgendwo hat Froxlor da aber auch einen kleinen Fehler, denn es ergibt ja keinen Sinn das er in der "10_froxlor_ipandport_xx.xx.xx.xx.443.conf" auf ein Socket zeigt ohne die .conf dazu in der "pool.d" an zu legen.
  21. mod_php wieder aktivieren, alle generierten vhosts löschen und http://ip/froxlor - jast du doch selbst im ersten post geschrieben wie du das wieder erreicht hast
  22. Du kannst das auch in der SQL direkt ändern, per phpmyadmin oder per ssh. Alternativ kannst du auch den vhost für Froxlor per ssh manuel ändern.
  1. Load more activity




×
×
  • Create New...