Jump to content
Froxlor Forum

All Activity

This stream auto-updates     

  1. Past hour
  2. d00p

    acme.sh Failed

    sind denn Zertifikate in /root/.acme.sh/[domain] ? Das ist mal die grundlage. Denn froxlor synchronisiert diese mit seiner Datenbank und aus der eigenen Datenbank schreibt er die dann nach /etc/ssl/froxlor-custom/
  3. na ja, aber /etc/ssl/froxlor-custom ist immer noch leer, so lange er da die certs nicht erstellt. geht dies leider halt nicht.
  4. d00p

    acme.sh Failed

    naja, der ordner passt doch, dann hat er für tokushu.xxxxxx.eu halt einfahc kein ecc zertifikat, er sollte ja danach dann alternativ im nicht _ecc-Ordner suchen...
  5. Leider noch nicht. [error] Could not find file 'tokushu.xxxxxx.eu.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu_ecc/' [error] Could not find file 'ca.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu_ecc/' [error] Could not find file 'fullchain.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu_ecc/' [error] Could not get Let's Encrypt certificate for tokushu.xxxxxx.eu: nginx: [emerg] no "ssl_certificate" is defined for the "listen ... ssl" directive in /etc/nginx/sites-enabled/10_froxlor_ipandport_xxxxxxxx.443.conf:5 ich probiere gleich mal, wenn ich frox eine andere sub domain zuweise, ob dies geht.
  6. Yesterday
  7. Ich guck am Wochenende nochmal ganz genau, ob ich was übersehen habe. Kann natürlich nicht ausschließen dass ich irgendwo was gemacht habe, was ich nicht mehr weiß, oder das vom Debian Upgrade kommt. Wenn ich nichts finde, nehm ich jedoch gerne mal dein Angebot an draufzugucken. Ich danke dir vielmals für deine Informationen und Mühe. Ich meld mich auf jeden Fall mit einem Feedback. Gruß feiaweng
  8. Also, die nsswitch.conf sagt dem System das sie."extrausers" benutzen sollen wenn du die.korrekt eingerichtet hast. Wenn in froxlor extrausers aktiviert ist, schreibt er die User in eine passwd, group und shadow Datei nach /var/lib/extrausers Über die das extrausers Plugin die dem System bereitstellt. K.a. was du da gemacht hast, das sind normal 2min dann läuft das. Bis auf das aktivieren und config Templates laufen lassen ist doch da nix zu tun. Sorry, meine Erfahrungen bisher sagen Einfach: entweder was vergessen oder selbst irgendwo manuell in den configs rumgefrickelt ohne zu wissen was man tut - no offense. Von mir aus schau ich da gern Mal auf die Kiste - zu 99% garantiere ich dir das es nach 2min funktioniert und ich mache nichts anderes als das was ich hier erkläre
  9. Was meinst du mit Konfigurationsdateien prüfen ? Im Panel aktiviere ich die Checkbox, dass ich libnss-Extrausers nutzen will. Führe dann die Befehle aus dem Config Template aus. Wie werden denn die passwd group Shadow befüllt ? Aus der froxlor DB und dem cronjob. Im Debug zeigt er leider nur an, dass er 0 Datensätze angelegt hat. Wo kann ich denn noch gucken ?
  10. Na dann würde ich doch Mal die entsprechenden Konfigurationsdateien prüfen die du ja via config templates befüllt hast. Na weil der restart fehlschlägt Läuft er halt mit der config mit der der Dienst gestartet wurde.
  11. Hier noch eine Ausgabe, was mich wundert, warum will der unbedingt /etc/php/7.2/fpm/pool.d/www.conf haben, obwohl ich /etc/php-fpm.d konfiguriert habe? Process: 20706 ExecStopPost=/usr/lib/php/php-fpm-socket-helper remove /run/php/php-fpm.sock /etc/php/7.2/fpm/pool.d/www.conf 72 (code=exited, status=0
  12. sorry, service apache2 restart AH00543: apache2: bad user name USER apachectl[19943]: Action 'start' failed. apachectl[19943]: The Apache error log may have more information. systemd[1]: apache2.service: Control process exited, code=exited status=1 systemd[1]: Failed to start The Apache HTTP Server. service php7.2-fpm restart Starting The PHP 7.2 FastCGI Process Manager... php-fpm7.2[20704]: [04-Jun-2020 19:36:57] ERROR: [pool adrenalinpur.de] cannot get uid for user 'USER' php-fpm7.2[20704]: [04-Jun-2020 19:36:57] ERROR: FPM initialization failed systemd[1]: php7.2-fpm.service: Main process exited, code=exited, status=78/n/a systemd[1]: Failed to start The PHP 7.2 FastCGI Process Manager. libnsss-extrausers ist installiert und aktiviert. Froxlor nutzt es aus irgendeinem Grund nciht.
  13. Was sagt fpm beim Start? Ohne Fehlermeldung ist helfen schwer. "Geht nicht" ist keine Meldung. Offenbar hast Du dann libnss-extrausers nicht korrekt konfiguriert und oder in den Einstellungen nicht aktiviert
  14. so hab jetzt folgendes gemacht: dump importiert, froxlor DB update gemacht, alle Einstellungen konfiguriert im Panel, nach dem Cronjob von Froxlor kommt dann die Meldung, php7.2-fpm startet nicht. Hab wieder das Problem, dass Apache die User nicht, weil die /var/lib/extrausers files leer sind. Jetzt weiß ich grad nicht weiter.
  15. Na wenn du einen dump hast, hast du doch eh noch die Datenbank von 0.9.40 - das DB update musst du dann eh noch machen, kannst also ruhig auf dem neuen schon die 0.10.17 Dateien haben - nur frolxor brauchst du da nicht erst noch mal installieren von null, du nutzt ja eine bestehende Datenbank (also kopiere die lib/userdata.inc.php von 0.9.40 nach lib/ von 0.10.17). Danach machst du alle Einstellungen, dann konfigurierst du die Dienste. Easy
  16. also ich habe einen mysqldump vom alten Server (Debian 8 und Froxlor 0.9.40), den Dump importiere ich nun in mysql, dann habe ich alle Daten die ich brauche, dann starte ich froxlor auf dem neuen Server (Debian 9 und Froxlor 0.10.17) gehe alle Einstellungen durch, und führe die config templates aus. Oder meintest du ich soll auf dem neuen Server die Froxlor Version 0.9.40 installieren, und diese dann updaten auf 0.10.17?
  17. Warum denn Neuinstallation? Übernimm doch erstmal alles vom alten Server auf den neuen, mach dann das Update - Pass alle (neuen) Einstellungen an und rekonfiguriere dann die Dienste nach Bedarf.
  18. ok,danke, ich werde das jetzt genau so mache. Froxlor reinstallieren, dann starten, alle Einstellungen durchgehen, dann services aus den config templates konfigurieren, dann mysql import.
  19. Nein muss es natürlich nicht, wenn du es überall konsistent nutzt ist ja gut, dann sollte es ja passen. Und da stoppe ich doch schon, ERST einstellungen anpassen, DANN config-services script / manuell die config templates durchgehen. SSL für apache wird dir dann von den config-templates schon aktiviert wenn du es in den Einstellungen entsprechend aktiviert hast (und auch Let's Encrypt -> acme.conf alias usw.) wenn die Einstellungen stimmen machen die config-templates das alles für dich - deswegen ist es ja so wichtig AM ANFANG alle Einstellungen anzupassen, bevor man die Dienste konfiguriert. Zumindest ist es so der einfachste weg.
  20. Ok, ich könnte ja nochmal von vorne anfangen: mysqldump importieren Konfiguration im Panel komplett durchgehen, bzw. das install-services.php script ausführen Apache SSL aktiveren php-fpm config anpassen Wäre das der richtige Weg?
  21. Also was du im gunde gemacht hast sind wieder viele kleine Dinge auf einmal die man ganz gemütlich eine nach der anderen macht und nicht so mischt, denn so ist es gerade für jemandem der hier mitliest unglaublich schwierig das alles aufzudröseln: MySQL: Du sagst der import der gedumpten Datenbanken habe nur teilweise funktioniert ohne weitere Erläuterung, was sollen wir damit anfangen? Bei Umzug von Server A auf B beachte bitte das du auch die mysql-Datenbank mitnehmen musst, denn hier speichert der MySQL server seine Benutzer (ergo, die Zugänge zu deinen Datenbanken!). libnss-extrausers / php-fpm: Allen voran hast du meine zwei Fragen bezogen auf diese Problematik aus meiner vorherigen Antwort nicht beantwortet, ich gehe also mal nicht davon aus. Zum Anderen bezweifle ich stark das die php-fpm pool configs unter debian buster (bei default installation) in dem von dir angegebenen Ordner /etc/php-fpm.d/ liegen. Du hast also nach deinem gewaltigen Versionsprung und gleichzeitigem Aktivieren von php-fpm deine Einstellungen nicht überprüft und an dein System angepasst. Let's Encrypt: Sorry, aber das Aktivieren von php-fpm löscht sicher nicht alle Zertifikate, wie bereits gesagt, mach nicht 10 Dinge auf einmal. Richte eins nach dem anderen ein und behebe ein Problem nach dem anderen sonst weisst du am ende nicht warum woher welcher Fehler kommt weil du an 10 Schrauben gleichzeitig gedreht hast.
  22. ich habe nachdem ich die DB importiert habe, im Apache SSL und PHP_FPM deaktiviert gelassen. Im Apachen SSL aktiviert. Funktioniert. Wenn ich PHP_FPM aktiviere und den Apachen neu starte hat er alle Letsencrypt Certs gelöscht, wenn ich diese vom alten System unt /etc/apache2/ssl einfüge, lässt er sich starten. Ich muss dazu sagen, auf dem Server 1 habe ich viele LE Certs installiert. getent passwd zeigt keine mysql user an, nur die lokalen. Ausfürhren des cronjobs: /usr/bin/php7.2 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug [information] TasksCron: Searching for tasks to do [information] Task4 started - Rebuilding froxlor_bind.conf [information] Cleaning dns zone files from /etc/bind/domains/ [information] No domains found for nameserver-config, skipping... [information] apache::createIpPort: creating ip/port settings for IP:80 [notice] IP :: namevirtualhost-statement no longer needed for apache-2.4 [debug]IP :: inserted vhostcontainer [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/40-diroptions [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] Froxlor\Cron\Http\ApacheFcgi::reload: fpm config directory "/etc/php-fpm.d/" is empty. Creating dummy. [information] Froxlor\Cron\Http\ApacheFcgi::reload: running service php7.2-fpm restart [information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi [notice] Creating passwd file [notice] Writing 0 entries to passwd file [notice] Succesfully wrote passwd file [notice] Creating group file [notice] Writing 0 entries to group file [notice] Succesfully wrote group file [notice] Creating shadow file [notice] Writing 0 entries to shadow file [notice] Succesfully wrote shadow file [notice] Checking system's last guid Das Verzeichnis /etc/php-fpm.d/" war nicht leer, da sind die fpm-configs drin. Die hat er aber überschrieben. Wo soll er denn die neuen Configs herhaben?
  23. 1) auch entsprechende config Templates ausgeführt? 2) Ausgabe des Fehler des cronjobs? Wüsste nicht was du da konvertieren willst? Wo der Fehler liegt sehen wir dann wenn geforderte Info vorliegt
  24. Hallo Community, ich habe froxlor 0.9.40 auf Debian Jessie laufen, und wollte auf dem 2. Server Debian und froxlor upgraden. Nach dem Update auf Debian Stretch habe ich alle mysql-DBs gedumpt, und wollte diese auf dem anderen Server importieren. Das hat teilweise funktioniert. Sobald ich php-fpm im Panel aktiviere, und angebe, ich möchte libnss-extrausers nutzen, fährt apache nicht mehr hoch. Liegt daran, das getent passwd keine User liefert, und somit der Apache den User nicht kennt. Und die php-fpm config basiert ja noch auf libnss-mysql-bg. Wenn ich im Panel den Haken setze, ich will libnss-extrausers nutzen, legt er unter /var/lib/customers in den files passwd/group/shadow keine User an. Der cronjob mit --force --debug schlägt dann auch fehl. Muss ich die importierte mysql-DB vorher anpassen, konvertieren, damit das klappt. Oder liegt der Fehler woanders? Danke euch schon mal, welche Logs etc. braucht ihr denn? Die files kann ich gezielt liefern. Gruß feiaweng
  25. d00p

    acme.sh Failed

    Schau mal ob es das jetzt war - sollte es sein: https://github.com/Froxlor/Froxlor/commit/2c98fc4c2d2522ab3e8006b5e968bc8a39f0ff56
  26. Last week
  27. d00p

    acme.sh Failed

    Alles klar, das schränkt die Möglichkeiten ein wo ich ggfls einen Fehler gemacht habe, danke, ich schau da später gleich rein und dann finden wir das Problem sicher
  28. Ja, aber auch das Costum Ordner keine dateien vorhanden sind, verstehe ich irgendwie nicht., für domains erstellt er die. nur für die froxlor domain nicht, aber manuel ein cert erstellen geht ohne probleme. Die Domain für Froxlor, ist zwar nur eine Sub-Domain, aber die hat bisher noch nie probleme gemacht.
  1. Load more activity
×
×
  • Create New...