Jump to content
Froxlor Forum
  • 0

[gel?st] Wildcarddomain standardm?ssig auf Nein stellen


feiaweng

Question

Hallo,

 

ich habe folgende Frage:

Wenn ich eine Domain anlege, bekommt die als Attribut den Wildcardeintrag standardm?ssig auf JA.

Wenn sich der Kunde dann in Froxlor einloggt, muss er das von Hand auf Nein stellen.

Der Hintergrund ist folgender:

Ich verwalte meine Dom?nen mit einem Tool des Providers.

Im DNS haben die Dom?nen einen Wildcardeintrag.

Wenn der Kunden nun eine Subdomain anlegt, und den Host gibt es nicht, erscheint im Browser die Hauptseite.

Gibt es im Folder der Subdomain eine Webseite, wird diese angezeigt.

Ich muss so keine Zonen bereithalten, und benutze den Nameserver des Providers.

Steht im Froxlor der Wildcardeintrag auf Ja, legt der Apache im vhost einen ServerName *.domain.de an.

Der Webserver reagiert nun nicht mehr auf den Namen www.domain.de.

Daher sollte der Wildcardeintrag auf Nein stehen.

Allerdings wei? ich nicht, wie ich das bewerkstelligen soll. Ich m?chte dem Kunden ersparen, dass immer erst auf Nein stellen zu m?ssen.

Wi?t ihr an welcher Schraube ich drehen soll?

 

Danke und Gruss

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

ich versteh ehrlich gesagt dein Problem nicht, den www-alias kannst du auch von Foixlor anlegen lassen und normalerweise freut sich der Kunde wenn nicht angelegt subdomains auf seine Seite zeigen anstatt auf den froxlor-Login (das wurde mal extra deswegen umgestellt, weil soviele das gerne so h?tten)

Link to comment
Share on other sites

Hallo,

 

das Problem ist, wenn der Wildcardeintrag auf Ja steht, legt er nur einen ServerAlias *.domain.de an. Nicht aber einen www.domain.de.

Ich hab das grad getestet, komischerweise kommt jetzt auch die Seite, wenn ich www.domain.de eingebe, das ging vorher nicht.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...