Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Marcus

[solved] Apache startet nicht - bad username

Question

Hi,

 

Ich habe Froxlor 0.9.12 installiert ?ber apt-get und alles konfiguriert. Das anlegen von Kunden und Domains klappt auch, aber danach passiert nichts mehr. Wenn man die Domain anw?hlt, erscheint nur "It works!" und das wars. Die Ordner und Dateien legt Froxlor aber alle genau so an, wie er es soll. Der Apache spuckt bei einem reload bzw restart folgendes aus:

 

 * Restarting web server apache2
apache2: bad user name xxx
  ...fail!

 

Ich habe jetzt wirklich keine Ahnung mehr, woran das liegen soll. Was mich jedoch wundert ist, dass der Apache den Benutzernamen angibt, Wenn Ich im Ordner der Webs Ordner und Besitzer anzeigen lasse, werden dort nur die IDs und nicht die Namen geschrieben. Kann es damit zusammenh?ngen?

 

Ich bin f?r jede Hilfe dankbar. Wenn ihr Informationen braucht, schreibt mir bitte welche.

 

Lg

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

Hi,

 

Ich habe Froxlor 0.9.12 installiert ?ber apt-get und alles konfiguriert. Das anlegen von Kunden und Domains klappt auch, aber danach passiert nichts mehr. Wenn man die Domain anw?hlt, erscheint nur "It works!" und das wars. Die Ordner und Dateien legt Froxlor aber alle genau so an, wie er es soll. Der Apache spuckt bei einem reload bzw restart folgendes aus:

 

 * Restarting web server apache2
apache2: bad user name xxx
  ...fail!

 

Ich habe jetzt wirklich keine Ahnung mehr, woran das liegen soll. Was mich jedoch wundert ist, dass der Apache den Benutzernamen angibt, Wenn Ich im Ordner der Webs Ordner und Besitzer anzeigen lasse, werden dort nur die IDs und nicht die Namen geschrieben. Kann es damit zusammenh?ngen?

 

Ich bin f?r jede Hilfe dankbar. Wenn ihr Informationen braucht, schreibt mir bitte welche.

 

Lg

 

Ich habe das Problem gel?st, indem Ich meinen Server neu gestartet habe. Ich w?rde nur gerne wissen, warum das das Problem l?ste? Wei? einer bescheid?

Share this post


Link to post
Share on other sites

Wie w?re es mal die Konfiguration vollst?ndig durch zuf?hren? ;)

 

Hast du bereits libnss konfiguriert [ <OS> ? Sonstige (System) ? libnss (system login with mysql) ]?

 

 

Nachtrag: Du brauchst deine Beitr?ge nicht auch noch in englisch zu schreiben. Ein Gro?teil der Community wie auch die Hauptentwickler sprechen deutsch ;)

Share this post


Link to post
Share on other sites

Vermutlich hast du einen der Services nach der Konfiguration nicht neugestartet (nscd z.B.) so dass es den Anschein hat, ein Serverreboot h?tte alles wieder "eingerenkt".

 

Die "bad user name xxx" meldung taucht immer dann auf, wenn:

 

1) Du FCGID nutzt, aber libnss-mysql nicht eingerichtet hast

2) z.B. der Mysql-Server nicht l?uft und so libnss die usernames nicht aus der datenbank auslesen kann

3) z.B. der nscd-Dienst (libnss) nicht l?uft, dieser weiss wo er die usernames in der Datenbank findet, liest diese f?r den jeweiligen Service aus und cached die Resultate, damit nicht st?ndig aus der DB gelesen werden muss

Share this post


Link to post
Share on other sites

Dieses Problem ist mir ebenfalls bekannt jedoch nur ?hnlich.

 

Undzwar tritt es beim L?schen von Kunden auf.

Ich sch?tze mal es ist irgendwo verwandt - evtl. l?scht Froxlor da etwas nicht richtig?!

Share this post


Link to post
Share on other sites

evtl hast du den Apache neugestartet bevor der cronjob lief aber durch das L?schen die user-Tabelle schon leer ist f?r den user

Share this post


Link to post
Share on other sites

Hallo,

 

ich h?nge mich mal hier dran, denn ich habe genau das gleiche Problem.

Nur dass es bei mir bei jedem Neustart auftritt.

 

Ich hatte ein vollst?ndig funktionierendes System, basierend auf debian squeez 64Bit.

Nun habe ich fcgi nach dieser Anleitung installiert.

http://wiki.froxlor.org/contrib/german/de-fcgid-handbook

 

Es funktioniert auch alles prima, aber ich habe 2 Probleme:

- Der Apache Dienst wird bei einem Neustart nie gestartet

Starting web server: apache2apache2: bad user name [Name eines Benutzers] Action 'start' failed.

Wenn ich den Dienst von der Shell aus starte funktionierts

 

- Das Froxlor Webinterface ist nicht aufrufbar.

Er will immer eine php Datei runterladen statt sie auszuf?hren, aber nur beim froxlor. Bei allen Kunden funktionierts ohne Probleme.

 

Hat da mal Jemand einen Tipp f?r mich?

 

Danke

Share this post


Link to post
Share on other sites

Hallo,

ich hab mein Image zur?ckgespielt und es nochmal gemacht.

Nun gehts, denn ich hatte den Punkt "Damit das auch funktioniert, ist noch folgendes einzustellen: In Froxlor einloggen, dann Einstellungen ? FCGID ? Konfiguration und dort die Checkbox Verwende FCGID im Froxlor Vhost aktivieren." ?bersehen.

 

Zwei Dinge sind mir aber in der Anleitung aufgefallen.

 

Beim anlegen des Users fragt er ja nach einem Kennwort. Ich habe dort eines eingetragen und mir notiert.

Dies sollte im Text erw?hnt werden.

 

Au?erdem steht in Puntk 8 "In der Froxlor-?bersicht nachschauen ob nun CGI-FCGI angezeigt wird. Wenn ja, ist alles richtig verlaufen und Froxlor wird nun mit dem Froxlor-Benutzer ausgef?hrt."

Da bekomme ich nur eine Fehlermeldung (You have to make the file "./lib/userdata.inc.php" readable for the http-process!).

Die kommt, da der Cron-Job ja noch nicht gelaufen ist.

Wenn man weitermacht funktioniert ja alles, aber das iritiert doch sehr.

 

Weiter so...

 

Stefan

Share this post


Link to post
Share on other sites

sawasdee krub

 

ein nach Reboot nicht ?ber die Startscripte/Runlevel automatisch zu startender Apache2, "bad user name", liegt an der Reihenfolge der Startscripte!

Wird apache2 vor mysql und nscd gestartet, sind dem System die in der MySQL gespeicherten User nicht bekannt und der Aache2 ist ?belst verwirrt.

 

L?sung:

Unter Insserv die Parameter Required-Start und Required-Stop im entspr. Startscript um "$mysql $nscd" erweitern. So setzt Insserv den Apachen erst nach mysql und nscd.

Ohne Insserv einfach an den Nummern der SymLinks (zB S012apache2) unter /etc/rc*.d schrauben und die Nummer des apachen2 h?her als mysql und nscd setzen.

Share this post


Link to post
Share on other sites

Hallo snappy_panther,

 

ich bekomme es einfach nicht hin.

Egal wie ich es drehe die Fehlermeldung beim starten des Servers bleibt immer.

 

Von Hand kann ich den apache2 immer starten.

 

Log

Using makefile-style concurrent boot in runlevel 3.

Starting enhanced syslogd: rsyslogd.

Starting domain name service...: bind9.

Starting web server: apache2apache2: bad user name domain Action 'start' failed. The Apache error log may have more information. failed!

Starting Courier authentication services: authdaemond.

Starting Courier IMAP server: imapd.

Starting Courier POP3 server: pop3d.

Starting MySQL database server: mysqld. Checking for tables which need an upgrade, are corrupt or were not closed cleanly..

Starting Name Service Cache Daemon: nscd. Starting periodic command scheduler: cron.

Starting ftp server: proftpd. Starting SpamAssassin Mail Filter Daemon: spamd.

Starting Postfix Mail Transport Agent: postfix.

Starting OpenBSD Secure Shell server: sshd.

startpar: service(s) returned failure: apache2 ... failed!

 

Das einzige was ich den in den Logs finde ist, dass nscd nicht auf den mysql Server zugreifen kann.

 

Ich habe die Skripte angepa?t wie es unten steht und dann "insserv" gestartet.

Er baut die .depend.start neu auf, aber es sieht nicht so aus, als ob die Eintr?ge verwendet werden.

 

Kann mir bitte Jemand sagen was ich ?bersehen habe?

 

Debian Suqeeze 64Bit, gerade frisch installiert.

Apache2, Froxlor, FCGI

 

 

/etc/init.d/apache2

#!/bin/sh

### BEGIN INIT INFO

# Provides: apache2

# Required-Start: $local_fs $remote_fs $network $syslog $named $mysql $nscd

# Required-Stop: $local_fs $remote_fs $network $syslog $named

# Default-Start: 2 3 4 5

# Default-Stop: 0 1 6

# X-Interactive: true

# Short-Description: Start/stop apache2 web server

### END INIT INFO

 

/etc/init.d/nscd

#!/bin/sh

### BEGIN INIT INFO

# Provides: nscd

# Required-Start: $remote_fs $syslog $mysql

# Required-Stop: $remote_fs $syslog

# Default-Start: 2 3 4 5

# Default-Stop: 0 1 6

# Short-Description: Starts the Name Service Cache Daemon

### END INIT INFO

 

/etc/init.d/.depend.start

TARGETS = rsyslog spamassassin nscd bind9 mysql courier-authdaemon courier-imap courier-pop single ssh apache2 proftpd postfix cron rc.local

INTERACTIVE = apache2

spamassassin: rsyslog

nscd: rsyslog

bind9: rsyslog

mysql: rsyslog

courier-authdaemon: rsyslog

courier-imap: rsyslog

courier-pop: rsyslog

ssh: rsyslog

apache2: rsyslog bind9

proftpd: rsyslog bind9

postfix: rsyslog bind9 mysql spamassassin

cron: rsyslog bind9 nscd

rc.local: rsyslog spamassassin nscd bind9 mysql courier-authdaemon courier-imap proftpd postfix apache2 courier-pop ssh cron

Share this post


Link to post
Share on other sites

 

Au?erdem steht in Puntk 8 "In der Froxlor-?bersicht nachschauen ob nun CGI-FCGI angezeigt wird. Wenn ja, ist alles richtig verlaufen und Froxlor wird nun mit dem Froxlor-Benutzer ausgef?hrt."

Da bekomme ich nur eine Fehlermeldung (You have to make the file "./lib/userdata.inc.php" readable for the http-process!).

Die kommt, da der Cron-Job ja noch nicht gelaufen ist.

Wenn man weitermacht funktioniert ja alles, aber das iritiert doch sehr.

 

Weiter so...

 

Stefan

 

Das Froxlor-Verzeichnis auch dem Froxloruser zugewiesen?

 

chown -R froxloruser:froxloruser froxlor/

Share this post


Link to post
Share on other sites

Das Froxlor-Verzeichnis auch dem Froxloruser zugewiesen?

chown -R froxloruser:froxloruser froxlor/

 

Hallo Timo,

 

Ja. Den gleichen Fehler hatte ich eben auch f?r ca. 1 Minute beim Update von 9.23 auf 9.24.

 

Stefan

Share this post


Link to post
Share on other sites

Hallo Froxlor Gemeinde.

 

Ich muss das Thema hier noch mal aufgreifen, ich bin jetzt seit 2 std. auf Fehlersuche und habe diesen Thread rauf und runter gelesen, aber geholfen hat das nicht wirklich, ich kann apache2 nicht mehr starten auch mit einem Server reboot nicht.

 

Starting web server: apache2apache2: bad user name web1
Action 'start' failed.
The Apache error log may have more information.

 

Diese Meldung kommt, nachdem ich einen Kunden angelegt hatte.

 

Mir sind hierzu die Ideen ausgegenagen und w?rde mich ?ber Tipps freuen, da ich den Server nicht neu aufsetzen m?chte.

 

Hier noch mein System: Debian 6 Squeeze (64)

Share this post


Link to post
Share on other sites

Hi,

 

hast du mal in den Apache Logs nach der entsprechenden Meldung geschaut? W?re evtl hilfreich wenn du uns die betreffenden Zeilen posten k?nntest.

Share this post


Link to post
Share on other sites

Hallo,

 

hatte schon geguckt, aber da steht nichts drin ausser:

 

No such file or directory: apache2: could not open error log file /var/customers/logs/web1-error.log.
Unable to open logs

 

Aber das kommt daher, da ich beim einrichten den Pfad nicht ge?ndert hatte.

 

Ich habe das Verzeichnis "Kunden" anstatt Customer genommen.

Share this post


Link to post
Share on other sites

Hallo,

 

hatte schon geguckt, aber da steht nichts drin ausser:

 

No such file or directory: apache2: could not open error log file /var/customers/logs/web1-error.log.
Unable to open logs

 

Aber das kommt daher, da ich beim einrichten den Pfad nicht ge?ndert hatte.

 

Ich habe das Verzeichnis "Kunden" anstatt Customer genommen.

Es w?re sicherlich von Vorteil wenn du zumindest tempor?r die Logdatei anlegen k?nntest. Apache sollte eine bessere Fehlerbeschreibung evtl in die Datei schreiben. Btw denke ich das es sehr von Vorteil ist wenn du f?r den Notfall Logs zur Verf?gung hast. Entsprechend w?rde ich dir empfehlen die Logs "zu aktivieren", kann auch sp?ter sehr von Hilfe sein, wenn andere Probleme auftreten. Kannst den Logpfad ?ber Settings->Webserver Settings ?ndern.

Share this post


Link to post
Share on other sites





×
×
  • Create New...