Jump to content
Froxlor Forum
  • 0

FCGI / verschiedene PHP.ini


Marco

Question

Hey Leute,

 

ich m?chte gerne mehrere PHP.ini's. Daf?r habe ich das HowTo von SysCP genutzt: http://wiki.syscp.org/contrib/php-fcgi-ger

 

Dabei habe ich die Option 2 genutzt und habe alles gemacht au?er "PHP als FastCGI kompilieren" und "SysCP anpassen".

 

Sind diese Schritte zwingend n?tig? Ich habe ja PHP per apt installiert und kann ja dadurch nicht ./configure ausf?hren (wenn ich es richtig verstanden habe)

 

Naja auf jeden Fall funktioniert es nicht mit den PHP.ini's.

 

Die Konfiguration sieht man ja in der Anleitung.

 

Wisst ihr evt. woran das liegen k?nnte?

 

Die Logs sagen auch nichts besonderes.

 

Gr??e

Link to post
Share on other sites

21 answers to this question

Recommended Posts

Hey ihr,

 

ich habe alles gemacht wies im Wiki steht.

 

Leider immer noch das selbe Ergebnis. Alle Domains greifen auf die gleiche PHP.ini zu.

 

und wenn ich

 

a2dismod php5

 

ausf?hre, wird die PHP Datei heruntergeladen.

 

gr??e :(

Link to post
Share on other sites

Wenn du Debian nutzt: versuch mal ein "apache stop" und "apache start"...debian ist da leicht merkw?rdig, und braucht manchmal mehr als nen restart, ebenso kannst du versuchen deinen Browser-Cache zu leeren, hilft auch oft

Link to post
Share on other sites

?hm bei mir laufen nur folgende prozesse:

 

root     18272  0.0  0.4 126276  4632 ?        Ss   17:08   0:00 /usr/sbin/apache2 -k start
www-data 18277  0.0  0.2 125700  2560 ?        S    17:08   0:00  \_ /usr/sbin/apache2 -k start
www-data 18286  0.0  0.3 126276  3316 ?        S    17:08   0:00  \_ /usr/sbin/apache2 -k start
www-data 18287  0.0  0.2 126276  2804 ?        S    17:08   0:00  \_ /usr/sbin/apache2 -k start
www-data 18288  0.0  0.2 126276  2804 ?        S    17:08   0:00  \_ /usr/sbin/apache2 -k start
www-data 18289  0.0  0.2 126276  2804 ?        S    17:08   0:00  \_ /usr/sbin/apache2 -k start
www-data 18290  0.0  0.2 126276  2804 ?        S    17:08   0:00  \_ /usr/sbin/apache2 -k start
www-data 18296  0.0  0.2 126276  2804 ?        S    17:08   0:00  \_ /usr/sbin/apache2 -k start

 

da kann doch was nicht stimmen...obwohl ich alles nach der anleitung gemacht habe

Link to post
Share on other sites

Eigentlich hatte ich Apache sehr oft neugestartet...

 

Ich sagte explizit nicht neustarten, sondern stoppen und danach wieder starten, das macht bei Debian manchmal einen gro?en Unterschied

Link to post
Share on other sites

Error-Log:

 

[sun Jun 27 17:06:32 2010] [notice] caught SIGTERM, shutting down
[sun Jun 27 17:06:33 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[sun Jun 27 17:06:33 2010] [notice] Apache/2.2.9 (Debian) mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
[sun Jun 27 17:06:41 2010] [notice] caught SIGTERM, shutting down
[sun Jun 27 17:06:54 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[sun Jun 27 17:06:54 2010] [notice] Apache/2.2.9 (Debian) mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations

 

Ja PHP5 habe ich dann wieder deaktiviert gehabt.

 

Gr??e

Link to post
Share on other sites

du kannst auch einfach das rootpasswort f?r 2 min ?ndern? ich kann dir nur anbieten zu helfen. Aber ohne root ist das fast so, wie wenn du einem Handwerker nicht erlaubst Werkzeug zu benutzen ;-)

Link to post
Share on other sites

unter debian gibts daf?r einfach ein zus?tzliches paket php5-cgi, am besten folgst du unserem Handbuch: http://wiki.froxlor.org/contrib/fcgid-handbook

 

Das Handbuch befolgen h?tte das Problem gel?st. Handbuch nicht gelesen oder nicht befolgt, keinerlei Einstellungen wurden gemacht und keine entsprechenden Pakete geladen. H?tte alles in 10 min erledigt sein k?nnen.

 

EDIT: und danke f?r die negativ-Reputation f?rs Ehrlich sein...

Link to post
Share on other sites

Hallo,

 

so Thema wurde wieder ge?ffnet, da das Problem immer noch besteht.

 

Das Handbuch habe ich dieses Mal genau befolgt und die einzelnen User angelegt.

 

Sobald ich auf eine Website gehe, wird immer noch die PHP Datei runtergeladen.

 

Suexec sowie FCGI ist aktiviert.

 

Die Prozesse von den einzelnen Usern laufen auch komischer Weise nicht.

 

Jemand ne Idee?

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...