Skip to content
View in the app

A better way to browse. Learn more.

Froxlor Forum

A full-screen app on your home screen with push notifications, badges and more.

To install this app on iOS and iPadOS
  1. Tap the Share icon in Safari
  2. Scroll the menu and tap Add to Home Screen.
  3. Tap Add in the top-right corner.
To install this app on Android
  1. Tap the 3-dot menu (⋮) in the top-right corner of the browser.
  2. Tap Add to Home screen or Install app.
  3. Confirm by tapping Install.

Default option to add DMARC record to each domain

Featured Replies

I have set up SPF and DKIM for the domains provided by Froxlor, that works pretty straight forward except for the opendkim thing, but I got it working.

Now I am wondering if it is possible to add a DNS record for DMARC to each domain that is maintained automatically, this would be a TXT record

with _dmarc TXT "fixed string" or a domain-by-domain entry when using a different feedback address for different domains

for domains that are manually maintained that works by adding it manually, but a generic rule for all domains would be helpful

 

That's already in 2.2-dev...current main-branch.

  • 1 month later...

Hi,

i set my update channel to "nightly" and updatet my froxlor installation to 2.2-dev.

Now I´m able to edit SPAM Settig, etc, and everything seems to work.
But after a little time, i got an timeout and want relogin, but this di not work :(

SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'WHERE `loginname`= 'admin'' at line 1

 

Be sure to have the l latest version, nightlies are build after each push to the repository. Just run `bin/froxlor-cli froxlor:update` as root in your shell

root@ps-gronau:/var/www/html/froxlor# bin/froxlor-cli froxlor:update
You already have the latest nightly-version of Froxlor installed.

 

Then please set $sql['debug'] to 'true' in lib/userdata.inc.php and try to reproduce the issue so we have a full trace

A database error occurred

SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'WHERE `loginname`= 'admin'' at line 1


 

#0 /var/www/html/froxlor/lib/Froxlor/Database/Database.php(122): PDOStatement->execute()
#1 /var/www/html/froxlor/index.php(287): Froxlor\Database\Database::pexecute()
#2 {main}


			SELECT * FROM  WHERE `loginname`= :loginname

 

Hi,

steht doch oben ;) Updated Froxlor, configured the new features, drink a coffee, come back to my computer, have to relogin (Time out) and then the error occurs.
It seems, that only the login does not work.

 

Just now, PC Service Gronau said:

Hi,

steht doch oben ;) Updated Froxlor, configured the new features, drink a coffee, come back to my computer, have to relogin (Time out) and then the error occurs.
It seems, that only the login does not work.

"Login does not work" hilft halt nicht. Als customer? Als admin? Hast du 'domain_login' aktiviert und loggst dich vllt damit ein?

Reproducable when "login with domain" is active, try the following patch:

diff --git a/index.php b/index.php
index c2f6d911..90fbdd53 100644
--- a/index.php
+++ b/index.php
@@ -220,11 +220,14 @@ if ($action == '2fa_entercode') {
                                                }
                                        }
                                }
-                       } else {
-                               $is_admin = true;
                        }
                }

+               if (empty($table)) {
+                       // try login as admin of no customer-login method worked
+                       $is_admin = true;
+               }
+
                if ((Froxlor::hasUpdates() || Froxlor::hasDbUpdates()) && $is_admin == false) {
                        Response::redirectTo('index.php');
                        exit();

 

Moin,

also Login war als Admin, Domainlogin ist nicht aktivert.
Mein Problem hat sich allerdings gerade nach einem "/var/www/html/froxlor/bin/froxlor-cli froxlor:update" erledigt. Ich konnte mich direkt nach dem Update so wieder Einloggen. Danke für den Support und gruss aus Gronau

Just now, PC Service Gronau said:

Moin,

also Login war als Admin, Domainlogin ist nicht aktivert.
Mein Problem hat sich allerdings gerade nach einem "/var/www/html/froxlor/bin/froxlor-cli froxlor:update" erledigt. Ich konnte mich direkt nach dem Update so wieder Einloggen. Danke für den Support und gruss aus Gronau

Ganz sicher das Domain-Login nicht aktiviert ist? Das ist eigentlich die einzige chance das der Fehler auftreten kann...und klar gehts jetzt nach dem update, hab den patch ja schon commited und die neue nightly gebaut...

Habe gerade in die Konteneinstellung geschaut und der Punkt "Erlaube Anmeldung mit Domains" ist tatsächlich aktiviert. Habe ich allerding bisher noch nicht genutzt.

Eine Frage habe ich noch. Kann ich jetzt die Paketquelle für die Updates gefahrlos zurück auf stable stellen oder wird das Probleme verursachen? Hatte nightly nur als Quelle gewählt um die neuen Spamfilterregeln nutzen zu können.

Ein Downgrade ist nicht möglich, aber natürlich kannst du den Update-Kanal auf "stable" stellen, dann wirst du erst wieder updates bekommen, wenn es einen release gibt (mit 2.2.x)

Create an account or sign in to comment

Account

Navigation

Search

Search

Configure browser push notifications

Chrome (Android)
  1. Tap the lock icon next to the address bar.
  2. Tap Permissions → Notifications.
  3. Adjust your preference.
Chrome (Desktop)
  1. Click the padlock icon in the address bar.
  2. Select Site settings.
  3. Find Notifications and adjust your preference.