Jump to content
Froxlor Forum
  • 0

Froxlor per subdomain aufrufen


xep22
 Share

Question

hi,

ich hatte im alten System eingerichtet dass ich mit froxlor.domain.tld Froxlor erreiche. wie richte ich das wieder ein ? Was trage ich als Pfad ein?

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Das machst du normal bei der Installation und gibts deine Wunsch-Domain die du nutzen möchtest, subdomain oder nicht, in das "Servername" Feld ein. Der Pfad für den Vhost wird automatisch auf die root-directory von froxlor gesetzt, hier musst du nichts explizit angeben.

Nochmal um es klar zu machen: Du trägst hier keine Domain/Kunden-Domain ein und setzt den Pfad auf /var/www/froxlor o.Ä. - das wird nichts bzgl. Berechtigungen etc.

Die Einstellung zum System-Hostname findest du unter Einstellungen -> System-Einstellungen -> Hostname; eine Anpassung der Einstellung ist durchaus möglich, bedenke aber das z.B. bereits vorhandene Standard-Subdomains (e.g. username.dein-hostname.tld) nicht mit aktualisiert werden!

Link to comment
Share on other sites

  • 0

aber das ist doch nur der hostname ? hier habe ich beim Einrichten server.domain.tld eingetragen, aber mit server.domain.tld komme ich ja jetzt nicht auf froxlor... Ich meine, ich hab das damals mit einer Subdomain bei einem kunden eingerichtet. Zumal ich für die Subdomain auch ein SSL-Zertifikat genutzt habe.

außerdem kann ich bei Hostname nicht "/var/www/froxlor" eintragen, da kommt ein Fehler. 

Link to comment
Share on other sites

  • 0

was meinst du mit "nur der hostname"

1) Du hast beim einrichten "server.domain.tld" eingegeben, das ist also dein Hostname für Froxlor

2) "aber mit server.domain.tld komme ich ja jetzt nicht auf froxlor.", versuchs mal mit http://server.domain.tld/froxlor - oder stelle in den Froxlor Vhost Einstellungen ganz oben ein, dass froxlor direkt über den hostnamen erreichbar sein soll.

3) "Ich meine, ich hab das damals mit einer Subdomain bei einem kunden eingerichtet." - das ist schlichtweg nicht richtig und auch nicht sinnvoll

4) "Zumal ich für die Subdomain auch ein SSL-Zertifikat genutzt habe." - hat damit nix zu tun, du kannst auch für den hostname ein ssl-zertifikat hinterlegen / let'S encrypt verwenden

5) "außerdem kann ich bei Hostname nicht "/var/www/froxlor" eintragen, da kommt ein Fehler. " - von welcher Einstellung/welchem Feld exakt sprichst du hier? Wie bereits gesagt, froxlor sorgt selbst für seinen vhost, du brauchst da nirgends /var/www/froxlor eintragen...

Link to comment
Share on other sites

  • 0
vor 5 Minuten schrieb d00p:

2) "aber mit server.domain.tld komme ich ja jetzt nicht auf froxlor.", versuchs mal mit http://server.domain.tld/froxlor - oder stelle in den Froxlor Vhost Einstellungen ganz oben ein, dass froxlor direkt über den hostnamen erreichbar sein soll.

Das geht.

vor 5 Minuten schrieb d00p:

hat damit nix zu tun, du kannst auch für den hostname ein ssl-zertifikat hinterlegen / let'S encrypt verwenden

aber wie mache ich das jetzt ? muss ich server nicht als Subdomain hinzufügen für domain.tld damit das Zertifikat erstellt wird ?

Link to comment
Share on other sites

  • 0
Just now, xep22 said:

aber wie mache ich das jetzt ? muss ich server nicht als Subdomain hinzufügen für domain.tld damit das Zertifikat erstellt wird ?

hä? Nein. Du kannst auch Zertifikate nur für Subdomains haben...

Einstellungen -> Froxlor Vhost Einstellungen -> Enable Let's Encrypt for the froxlor vhost

Link to comment
Share on other sites

  • 0

mir fällt jetzt aber auf, wenn eine domain auf meinen server zeigt welche in Froxlor nicht hinterlegt ist bzw. man die IP aufruft im Browser, landet man bei server.domain.tld. wie schalte ich das ab ?

Link to comment
Share on other sites

  • 0

Der webserver geht immer auf den ersten vhost den er eingelesen hat, wenn er die domain nicht kennt, du könntest also z.B. einen eigenen vhost anlegen, sagen wir 001-default-unknown.conf und das dort abfangen

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...