Jump to content
Froxlor Forum

xep22

Members
  • Content Count

    43
  • Joined

  • Last visited

Everything posted by xep22

  1. im... ? also zu deiner 1. Antwort: Hostname ist server.example.com. in froxlor soll ich jetzt aber nur "example.com" angeben oder wie ? und die Domain ist ja natürlich aber für einen Kunden angelegt.
  2. hab jetzt doch eine einfache möglichkeit gefunden : Domain "froxlor.example.com" für Kunde der Domain "example.com" anlegen -> ServerAlias-Angabe für Domain = www -> DocumentRoot = /var/www/html/Froxlor/
  3. wie kann ich froxlor über froxlor.example.com erreichbar machen ? Subdomain "froxlor" ist angelegt , was was muss in den Pfad ? habe schon dinge wie /var/www/froxlor/ probiert.
  4. hä? die pfade raus löschen also? was soll das aber bringen? habe ich mal gemacht und den Cron ausgeführt : [information] cron_tasks: Searching for tasks to do [information] apache::createIpPort: creating ip/port settings for 91.200.103.22 7:80 [notice] 91.200.103.227:80 :: namevirtualhost-statement no longer needed for apa che-2.4 [debug] 91.200.103.227:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for 91.200.103.22 7:443 [error] root.janis0705.tk :: empty certificate file! Cannot create ssl-directive s [debug] 91.200.103.227:443 :: inserted vhostcontainer [information] apache::createVirtualHosts: creating vhost container for domain 2, customer user1 [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] apache::reload: reloading apache [information] Task4 started - Rebuilding froxlor_bind.conf [information] Cleaning dns zone files from /etc/bind/domains/ [debug] domId domain ismainbutsubto parent d omain list of child domain ids [debug] 2 janis0705.tk 0 - [information] `/etc/bind/domains/janis0705.tk.zone` written [debug] Generating dns config for janis0705.tk [information] froxlor_bind.conf written [information] bind daemon reloaded [information] Task4 finished [notice] Checking system's last guid
  5. ja das sagte ich ja, die Certs für apache fehlen... bzw. die im Ordner von apache halt. wo entferne ich die im Panel? da sind ja nur die Pfade.
  6. ja schon. aber wie bereits erwähnt erhalte ich ohne die 2 Certs in /etc/apache2 nach einem Neustart von Apache2 den error: Mai 11 15:10:00 root.eurenikz.de systemd[1]: apache2.service: Failed with result 'exit-code'. Mai 11 15:10:00 root.eurenikz.de systemd[1]: Starting The Apache HTTP Server... Mai 11 15:10:00 root.eurenikz.de apachectl[22701]: AH00526: Syntax error on line 14 of /etc/apache2/sites-enabled/10_froxlor_ipandport_185.254.97.69.443.conf: Mai 11 15:10:00 root.eurenikz.de apachectl[22701]: SSLCertificateFile: file '/etc/apache2/apache2.pem' does not exist or is empty Mai 11 15:10:00 root.eurenikz.de apachectl[22701]: Action 'start' failed. Mai 11 15:10:00 root.eurenikz.de apachectl[22701]: The Apache error log may have more information.
  7. welches selbst erstellt für apache? wie gesagt habe ich es jetzt ohne opensll eingerichtet. Froxlor erstellt doch neben den webseiten-Zertifikaten auch die für apache oder nicht ? error.log : [Sat May 11 10:34:00.140950 2019] [ssl:warn] [pid 367] AH01906: janis0705.tk:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?) [Sat May 11 10:34:00.141013 2019] [ssl:warn] [pid 367] AH01909: janis0705.tk:443:0 server certificate does NOT include an ID which matches the server name
  8. jetzt ist sie da : # 35_froxlor_ssl_vhost_janis0705.tk.conf # Created 11.05.2019 12:28 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 2 (SSL) - CustomerID: 1 - CustomerLogin: user1 <VirtualHost 91.200.103.227:443> ServerName janis0705.tk ServerAlias www.janis0705.tk ServerAdmin gwegew@egewew.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/froxlor-custom/janis0705.tk.crt SSLCertificateKeyFile /etc/ssl/froxlor-custom/janis0705.tk.key SSLCACertificateFile /etc/ssl/froxlor-custom/janis0705.tk_CA.pem SSLCertificateChainFile /etc/ssl/froxlor-custom/janis0705.tk_chain.pem <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=0" </IfModule> DocumentRoot "/var/customers/webs/user1/" php_admin_value sendmail_path "/usr/sbin/sendmail -t -f gwegew@egewew.de" php_admin_value open_basedir "/var/customers/webs/user1:/tmp" ErrorLog "/var/customers/logs/user1-error.log" CustomLog "/var/customers/logs/user1-access.log" combined </VirtualHost> die Apache-Zertifikate fehlen aber immer noch.
  9. Ja ist es. damit erhalte ich : [information] Updating Let's Encrypt certificates [information] Updating janis0705.tk [information] Adding SAN entry: janis0705.tk [information] Adding SAN entry: www.janis0705.tk [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to genera te certificate [information] letsencrypt Using existing account key [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for janis0705.tk [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for janis0705.tk [information] letsencrypt Token for janis0705.tk saved at /var/www/froxlor/.well -known/acme-challenge/H8njL3drd-mJsxzBslhVR3zaOGs_nvp6-boQB_OV5Lg and should be available at http://janis0705.tk/.well-known/acme-challenge/H8njL3drd-mJsxzBslhV R3zaOGs_nvp6-boQB_OV5Lg [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsenc rypt.org/acme/challenge/5bmoerVxtc2BpY1TQAjIgKsLNCyWSm2AEF6fSbuGCWo/15705940615 [information] letsencrypt Verification ended with status: valid [information] letsencrypt Requesting challenge for www.janis0705.tk [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for www.janis0705.tk [information] letsencrypt Token for www.janis0705.tk saved at /var/www/froxlor/. well-known/acme-challenge/4o-Cpq3j4vASY8hF2rYbggLzOEClgLwN7qxltrW0n5A and should be available at http://www.janis0705.tk/.well-known/acme-challenge/4o-Cpq3j4vAS Y8hF2rYbggLzOEClgLwN7qxltrW0n5A [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsenc rypt.org/acme/challenge/Mlk_Oakw17OOQZOSgnlSHaR2NsYC1WjB3oonWTyx1dI/15706079190 [information] letsencrypt Verification ended with status: valid [information] letsencrypt Sending signed request to /acme/new-cert [information] letsencrypt Got certificate! YAY! [information] letsencrypt Requesting chained cert at https://acme-v01.api.letsencrypt.org/acme/issuer-cert [information] letsencrypt Done, returning new certificates and key [information] Updated Let's Encrypt certificate for janis0705.tk [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid das sieht mir aber nur aus wie das Website-zertifikat, nicht für apache.
  10. SSL-config habe ich komischerweise keine.die froxlor settings stimmen mMn.
  11. ahh : # 35_froxlor_normal_vhost_janis0705.tk.conf # Created 10.05.2019 20:37 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 2 - CustomerID: 1 - CustomerLogin: user1 <VirtualHost 91.200.103.227:80> ServerName janis0705.tk ServerAlias *.janis0705.tk ServerAdmin mail@example.com DocumentRoot "/var/customers/webs/user1/" php_admin_value sendmail_path "/usr/sbin/sendmail -t -f mail@example.com" php_admin_value open_basedir "/var/customers/webs/user1:/tmp" ErrorLog "/var/customers/logs/user1-error.log" CustomLog "/var/customers/logs/user1-access.log" combined </VirtualHost>
  12. Meinst du die 000-default.conf ? <VirtualHost *:80> # The ServerName directive sets the request scheme, hostname and port that # the server uses to identify itself. This is used when creating # redirection URLs. In the context of virtual hosts, the ServerName # specifies what hostname must appear in the request's Host: header to # match this virtual host. For the default virtual host (this file) this # value is not decisive as it is used as a last resort host regardless. # However, you must set it for any further virtual host explicitly. #ServerName www.example.com ServerAdmin webmaster@localhost DocumentRoot /var/www # Available loglevels: trace8, ..., trace1, debug, info, notice, warn, # error, crit, alert, emerg. # It is also possible to configure the loglevel for particular # modules, e.g. #LogLevel info ssl:warn ErrorLog ${APACHE_LOG_DIR}/error.log CustomLog ${APACHE_LOG_DIR}/access.log combined # For most configuration files from conf-available/, which are # enabled or disabled at a global level, it is possible to # include a line for only one particular virtual host. For example the # following line enables the CGI configuration for this host only # after it has been globally disabled with "a2disconf". #Include conf-available/serve-cgi-bin.conf </VirtualHost> # vim: syntax=apache ts=4 sw=4 sts=4 sr noet
  13. welche Vhost config meinst du? sites-available / sites-enabled ?
  14. Komischerweise nicht. habe die Certs mal umbenannt und Apache neu gestartet. folgender Fehler kommt nun beim Ausführen vom Cronjob: root@root:~# /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force [error] 91.200.103.227:443 :: certificate file "/etc/apache2/apache2.pem" does not exist! Cannot create ssl-directives apache2.service is not active, cannot reload. Der Apache Status sagt : Mai 10 20:26:53 root.janis0705.tk apachectl[27677]: AH00526: Syntax error on line 14 of /etc/apache2/sites-enabled/10_froxlor_ipandport_91.200.103.227.443.conf: Mai 10 20:26:53 root.janis0705.tk apachectl[27677]: SSLCertificateFile: file '/etc/apache2/apache2.pem' does not exist or is empty Mai 10 20:26:53 root.janis0705.tk apachectl[27677]: Action 'start' failed.
  15. ah okay ups, habe die Config jetzt erstellt. Der Error ist nun weg. Das Zert. ist jedoch immer noch nicht da (ist das normal so?) Außerdem besteht auch jetzt der Fehler Diese Website kann keine sichere Verbindung bereitstellen janis0705.tk hat eine ungültige Antwort gesendet. mit openssl habe ich gerade ein Zertifikat für Apache erstellt, nun geht es zwar. aber wie ist das normalerweise gedacht? Wie erstellt froxlor für Apache das Zertifikat?
  16. das tue ich doch ? habe es gemacht wie hier erklärt : https://nichteinschalten.de/froxlor-mit-letsencrypt-verbinden/
  17. ich dachte Froxlor macht das alles selbst, ich muss keine Certs erstellen... wie ist es denn gedacht das Cert für apache zu erstellen?
  18. Habe das ganze jetzt so wie erklärt mal probiert, also nur SSL aktiviert, die Apache Konfiguration und Haken bei Domain setzen. Doch die Zertifikate werden nicht erstellt, und nach einigen Minuten erhalte ich mit systemctl status apache2.service auch folgenden Fehler : Mai 10 18:37:59 root.janis0705.tk apachectl[26391]: AH00526: Syntax error on line 16 of /etc/apache2/sites-enabled/35_froxlor_ssl_vhost_janis0705.tk.conf: Mai 10 18:37:59 root.janis0705.tk apachectl[26391]: SSLCertificateFile: file '/etc/apache2/apache2.pem' does not exist or is empty Mai 10 18:37:59 root.janis0705.tk apachectl[26391]: Action 'graceful' failed. selbst mit dem Force ( /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force ) befehl werden die nicht erstellt. In froxlor wird das Zert. für die Website aber erstellt. wie erstelle ich aber für apache jetzt das notwendige noch ?
  19. oder anders gefragt, wie soll man denn normalerweise lets encrypt automatisch generieren lassen ? SSL in froxlor aktivieren, und dann ? gibts irgendwo eine doku/anleitungen ?
  20. moin, habe auf einer testumgebung froxlor neu installiert, diesmal mit debian 9 und PHP 7. soweit ging auch alles, habe jetzt SSL aktiviert und die Webserver konfiguration durchgeführt. dann noch in putty diesen Befehl verwendet : openssl req -new -days 999 -newkey rsa:4096bits -sha512 -x509 -nodes -out server.crt -keyout server.key dann in Froxlor die IP mit port 443 hinzugefügt und gewartet. in froxlor wird das Zert. angezeigt und in /etc/ssl/froxlor-custom ist es auch. aber im Browser kommt Diese Website kann keine sichere Verbindung bereitstellen janis0705.tk hat eine ungültige Antwort gesendet. aber wieso ? das hat so immer funktioniert. was mache ich falsch ? wie kann ich da debuggen ?
  21. ah ja. mal in hourly kopiert, mal sehen
  22. hab mal folgende config erstellt, aber er macht nix, die Logs sind teilweise größer als 1MB... in der Doku steht ja, er rotiert sobald größer als 1MB /var/customers/logs/*.log { rotate 3 missingok notifempty size 1M compress delaycompress create sharedscripts postrotate /etc/init.d/apache2 reload > /dev/null 2>&1 || true endscript }
  23. moin, hatte gerade folgendes problem: die error.log von einem Kunden war gerade 18GB groß und somit lief mein vserver voll. der Kunde selbst hat nur 50MB speicher, das hat ja aber leider nichts mit der Log zu tun. kann man denn nicht irgendwie einstellen dass die nicht so groß werden kann, damit sowas nicht passiert ?? eine fehlerhafte Schleife kann sowas ja ganz schnell verursachen...
  24. kann ich nicht einfach mit PHP einen user erstellen sodass das ist, als ob ich es über Froxlor anlege ? Damit froxlor den Ordner erstellt, etc...
  25. https://froxlor-api.5z5.de/en_index.php die API hab ich mal genutzt, gibts die nicht mehr ? hat auch direkt den ordner erstellt...
×
×
  • Create New...