Jump to content
Froxlor Forum
  • 0

Quota im Nachhinein aktivieren ?


X-GER
 Share

Question

Hallo zusammen,

einige meiner Kunden sind eifrige Mail-Sammler und haben den zugewiesenen Mail-Speicherplatz teilweise schon überschritten.
Meine Mails (siehe unten), den Speicherplatz zu erhöhen wurde komplett ignoriert.

Die vom System ausgelöste Mail sieht wie folgt aus:
*******
Sie haben bereits 5997.51 MB von Ihren insgesamt 5000 MB Speicherplatz verbraucht.
Dies sind mehr als 90%.
******
Das die Berechnung hier überhaupt nicht passt ist natürlich absolut unschön, wie kann ich das korrigieren ?

Aber nun zu meiner Frage,
ich habe gelesen, dass ich durch Aktivierung von Quota den Versand von Mails unterbinden kann.
Kann ich die Aktivierung von Quota auch jetzt noch machen ????

Was muss ich bedenken ?

VG
X-GER

 

Link to comment
Share on other sites

Recommended Posts

  • 0
1 minute ago, X-GER said:

den zugewiesenen Mail-Speicherplatz teilweise schon überschritten.

Den Kunden "Webspace" oder explizit Mail-Speicherplatz pro Mailkonto?

2 minutes ago, X-GER said:

Meine Mails (siehe unten), den Speicherplatz zu erhöhen wurde komplett ignoriert.

Den Satz versteh ich nicht.

2 minutes ago, X-GER said:

Das die Berechnung hier überhaupt nicht passt ist natürlich absolut unschön, wie kann ich das korrigieren ?

Was stimmt da nicht? 5997.51 MB sind offensichtlich mehr als 90% von 5000 MB....Du hast halt als Schwellwert "90" angegeben...

5 minutes ago, X-GER said:

Kann ich die Aktivierung von Quota auch jetzt noch machen ????

Wenn es dir nur um Mails geht, ja, das geht. Einstellungen -> Mail -> Mailbox-quota

Dann kannst du dem Kunden eine gesamt-quota zuweisen und der Kunde selbst kann pro Konto Einschränken wieviel Speicherplatz da pro Konto verwendet werden darf. Dovecot/Postfix lesen das direkt via SQL aus, da muss man gott sei dank nichts mit quotatool oder auf dem dateisystem machen

Link to comment
Share on other sites

  • 0
vor 27 Minuten schrieb d00p:

Hallo d00p,
vielen Dank für Deine rasche Antwort.


Du schreibst :
Einstellungen -> Mail -> 
Mailbox-quota 

Das finde ich so bei mir nicht:

image.thumb.png.b8702acf9665868ae61dc936dbbeef0e.png

kannst Du mir da noch mal weiterhelfen ?

Eine Unterscheidung von Webspace und Mail-Speicherplatz kann ich beim Kunden gar nicht vornehmen:
Screenshot anbei:

image.thumb.png.ce3b9699c0879588020eb1dd4c779629.png

Gruß
X-GER

Link to comment
Share on other sites

  • 0
20 minutes ago, X-GER said:

kannst Du mir da noch mal weiterhelfen ?

Jo da war ich wohl zu knapp angebunden, die Settings-Kategorie heisst "Mailserver-Einstellungen"

20 minutes ago, X-GER said:

Eine Unterscheidung von Webspace und Mail-Speicherplatz kann ich beim Kunden gar nicht vornehmen

Das hängt damit zusammen dass du die erste Einstellung noch nicht aktiviert hast :)

Link to comment
Share on other sites

  • 0

Danke für Deine Antwort.

Kann ich mit der Aktivierung etwas "kaputt" machen?
Ich habe irgendwo gelesen, dass sich durch eine Quota-Aktivierung die Datei-Struktur ändert.

Oder kann ich Quota nach Belieben ein- und ausschalten ?

 

Link to comment
Share on other sites

  • 0
Just now, X-GER said:

Ich habe irgendwo gelesen, dass sich durch eine Quota-Aktivierung die Datei-Struktur ändert.

Bei echter dateisystem-quota ist das so, ja, nur mail-quota läuft komplett über SQL und kann an und ausgeschaltet werden

Link to comment
Share on other sites

  • 0
2 hours ago, d00p said:

Dann kannst du dem Kunden eine gesamt-quota zuweisen und der Kunde selbst kann pro Konto Einschränken wieviel Speicherplatz da pro Konto verwendet werden darf. Dovecot/Postfix lesen das direkt via SQL aus, da muss man gott sei dank nichts mit quotatool oder auf dem dateisystem machen

Genau an dieser Umsetzung hänge ich auch aktuell mal wieder bei Bestandskunden. Wenn ich nun im Nachhinein eine Gesamtquota vergebe, aber der Kunde die Mailboxquota nicht setzt (und somit auf 0 bleibt) geht technisch nichts. E-Mails werden trotzdem zugestellt. Auch wenn er auf E-Mails (automatische "Speicherplatz voll" oder auch direkte Ansprache) nicht reagiert, kann / darf / sollte ich ihm ja nicht seine Verteilung vorgeben. Wenn die jeweiligen Mailbox-Quotas definiert sind, funktioniert die Ablehnung bei Mailbox full.

Oder habe ich noch irgendwo eine Einstellung übersehen, die nur das Gesamtquota für E-mails berücksichtigt?

Link to comment
Share on other sites

  • 0

Nein, das muss pro Konto festgelegt werden. Und ob du ihm das dann setzen kannst/darfst/sollst hängt von dir und den AGB die der Kunde akzeptiert hat ab. Ist z.b. eine feste Speichergröße für seine Daten festgesetzt wüsste ich nicht wieso du die nicht auch umsetzen darfst

Link to comment
Share on other sites

  • 0
21 minutes ago, d00p said:

Nein, das muss pro Konto festgelegt werden. Und ob du ihm das dann setzen kannst/darfst/sollst hängt von dir und den AGB die der Kunde akzeptiert hat ab. Ist z.b. eine feste Speichergröße für seine Daten festgesetzt wüsste ich nicht wieso du die nicht auch umsetzen darfst

Nun der Kunde hat bspw. 5GB Speicherplatz - wie er die aber nutzt und sich aufteilt gebe ich ihm nicht vor. Daher kann ich da im nachhinein nichts einschränken. Einer der "Maximalkunden" nutzt da nur eine Webvisitenkarte und den Rest für 5 oder 6 E-Mail-Adressen und dort haben die Mailuser unterschiedliche Auslastungen, die ich ohne genauere Kenntnis eben nicht einschätzen kann - außer dass einer alleine immer wieder über die 5GB rausknallt (wohl ein Objektleiter). Würde ich den festsetzen auf die maximalen 5GB wären ja immer noch die anderen Mailnutzer die das Gesamtpaket überschreiten.

Link to comment
Share on other sites

  • 0

Naja, egal wie, wenn du den kunden jetzt "zwingen" willst in seiner quota zu bleiben musst du ihn da ja in irgendeiner art und weise was vorgeben oder du hoffst halt das er es selbst macht. Hat der Kunde ein gesamt-mail-quota-kontingent kann er dieses auf seine konten-verteilen wie er will (und 0 [unlimited] darf er nicht mehr setzen).

Das Thema Quota ist immer bescheiden bei Bestandskunden

Link to comment
Share on other sites

  • 0

Hallo d00p,
leider funktioniert die Quota-Regel nicht.

Ich habe ein Test-Mail-Konto angelegt und ein Kontingent von 5 MiB festgelegt.
Dann habe ich zu dieser Mail-Adresse einige Mails geschickt (über 5 MiB)

Es findet keine Abweisung durch den Dovecot statt. In der Datei /etc/dovecot/conf.d/90-quota.conf sind alle Einträge auskommentiert.
Ist das so korrekt?


 

 

Link to comment
Share on other sites

  • 0

Das Plugin an sich ist ja aktiviert und die Froxlor-SQL Queries geben die Eigenschaft "quota_rule" für das Konto mit zurück. Aktiviere doch mal ein höheres Logging und schau mal was dovecot dazu so loggt

Link to comment
Share on other sites

  • 0

Als Anregung was bei mir relevantes drin ist und es ist schon lange her, dass ich es eingerichtet habe:

plugin {
  quota_warning = storage=95%% quota-warning 95 %u
  quota_warning2 = storage=80%% quota-warning 80 %u
}

service quota-warning {
  executable = script /usr/local/bin/quota-warning-de.sh
  user = vmail
  unix_listener quota-warning {
    user = vmail
  }
}

plugin {
  quota = maildir:User quota
}

 

und wegen der Vollständigkeit noch um die Mailboxuser zu informieren /usr/local/sbin/quota-warning-de.sh:

#!/bin/sh
PERCENT=$1
USER=$2
cat << EOF | /usr/lib/dovecot/dovecot-lda -d $USER -o "plugin/quota=maildir:User quota:noenforcing"
From: support@domain.de
To: $USER
Cc: support@domain.de
Date: `date +"%a, %d %b %Y %H:%M:%S %z"`
Subject: Quota-Warnung!


Sehr geehrter Benutzer,

das Postfach $USER ist zu $PERCENT% ausgelastet!

Viele Grüße
Ihr Support

 

Link to comment
Share on other sites

  • 0

@Shortie:
vielen Dank.
E-Mails werden nun beim Erreichen der Quota abgelehnt.

Was jetzt noch nicht funktioniert, ist der automatische Versand der quota-warning-de.sh
Das manuelle Ausführen der Datei quota-warn
ing-de.sh (chmod 755) von der Konsole funktioniert problemlos.
Also vermute ich, das dovecot das Script nicht automatisch ausführt. 

Hast Du da evtl. eine Lösung ?

Link to comment
Share on other sites

  • 0
54 minutes ago, X-GER said:

@Shortie:
vielen Dank.
E-Mails werden nun beim Erreichen der Quota abgelehnt.

Was jetzt noch nicht funktioniert, ist der automatische Versand der quota-warning-de.sh
Das manuelle Ausführen der Datei quota-warn
ing-de.sh (chmod 755) von der Konsole funktioniert problemlos.
Also vermute ich, das dovecot das Script nicht automatisch ausführt. 

Hast Du da evtl. eine Lösung ?

Abgelehnt werden die E-Mails und der Sender bekommt auch eine E-Mail mit "Quota exceeded (mailbox for user is full)" - richtig oder?

Die quota-warning-de.sh (bei mir ist es chmod 700 - chown vmail :vmail) informiert ja nur den Mailboxeigentümer - eher nice to have statt wirklich notwendig

plugin {
  quota_warning = storage=95%% quota-warning 95 %u
}

hast du das mindestens auch drin?

Link to comment
Share on other sites

  • 0

Quota exceeded (mailbox for user is full)
diese Meldung geht raus !

Die quota-warning-de.sh wird leider immer noch nicht verschickt,
hier ein Auszug aus der 90-quota.conf:


 

##
## Quota configuration.
##

# Note that you also have to enable quota plugin in mail_plugins setting.
# <doc/wiki/Quota.txt>

##
## Quota limits
##

# Quota limits are set using "quota_rule" parameters. To get per-user quota
# limits, you can set/override them by returning "quota_rule" extra field
# from userdb. It's also possible to give mailbox-specific limits, for example
# to give additional 100 MB when saving to Trash:

plugin {
  #quota_rule = *:storage=1G
  #quota_rule2 = Trash:storage=+100M
}

##
## Quota warnings
##

# You can execute a given command when user exceeds a specified quota limit.
# Each quota root has separate limits. Only the command for the first
# exceeded limit is excecuted, so put the highest limit first.
# The commands are executed via script service by connecting to the named
# UNIX socket (quota-warning below).
# Note that % needs to be escaped as %%, otherwise "% " expands to empty.

plugin {
  #quota_warning = storage=95%% quota-warning 95 %u
  #quota_warning2 = storage=80%% quota-warning 80 %u
   quota_warning = storage=90%% quota-warning 90 %u
}

# Example quota-warning service. The unix listener's permissions should be
# set in a way that mail processes can connect to it. Below example assumes
# that mail processes run as vmail user. If you use mode=0666, all system users
# can generate quota warnings to anyone.
service quota-warning {
  executable = script /usr/local/bin/quota-warning.sh
  user = vmail
  unix_listener quota-warning {
  user = vmail
  }
}

# Service der die Quota fernabfragbar macht
service quota-status {
  executable = quota-status -p postfix
  inet_listener {
    address = 127.0.0.1
    port = 12340
  }
  client_limit = 1
}

##
## Quota backends
##

# Multiple backends are supported:
#   dirsize: Find and sum all the files found from mail directory.
#            Extremely SLOW with Maildir. It'll eat your CPU and disk I/O.
#   dict: Keep quota stored in dictionary (eg. SQL)
#   maildir: Maildir++ quota
#   fs: Read-only support for filesystem quota

plugin {
  #quota = dirsize:User quota
  quota = maildir:User quota
  #quota = dict:User quota::proxy::quota
  #quota = fs:User quota
}

# Multiple quota roots are also possible, for example this gives each user
# their own 100MB quota and one shared 1GB quota within the domain:
plugin {
  #quota = dict:user::proxy::quota
  #quota2 = dict:domain:%d:proxy::quota_domain
  #quota_rule = *:storage=102400
  #quota2_rule = *:storage=1048576
}

Sieht Du hier einen Fehler ?

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...