Jump to content
Froxlor Forum
  • 0

proftpd Einstellung anpassen IP-Adresse


saxandl
 Share

Question

Hallo wiedermal!

Bei FTP-Aufbau erhalte ich die Fehlermeldung

Zitat

Server sent passive reply with unroutable address 192.168.100.22

Diese IP ist die lokale IP des Froxlor, der sich hinter einer Firewall befindet.
Ich nehme an, hier müsste eine Einstellung vorgenommen werden - kann mir jmd den Hinweis geben?

danke & greets
 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

für nutzung hinter firewall musst du die passive-ports explizit deklarieren in der proftpd config und diese dann auch in der firewall freigeben, der server sollte natürlich auch auf die externe IP hören und nicht die lokale:

# In some cases you have to specify passive ports range to by-pass
# firewall limitations. Ephemeral ports can be used for that, but
# feel free to use a more narrow range.
PassivePorts                  10000 10499 (<<< die von dir gewünschte Port-Range)

# If your host was NATted, this option is useful in order to
# allow passive tranfers to work. You have to use your public
# address and opening the passive ports used on your firewall as well.
MasqueradeAddress               123.123.123.123 (<<< deine externe IP)

 

Link to comment
Share on other sites

  • 0

super!!! danke!

 

ups - ich war zu schnell: jetzt kann ich mich zwar anmelden, aber keinen Dateitransfer ausführen - weder up- noch download

 

UPDATE: es mussten noch die Passive-Port in der FW freigegeben werden!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...