Jump to content
Froxlor Forum

saxandl

Members
  • Posts

    27
  • Joined

  • Last visited

Everything posted by saxandl

  1. Fehlermeldung open(/var/customers/tmp/<customer>//sess_vrik2d57cvbp108jmf3hl29i02, O_RDWR) failed: Permission denied (13) worauf ich das verzeichnis "/var/customers/tmp/<customer>" von ursprünglich 10002:10002 auf <customer>:<customer> geowned habe. damit dürfte es jetzt funktionieren
  2. FCGDI ist deaktiviert PHP-FPM aktiviert WP_TEMP_DIR siehe unten was mir aufgefallen ist: "proxy_fcgi"- modul in apache ist aktiviert, "php8.0" - modul deaktiviert genau so steht's in der wp-config.php define(‘WP_TEMP_DIR’, ABSPATH . ‘wp-content/tmp’);
  3. Hi! Nach Installation von Wordpress sollte ein neues Template hochgeladen und installiert werden. Hier kommt die Fehlermeldung "Es fehlt ein temporärer Ordner" Ich habe nach WP-Anleitung den WP_TEMP_DIR definiert und schreibbar gemacht - ohne Erfolg. In verschiedenen Tutorials wird empfohlen, die PHP-Einstellungen der php.ini zu ändern. Das getraue ich mich nicht, weil ich befürchte, dass es sich global auswirkt. Hat jmd ähnliche Erfahrungen und ev. einen Lösungansatz? danke & greets Alex
  4. automatisiertes update halt, ich hätte es aber auch zugelassen, wenn es zu bestätigen gewesen wäre. Wir erwähnt proxy_fcgi-error erstmal um 10:40 aufgetreten, davon um 10:33 update von php 8.0.11 => 8.0.12 sowohl apache2 als auch system-neustart - beides ohne erfolg. Kann es mit suexec in zusammenhang stehen? denn auch hier kommt eine Fehlermeldung "suexec policy violation" und im suexec.log bei aufruf von cgi-script: [2021-10-26 12:44:20]: target uid/gid (1001/1001) mismatch with directory (10000/10000) or program (10000/10000)
  5. das Phänomen ist spontan und ohne mein zutun aufgetreten srw-rw---- 1 customer2 customer2 0 Okt 26 11:48 1-customer2-<domain>.<tdl>-php-fpm.socket srw-rw---- 1 customer1 customer1 0 Okt 26 11:48 1-customer1-<domain>.<tdl>-php-fpm.socket es wundert mich auch: zumal das spontan aufgetreten ist und ungefähr zeitgleich im apt.log das update ausgeführt wurde!
  6. da sind dann alle domains und subdomains aufgelistet. Auszug: customer1 3504 0.0 0.0 234592 11772 ? S 11:48 0:00 \_ php-fpm: pool <domain>.<tdl> customer1 3505 0.0 0.0 234592 11772 ? S 11:48 0:00 \_ php-fpm: pool <domain>.<tdl> customer2 3514 0.0 0.0 234592 11776 ? S 11:48 0:00 \_ php-fpm: pool <domain>.<tdl> customer2 3515 0.0 0.0 234592 11776 ? S 11:48 0:00 \_ php-fpm: pool <domain>.<tdl> die domain von customer1 bildet index.php ab; die domain von customer2 nicht mehr => Error 502 (sehr wahrscheinlich seit dem Update von PHP)
  7. *ggg* ich kann leider nicht alles wissen 😞 aber ich versuchs mir zu merken: root 3484 0.5 0.1 234816 33976 ? Ss 11:48 0:00 php-fpm: master process (/etc/php/8.0/fpm/php-fpm.conf)
  8. wie überprüft man das? // update: ja, läuft: php8.0-fpm & php8.0-fpm.service jetzt beide reseller ident
  9. Hi Nach einem automatisierten update von PHP 8.0.11 auf 8.0.12 erschein folgende Fehlermeldung im log: [Tue Oct 26 11:17:44.413045 2021] [proxy:error] [pid 890] (13)Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-<customer>-<domain>.<tdl>-php-fpm.socket (*) failed [Tue Oct 26 11:17:44.413120 2021] [proxy_fcgi:error] [pid 890] [client nn.nn.nn.nn:44115] AH01079: failed to make connection to backend: httpd-UDS Die website meldet Fehler 503 Service Unavailable. Zur Ergänzung: es handelt sich um websites mit index.php Obiges tritt interessanter Weise nur bei einem customer auf, bei einem zweiten nicht. Der einzig erkennbare Unterschied: bei Customer mit error fehlt in der Option Domains=>(Sub-) Domain bearbeiten => die Option "OpenBasedir-Pfad"
  10. das script selbst tut nichts anderes, als das Environment auszulesen und an den Browser weiter geben - vergleichbar mit phpinfo(). Am script liegt es definitiv nicht! Wenn ich das script über den Browser aufrufe, bekomme ich einen 404-error und im logfile den beschriebenen error. Es sieht so aus, als würde apache nicht auf das Verzeichnis des customers zugreifen, sondern das script im Verzeichnis /usr/lib/cgi-bin/ ausführen versuchen. Nur zur Sicherheit: FCGID ist deaktiviert
  11. das weiss ich nicht! das cgi-script wird nicht im Verzeichnis ausgeführt - daher hab ich ins logfile geschaut.
  12. bin exakt wie beschrieben vorgegangen. softlink's werden korrekt eingerichtet, apache scheint nicht richtig darauf zu reagieren: AH02811: script not found or unable to stat: /usr/lib/cgi-bin/env.cgi
  13. update: leider ein Folgeproblem aufgetreten: apache error.log: AH01215: suexec policy violation: see suexec log for more details: suexec.log uid: (10000/<customer>) gid: (10000/<customer>) cmd: env.cgi command not in docroot (/mnt/datastore2/webs/<customer>/<domain>.<tdl>/shop/cgi-bin/env.cgi) sieht so aus, was würde das env.cgi aufgrund Rechteproblem nicht ausgeführt werden können. Es gibt da bei den Einstellungen Perl/CGI den Punkt - Aktiviere SuExec-Workaround der vermutlich angepasst werden muss. Ich habe die Pfade grundsätzlich so angelegt, dass sich das Verzeichnis /cgi-bin/ unterhalb des docroots befindet: /var/customers/webs/<customer>/<domain>.<tdl>/cgi-bin/ und dies in der vHost-Einstellung über ScriptAlias definiert. Wie sollte die Konfiguration angepasst werden?
  14. a2enmod proxy_fcgi => alles gut thanks!
  15. als root von der console: # sudo service Usage: service < option > | --status-all | .... Debian 10 Apache 2.4.38 php 8.0 MariaDB 10.3.31 wo finde ich froxlor/php-fpm-daemon settings?
  16. wie vorgeschlagen vorgegangen libnss-extrausers eingerichtet - scheint zu funktionieren: ftp user:group wird auf customer:customer umgeschrieben. neues Problem entstanden: php wird nicht ausgeführt, sondern der code im browser angezeigt. Zum Test deaktiviere ich den <FilesMatch \.(php)$> im vhost => wird php ausgeführt. vl auch von Bedeutung: Froxlor\Cron\Http\ApacheFcgi::reload: running service php8.0-fpm restart sh: 1: service: not found
  17. heisst das im Umkehrschluss, wenn ich FCGID & PHP-FPM in den Einstellungen aktiviere benötige ich libnss-extrausers nicht?
  18. wo finde ich diese Einstellung bzw. wie lässt es ermitteln?
  19. Hallo! Ich habe eine Frage an jene, die Joomla auf Froxlor nutzen, weil mir folgendes aufgefallen ist: Nachdem ich die Joomla-Dateien ins web-root geladen und die Installation aufgerufen habe, erhalte ich die Fehlermeldung, dass die "configuration.php" nicht erstellt werden kann. Das führte ich auf fehlende Rechte zurück und habe webroot temporär auf 777 gesetzt. Damit ist zwar das Installations-Problem gelöst, es lassen sich aber keinerlei Module oder Templates laden. Augenscheinlich werden die Rechte durch FTP-Upload auf 10000:10000 gesetzt, Jommla über html erwartet jedoch www-data:www-data (ich kann aber auch falsch liegen, mit dieser Vermutung). Kann mir jmd, der Joomla im Einsatz hat, nützliche Hinweise geben? Danke & greets
  20. super!!! danke! ups - ich war zu schnell: jetzt kann ich mich zwar anmelden, aber keinen Dateitransfer ausführen - weder up- noch download UPDATE: es mussten noch die Passive-Port in der FW freigegeben werden!
  21. Hallo wiedermal! Bei FTP-Aufbau erhalte ich die Fehlermeldung Diese IP ist die lokale IP des Froxlor, der sich hinter einer Firewall befindet. Ich nehme an, hier müsste eine Einstellung vorgenommen werden - kann mir jmd den Hinweis geben? danke & greets
  22. danke für den Hinweis - ohne diesen wäre ich nicht darauf gekommen! Wie ich schon eingangs geschrieben habe, plane ich aus easyscp zu migrieren. Dort ist der doc-root wie beschrieben angelegt. Es würde die Migration erleichtern, aber wenn dies nicht möglich ist, werde ich es auch überstehen 😉 Danke nochmal herzlich!!
  23. in /etc/apache2/sites-enabled/35_froxlor_normal_vhost_clx.at.conf über webmin. jetzt erst habe ich das file im editor betrachtet und gesehen, dass es überschrieben wird "all changes will be deleted after the next domain change" - das wird bei der Bearbeitung über webmin nicht angezeigt ... damit stellt sich die Frage: wo nimmt man die Einstellung für das cgi-verzeichnis vor?
  24. die Schritte im Detail: - als admin Domain clx.at angelegt - in console verzeichnis /var/www/virtual/clx.at/cgi-bin/ angelegt - Apache direktive eingefügt: "ScriptAlias /cgi-bin/ /var/www/virtual/clx.at/cgi-bin/" - cgi-script getestet => OK - als customer subdomain zu domain clx.at angelegt Durch Anlegen der subdomain wird die zuvor geänderte direktive "ScripAlias" in /etc/apache2/sites-enabled/35_froxlor_normal_vhost_clx.at.conf wieder entfernt bzw. durch die Basis-Direktiven überschrieben
  25. nein, es läuft 2.4.38 - ich hab die Direktive aus einer anderen Installation übernommen - wie auch immer, das Problem war ein anderes: die Apache-Module cgi und cgid waren nicht enabled. Mir ist aber was anderes aufgefallen: 1.) Ändere ich die Direktive einer Domain und lege DANACH eine subdomain an, wird die Direktive der Domain wieder zurückgesetzt. Kennst du eine Einstellung, die das verhindert? 2.) Lege als admin eine Domain im Verzeichnis /var/www/virtual/<domain>/htdocs/ an. Wenn ich anschließen als customer eine Subdomain anlege (/var/www/virtual/<domain>/<subdomain>/htdocs/), wird diese im Verzeichnis var/customers/webs/<customer>/var/www/virtual/<domain>/<subdomain>/htdocs/ angelegt, ich möchte das Verzeichnis aber in /var/www/virtual/<domain>/<subdomain>/htdocs/. Lässt sich das einstellen?
×
×
  • Create New...