Jump to content
Froxlor Forum
  • 0

[gelöst] cgi(perl) ausführen


saxandl
 Share

Question

Hallo!

Habe froxlor erstmal installiert und möchte mehrere Domains aus easyscp migrieren. Soweit so gut

Woran ich im Moment scheitere: aktivieren von perl bzw. Ausgabe im Browser:
Aktuell wird beim Aufruf <website>/cgi-bin/env.cgi der Inhalt der Datei ausgegeben.

Ich habe bereits überprüft:
 - Apache modul perl enabled (webmin)
 - pfad zu perl correct: #!/usr/bin/perl --
 - Kunde->Pfadoptionen-> cgi enabled im pfad "/cgi-bin/"

was habe ich übersehen?

 

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

habe im vhost händisch hinzugefügt:

   ScriptAlias /cgi-bin/ /var/customers/webs/<kunde>/<website>/cgi-bin/
    <Directory /var/customers/webs/<kunde>/<website>/cgi-bin>
        AllowOverride AuthConfig
        Order allow,deny
        Allow from all
        Options +ExecCGI
        AddHandler cgi-script .cgi .pl .py
    </Directory>

Apache meldet: "Module perl already enabled"

im Browser ausgegeben wird

#!/usr/bin/perl --
# env.cgi
# COPYRIGHT NOTICE                                                           
# Copyright 1998 Markus Wolf
....

anstatt das script auszuführen

Link to comment
Share on other sites

  • 0
vor 18 Stunden schrieb d00p:

du hast wirklich noch apache 2.2 ???

nein, es läuft 2.4.38 - ich hab die Direktive aus einer anderen Installation übernommen - wie auch immer, das Problem war ein anderes: die Apache-Module cgi und cgid waren nicht enabled.

Mir ist aber was anderes aufgefallen:

1.) Ändere ich die Direktive einer Domain und lege DANACH eine subdomain an, wird die Direktive der Domain wieder zurückgesetzt. Kennst du eine Einstellung, die das verhindert?

2.) Lege als admin eine Domain im Verzeichnis /var/www/virtual/<domain>/htdocs/ an. Wenn ich anschließen als customer eine Subdomain anlege (/var/www/virtual/<domain>/<subdomain>/htdocs/), wird diese im Verzeichnis var/customers/webs/<customer>/var/www/virtual/<domain>/<subdomain>/htdocs/ angelegt, ich möchte das Verzeichnis aber in /var/www/virtual/<domain>/<subdomain>/htdocs/. Lässt sich das einstellen?

 

 

Link to comment
Share on other sites

  • 0
8 minutes ago, saxandl said:

1.) Ändere ich die Direktive einer Domain und lege DANACH eine subdomain an, wird die Direktive der Domain wieder zurückgesetzt. Kennst du eine Einstellung, die das verhindert?

verstehe nicht ganz was du damit meinst, bitte benenne die Aktionen die du durchgeführt hast und die Namen der Felder und was genau du gemacht hast...

9 minutes ago, saxandl said:

2.) Lege als admin eine Domain im Verzeichnis /var/www/virtual/<domain>/htdocs/ an. Wenn ich anschließen als customer eine Subdomain anlege (/var/www/virtual/<domain>/<subdomain>/htdocs/), wird diese im Verzeichnis var/customers/webs/<customer>/var/www/virtual/<domain>/<subdomain>/htdocs/ angelegt, ich möchte das Verzeichnis aber in /var/www/virtual/<domain>/<subdomain>/htdocs/. Lässt sich das einstellen?

Warum gibst du denn als customer auch den kompletten pfad an? Für den Kunden ist der angegebene Pfad immer relativ zum Homedir. Die Kunden homedirs liegen unterhalb von /var/customers/webs/<kundenname>/ ...das kannst du in den Haupteinstellungen als Admin alles anpassen (allerdings nicht ratsam zu ändern, wenn du schon alles konfiguriert hast und kunden/domains angelegt hast).

Als Admin darfst du auch durchaus docroots angeben die nicht innerhalb eines Kunden-Homedirs liegen

Link to comment
Share on other sites

  • 0
vor 35 Minuten schrieb d00p:

verstehe nicht ganz was du damit meinst, bitte benenne die Aktionen die du durchgeführt hast und die Namen der Felder und was genau du gemacht hast...

die Schritte im Detail:

 - als admin Domain clx.at angelegt 
 - in console verzeichnis /var/www/virtual/clx.at/cgi-bin/ angelegt
 - Apache direktive eingefügt: "ScriptAlias /cgi-bin/ /var/www/virtual/clx.at/cgi-bin/"
   - cgi-script getestet => OK
 - als customer subdomain zu domain clx.at angelegt
 
Durch Anlegen der subdomain wird die zuvor geänderte direktive "ScripAlias" in /etc/apache2/sites-enabled/35_froxlor_normal_vhost_clx.at.conf wieder entfernt bzw. durch die Basis-Direktiven überschrieben

Link to comment
Share on other sites

  • 0

wo und wie hast du die apache direktive mit deinem scriptalias denn eingefügt?

und ich frage mich immernoch wieso du document-roots außerhalb der customer-homedirs verwenden willst...da kommt der customer doch mit seinem ftp account gar nicht dran

Link to comment
Share on other sites

  • 0
vor 1 Minute schrieb d00p:

wo und wie hast du die apache direktive mit deinem scriptalias denn eingefügt?

in /etc/apache2/sites-enabled/35_froxlor_normal_vhost_clx.at.conf über webmin.

jetzt erst habe ich das file im editor betrachtet und gesehen, dass es überschrieben wird "all changes will be deleted after the next domain change" - das wird bei der Bearbeitung über webmin nicht angezeigt ...

damit stellt sich die Frage: wo nimmt man die Einstellung für das cgi-verzeichnis vor?

 

 

Link to comment
Share on other sites

  • 0
12 minutes ago, saxandl said:

damit stellt sich die Frage: wo nimmt man die Einstellung für das cgi-verzeichnis vor?

Eigene Vhost Einstellungen wenn du die Domain als Admin bearbeitest

Link to comment
Share on other sites

  • 0
vor einer Stunde schrieb d00p:

Eigene Vhost Einstellungen wenn du die Domain als Admin bearbeitest

danke für den Hinweis - ohne diesen wäre ich nicht darauf gekommen!

vor 2 Stunden schrieb d00p:

und ich frage mich immernoch wieso du document-roots außerhalb der customer-homedirs verwenden willst...da kommt der customer doch mit seinem ftp account gar nicht dran

Wie ich schon eingangs geschrieben habe, plane ich aus easyscp zu migrieren. Dort ist der doc-root wie beschrieben angelegt. Es würde die Migration erleichtern, aber wenn dies nicht möglich ist, werde ich es auch überstehen 😉

 

Danke nochmal herzlich!!

Link to comment
Share on other sites

  • 0

Klar ist das möglich, aber halt Quatsch. Warum migirerst du die docroot-inhalte nicht einfach in die entsprechendenn neuen Ordner? Am ende hast du sonst immer nur irgendwelche Probleme mit permissions oder sonstwas - und die customer erst Recht wenn sie ihre eigenen dateien nicht ändern können

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...