Jump to content
Froxlor Forum
  • 0

PHP-Fehler nach Update


matsy
 Share

Question

Nach einem Froxlor-Update über das Admin-Backend ergibt sich folgende Situation:

Beim Aufruf des Backends:

It seems you are using an older version of PHP
Froxlor requires at least PHP version 7.1.0
The installed version is: 7.0.33-53+0~20210826.58+debian9~1.gbpf7a29f

PHP7.3 ist installiert:

php -v
PHP 7.3.30-1+0~20210826.87+debian9~1.gbpe56a7b (cli) (built: Aug 26 2021 16:06:22) ( NTS )
Copyright (c) 1997-2018 The PHP Group

Ich habe keinen Weg gefunden, Forxlor zum Umstieg auf die 7.3 zu bekommen.

Daher habe ich geschaut, ob ich das in der Datenbank manuell ändern muss. Ich habe die Einstellungen defaultini, vhost_defaultini und mod_fcgid_defaultini_ownvhost auf die ID der 7.3 version gesetzt. Hat aber auch nicht funktioniert.

Zur Sicherheit wollte ich die manuell Konfigs neu schreiben lassen, damit die Änderungen übernommen werden, bekomme daraufhin aber nur: 

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug
Version of file doesn't match version of database. Exiting...

Possible reason: Froxlor update
Information: Current version in database: 0.10.20 (DB: 202007240) - version of Froxlor files: 0.10.28 (202108180))
Solution: Please visit your Foxlor admin interface for further information.

Webseiten, denen PHP7.3 vorher schon zugeordnet war, laufen ohne Probleme.

 

Wie kriege ich nun zunächst die Versionen auf Gleichstand und dann funktioniert nach dem Neuschreiben der Konfigs vielleicht auch PHP7.3 für das Backend?

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

"php -v" auf der Konsole gibt dir die aktuelle eingesetzte Version von php-cli. Je nach Art und Weise wie du PHP einbindest (mod_php, fcgid, php-fpm) musst du hier ggfls. natürlich hier auch aktualisieren und schauen das auch die korrekte version genutzt wird. 

Link to comment
Share on other sites

  • 0

und du hast 7.3 wohl in froxlor noch nicht hinterlegt / eingerichtet?! Wenn du jetzt natürlich nicht mehr an dein Froxlor kommst, bleibt dir eigentlich nur das manuell anzupassen:

- stoppe php7.0-fpm

- kopiere die pool-configs von php7.0 nach php7.3 (meist /etc/php/7.x/fpm/pool.d)

- starte php7.3-fpm

- dein froxlor sollte im browser aufrufbar sein, du kannst das update durchführen

- ändere die php-fpm einstellung im admin-interface das es nicht auf 7.0 zeigt sondern 7.3, dann sollte auch alles dauerhaft problemlos funktionieren

 

 

Link to comment
Share on other sites

  • 0

Vielen Dank. Ich konnte das Backend so wieder zum Laufen bringen und das Update abschließen.

Zwischendurch haben sich die Konfigs durch den Cron mal neu geschrieben und weder der PHP-FPM Service noch der Apache ließen sich neu starten. Es hat sich heraus gestellt, dass die Formatierungen in manchen site confs aus irgendeinem Grund nicht mehr gestimmt haben (Fehlende Zeilenumbrüche). Ich habe die Konfigs mehrmals neuschreiben lassen, hat aber trotzdem nicht funktioniert. Nachdem ich die Zeilenumbrüche manuell wieder eingefügt habe, läuft alles wieder.

Link to comment
Share on other sites

  • 0
3 minutes ago, matsy said:

dass die Formatierungen in manchen site confs aus irgendeinem Grund nicht mehr gestimmt haben (Fehlende Zeilenumbrüche).

Hast du da irgendwo eigene Vhost-Container Inhalte? Denn froxlor generiert immer alle vhosts gleich...und das keine Zeilenumbrüche geschrieben werden habe ich bisher noch nicht erlebt

Link to comment
Share on other sites

  • 0

Eigentlich nicht. Ich habe jetzt gerade noch einmal geschaut und so sieht das zum Beispiel aus:

<Directory /var/www/>    Options -Indexes +FollowSymLinks    AllowOverride All    Require all granted</Directory>
</VirtualHost>

Und wenn ich jetzt neu starten würde, dann würde der Apache wahrscheinlich wieder meckern.

Link to comment
Share on other sites

  • 0

Ich bin es jetzt noch einmal durchgegangen. Du hast Recht, bei 2 Vhosts waren keine Zeilenumbrüche im Eingabefeld. Warum, weiß ich nicht, bisher hatte es so funktioniert und geändert hatte ich auch nichts. Jetzt sollte es aber erst einmal wieder ohne Probleme laufen.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...