Jump to content
Froxlor Forum

matsy

Members
  • Content Count

    66
  • Joined

  • Last visited

Everything posted by matsy

  1. Eine Subdomain wurde als Kunde über den Kundenbereich angelegt. Sie wurde auch erfolgreich erstellt. Nun irritiert mich, dass sie zwar im Kundenbereich sichtbar ist, aber nicht im Admin Bereich. Sollte nicht der Admin in seinem Bereich alle angelegten Domains sehen? Was würde passieren, wenn der Admin aus welchem Grund auch immer, die gleiche Subdomain noch einmal erstellt, vielleicht sogar mit anderen Parametern?
  2. Jetzt scheint es auch zu funktionieren.
  3. Kann ich ausprobieren. Wie füge ich das am einfachsten ein? Per Copy & Paste?
  4. Hab ich doch: Ja bitte, wäre nett, wenn du das überprüfen kannst. Wichtig wäre ja nicht, ob der Wert angezeigt wird, sondern ob er übernommen wird. Da in meinen Logs der Idle-Timeout steht, befürchte ich, dass das System den Wert nicht berücksichtigt.
  5. Vielleicht schaue ich auch falsch oder habe ein Verständnisproblem? Ich sehe, dass unter /etc/php/7.0/fpm/pool.d conf-Dateien für die Domains liegen, in denen pm.process_idle_timeout auf die richtige Dauer vom child gesetzt ist. In der entsprechenden vhost unter /etc/apache2/sites-enabled steht aber unter FastCgiExternalServer die falsche Zeit, nämlich die vom parent. Ist es überhaupt richtig, dass in beiden die gleichen Sekunden stehen müssten?
  6. So ich habe gerade das Update gemacht. Folgende Situation: 1. Die Crons haben nicht mehr funktioniert. Obwohl ich im Syslog den Aufruf des Crons sehe, wurden keine Konfigs mehr neu erstellt. Ich habe das mit dem -force parameter nun ainmal manuell gemacht, da hat es funktioniert. Ob es nun wieder automatisch geht, muss man sehen. 2. Der Idle Timeout wird immer noch nicht übernommen.
  7. Ja, die Version ist älter. Dann versuche ich es später über autoupdate.
  8. Das letzte Mal als ich per apt-get updaten wollte, wurde mir kein Paket mehr angeboten. Geht das nur noch manuell und wenn ja wie?
  9. Es wird nur der Parent übernommen. Meine Version ist 0.10.3.
  10. Nein, da habe ich dich missverstanden: Das Dropdownfeld zeigt korrekt das an, was ich einstelle. Muss der parent auf etwas bestimmtem stehen? Ich stelle jetzt einmal beides auf "ondemand" nur mit unterschiedlichen Idle-Timeout.
  11. Also im Dropdownfeld bleibt es auf "ondemand" eingestellt. Ich habe eben testweise in PHP-Versionen den Idle-Timeout verändert und das wird in die Vhost übernommen.
  12. Dann scheint bei mir etwas nicht zu stimmen. Im Moment sieht es so aus. Unter PHP-FPM Versionen: Process Manager Control: dynamic Idle-timeout: 120s Unter PHP Konfigurationen die entsprechende PHP Version zugeordnet. Überschreibe FPM-Daemon Einstellungen: Angehakt Process Manager Control: ondemand Idle-timeout: 30s Im Vhost steht dennoch: FastCgiExternalServer -idle-timeout 120 Hier müssten nun doch die 30s stehen? Oder ist das eine andere Einstellung?
  13. Warum wird mein PHP-FPM idle timeout nicht übernommen? In PHP Versionen ist 120s eingestellt. In PHP Konfigurationen 300s, Überschreibe FPM-Daemon Einstellungen ist angehakt. Domain entsprechend zugeordnet. Trotzdem wird es nicht übernommen. Es bleibt bei 120s.
  14. Hat sich gerade erledigt. Die erlaubten Konfigurationen waren beim Kunden falsch eingestellt.
  15. Irgendetwas übersehe ich: Bei einer Domain lässt sich die gewünschte PHP Konfiguration nicht auswählen. Alle PHP-Konfigurationen bis auf die aktuell eingestellte, erscheinen grau. Wenn ich eine andere Domain auswähle, erscheinen die verfügbaren Konfigurationen im Dropdown-Feld nicht grau und die gewünschte Konfiguration lässt sich auswählen.
  16. Version ist Debian 8.11 Installiert habe ich es (glaube ich) nur nach der Froxlor Anleitung. Also einfach apt-get install postfix postfix-mysql Die Zeile in postfix-files sieht jetzt so aus: #$daemon_directory/dict_sdbm.so:f:root:-:755 Bei Google findet man nicht sehr viel darüber, was diese Datei macht. Ein Vorschlag ist das Paket postfix-tls zu installieren, das findet apt-get aber nicht bei mir.
  17. Weiß jemand, was es mit /usr/lib/postfix/dict_sdbm.so auf sich hat? Laut postfix-files sollte die Datei vorhanden sein, ist sie aber nicht. Ich habe den Eintrag dazu jetzt einmal auskommentiert, weil Postmulti sonst nicht läuft. Wo kriege ich die Datei her, bzw. brauche ich sie?
  18. Komisch. Es geht um eine Trennung der SMTP-Authentifizierung von der Postfach-Erstellung. Aber das bringt mich jetzt noch einmal auf eine andere Idee: Wenn man ein Postfach mit einer kaum zu erratenden E-Mail Adresse erstellt, dann könnte man dies rein zur Authentifizierung am SMTP-Server verwendet werden und die Überwachung des Postfaches kann man sich sparen, weil wahrscheinlich niemand die Adresse errät.
  19. Die, in der der die Logins und Passwörter drin stehen. Schon, nur Konto bedeutet doch auch automatisch Anlegen von einem POP-Konto und damit Empfang auf dieser Adresse, oder nicht? Es soll aber nur Senden. Oder kann ich das Abstellen, dass ein POP-Konto angelegt wird?
  20. Ich habe gerade einen Fall, bei dem ein generisches login für E-Mails glaube ich sinnvoll wäre. Im Moment ist es ja so, dass der SMTP login an eine reale E-Mail Adresse bzw. an ein angelegtes E-Mail Konto gebunden ist. Wenn nun aber Webscripte EMails versenden, z.B. Newsletter oder Statusmeldungen, dann müsste man für die entweder einen eigenen Account anlegen oder über bestehende Accounts versenden, was aber die Gefahr birgt, dass bei Änderungen an den E-Mails dann irgendwelche Skripte nicht mehr funktionieren. Daher die Idee und Frage, ob man nicht die MySQL Abfrage in mysql-virtu
  21. Das Risiko gehe ich ein. Scheint auch wunderbar geklappt zu haben. Vielen Dank.
  22. Hallo mal wieder. Beim Anlegen von Kunden zählt Froxlor ja automatisch hoch (web1-web111000) Gibt es die Möglichkeit entstandene Lücken wieder zu füllen? Also z.B. wenn ich die Kunden web10-web15 gelöscht habe, kann der nächste neue Kunde dann die web10 bekommen? Irgendwo in der Datenbank müsste doch der Zähler für nächster Kunde drin stehen?
  23. Vielen Dank an die Hinweise. Es geht voran. Ein bisschen anders, ein bisschen wilder, aber es scheint zu funktionieren. Noch eine Frage. Froxlor legt mir für jede Ip den Eintrag FastCgiExternalServer und Alias /fastcgiphp für das Froxlor Panel an. Da es mir ausreicht, wenn Froxlor über eine bestimmte Ip erreichbar ist, lässt sich das einstellen, dass es nur für eine Ip erstellt wird?
  24. Erst mal vielen Dank. Die Installation scheint geklappt zu haben und Froxlor hat eigentlich alles automatisch übernommen. Den Service PHP7.0-FPM zeigt der Server aber als running an. Richtig testen konnte es aber noch nicht, weil ich jetzt ein anderes Problem habe. Ich habe übersehen, dass die Projekte, die mit PHP7 laufen sollen gar keine Domain haben. Werden sie vermutlich auch nicht. Mit PHP5 ist der Zugriff über IP natürlich kein Problem, weil es System Default ist, wie kriege ich aber Froxlor dazu, nur für eine bestimmte IP (oder Verzeichnis) PHP7 zu verwenden?
  25. Ich habe jetzt doch 2 Projekte, bei denen ich gerne auf PHP7 setzen würde. Bisher PHP5-FPM und das soll auch so bleiben. Bevor ich groß suche, frage ich einmal hier, ob jemand ein Tutorial kennt damit ich mir PHP5 nicht zerschieße, bzw. ob jemand weiß, ob so eine Konfiguration mit Froxlor nebeneinander überhaupt möglich ist und ob es etwas besonderes zu beachten gibt. OS ist Debian Jessie, Apache2 mit PHP5-FPM und nur für 2 Projekte von mehreren beim einem Kunden wird PHP7 benötigt. Lässt sich das evtl. einfach über einen Directory Eintrag im Vhost realisieren? Das wäre ja dann
×
×
  • Create New...