Jump to content
Froxlor Forum

matsy

Members
  • Posts

    71
  • Joined

  • Last visited

Everything posted by matsy

  1. Ich bin es jetzt noch einmal durchgegangen. Du hast Recht, bei 2 Vhosts waren keine Zeilenumbrüche im Eingabefeld. Warum, weiß ich nicht, bisher hatte es so funktioniert und geändert hatte ich auch nichts. Jetzt sollte es aber erst einmal wieder ohne Probleme laufen.
  2. Eigentlich nicht. Ich habe jetzt gerade noch einmal geschaut und so sieht das zum Beispiel aus: <Directory /var/www/> Options -Indexes +FollowSymLinks AllowOverride All Require all granted</Directory> </VirtualHost> Und wenn ich jetzt neu starten würde, dann würde der Apache wahrscheinlich wieder meckern.
  3. Vielen Dank. Ich konnte das Backend so wieder zum Laufen bringen und das Update abschließen. Zwischendurch haben sich die Konfigs durch den Cron mal neu geschrieben und weder der PHP-FPM Service noch der Apache ließen sich neu starten. Es hat sich heraus gestellt, dass die Formatierungen in manchen site confs aus irgendeinem Grund nicht mehr gestimmt haben (Fehlende Zeilenumbrüche). Ich habe die Konfigs mehrmals neuschreiben lassen, hat aber trotzdem nicht funktioniert. Nachdem ich die Zeilenumbrüche manuell wieder eingefügt habe, läuft alles wieder.
  4. Sowohl PHP 7.0 also auch PHP 7.3 sind als PHP-FPM installiert.
  5. Nach einem Froxlor-Update über das Admin-Backend ergibt sich folgende Situation: Beim Aufruf des Backends: It seems you are using an older version of PHP Froxlor requires at least PHP version 7.1.0 The installed version is: 7.0.33-53+0~20210826.58+debian9~1.gbpf7a29f PHP7.3 ist installiert: php -v PHP 7.3.30-1+0~20210826.87+debian9~1.gbpe56a7b (cli) (built: Aug 26 2021 16:06:22) ( NTS ) Copyright (c) 1997-2018 The PHP Group Ich habe keinen Weg gefunden, Forxlor zum Umstieg auf die 7.3 zu bekommen. Daher habe ich geschaut, ob ich das in der Datenbank manuell ändern muss. Ich habe die Einstellungen defaultini, vhost_defaultini und mod_fcgid_defaultini_ownvhost auf die ID der 7.3 version gesetzt. Hat aber auch nicht funktioniert. Zur Sicherheit wollte ich die manuell Konfigs neu schreiben lassen, damit die Änderungen übernommen werden, bekomme daraufhin aber nur: php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug Version of file doesn't match version of database. Exiting... Possible reason: Froxlor update Information: Current version in database: 0.10.20 (DB: 202007240) - version of Froxlor files: 0.10.28 (202108180)) Solution: Please visit your Foxlor admin interface for further information. Webseiten, denen PHP7.3 vorher schon zugeordnet war, laufen ohne Probleme. Wie kriege ich nun zunächst die Versionen auf Gleichstand und dann funktioniert nach dem Neuschreiben der Konfigs vielleicht auch PHP7.3 für das Backend?
  6. Eine Subdomain wurde als Kunde über den Kundenbereich angelegt. Sie wurde auch erfolgreich erstellt. Nun irritiert mich, dass sie zwar im Kundenbereich sichtbar ist, aber nicht im Admin Bereich. Sollte nicht der Admin in seinem Bereich alle angelegten Domains sehen? Was würde passieren, wenn der Admin aus welchem Grund auch immer, die gleiche Subdomain noch einmal erstellt, vielleicht sogar mit anderen Parametern?
  7. Jetzt scheint es auch zu funktionieren.
  8. Kann ich ausprobieren. Wie füge ich das am einfachsten ein? Per Copy & Paste?
  9. Hab ich doch: Ja bitte, wäre nett, wenn du das überprüfen kannst. Wichtig wäre ja nicht, ob der Wert angezeigt wird, sondern ob er übernommen wird. Da in meinen Logs der Idle-Timeout steht, befürchte ich, dass das System den Wert nicht berücksichtigt.
  10. Vielleicht schaue ich auch falsch oder habe ein Verständnisproblem? Ich sehe, dass unter /etc/php/7.0/fpm/pool.d conf-Dateien für die Domains liegen, in denen pm.process_idle_timeout auf die richtige Dauer vom child gesetzt ist. In der entsprechenden vhost unter /etc/apache2/sites-enabled steht aber unter FastCgiExternalServer die falsche Zeit, nämlich die vom parent. Ist es überhaupt richtig, dass in beiden die gleichen Sekunden stehen müssten?
  11. So ich habe gerade das Update gemacht. Folgende Situation: 1. Die Crons haben nicht mehr funktioniert. Obwohl ich im Syslog den Aufruf des Crons sehe, wurden keine Konfigs mehr neu erstellt. Ich habe das mit dem -force parameter nun ainmal manuell gemacht, da hat es funktioniert. Ob es nun wieder automatisch geht, muss man sehen. 2. Der Idle Timeout wird immer noch nicht übernommen.
  12. Ja, die Version ist älter. Dann versuche ich es später über autoupdate.
  13. Das letzte Mal als ich per apt-get updaten wollte, wurde mir kein Paket mehr angeboten. Geht das nur noch manuell und wenn ja wie?
  14. Es wird nur der Parent übernommen. Meine Version ist 0.10.3.
  15. Nein, da habe ich dich missverstanden: Das Dropdownfeld zeigt korrekt das an, was ich einstelle. Muss der parent auf etwas bestimmtem stehen? Ich stelle jetzt einmal beides auf "ondemand" nur mit unterschiedlichen Idle-Timeout.
  16. Also im Dropdownfeld bleibt es auf "ondemand" eingestellt. Ich habe eben testweise in PHP-Versionen den Idle-Timeout verändert und das wird in die Vhost übernommen.
  17. Dann scheint bei mir etwas nicht zu stimmen. Im Moment sieht es so aus. Unter PHP-FPM Versionen: Process Manager Control: dynamic Idle-timeout: 120s Unter PHP Konfigurationen die entsprechende PHP Version zugeordnet. Überschreibe FPM-Daemon Einstellungen: Angehakt Process Manager Control: ondemand Idle-timeout: 30s Im Vhost steht dennoch: FastCgiExternalServer -idle-timeout 120 Hier müssten nun doch die 30s stehen? Oder ist das eine andere Einstellung?
  18. Warum wird mein PHP-FPM idle timeout nicht übernommen? In PHP Versionen ist 120s eingestellt. In PHP Konfigurationen 300s, Überschreibe FPM-Daemon Einstellungen ist angehakt. Domain entsprechend zugeordnet. Trotzdem wird es nicht übernommen. Es bleibt bei 120s.
  19. Hat sich gerade erledigt. Die erlaubten Konfigurationen waren beim Kunden falsch eingestellt.
  20. Irgendetwas übersehe ich: Bei einer Domain lässt sich die gewünschte PHP Konfiguration nicht auswählen. Alle PHP-Konfigurationen bis auf die aktuell eingestellte, erscheinen grau. Wenn ich eine andere Domain auswähle, erscheinen die verfügbaren Konfigurationen im Dropdown-Feld nicht grau und die gewünschte Konfiguration lässt sich auswählen.
  21. Version ist Debian 8.11 Installiert habe ich es (glaube ich) nur nach der Froxlor Anleitung. Also einfach apt-get install postfix postfix-mysql Die Zeile in postfix-files sieht jetzt so aus: #$daemon_directory/dict_sdbm.so:f:root:-:755 Bei Google findet man nicht sehr viel darüber, was diese Datei macht. Ein Vorschlag ist das Paket postfix-tls zu installieren, das findet apt-get aber nicht bei mir.
  22. Weiß jemand, was es mit /usr/lib/postfix/dict_sdbm.so auf sich hat? Laut postfix-files sollte die Datei vorhanden sein, ist sie aber nicht. Ich habe den Eintrag dazu jetzt einmal auskommentiert, weil Postmulti sonst nicht läuft. Wo kriege ich die Datei her, bzw. brauche ich sie?
  23. Komisch. Es geht um eine Trennung der SMTP-Authentifizierung von der Postfach-Erstellung. Aber das bringt mich jetzt noch einmal auf eine andere Idee: Wenn man ein Postfach mit einer kaum zu erratenden E-Mail Adresse erstellt, dann könnte man dies rein zur Authentifizierung am SMTP-Server verwendet werden und die Überwachung des Postfaches kann man sich sparen, weil wahrscheinlich niemand die Adresse errät.
  24. Die, in der der die Logins und Passwörter drin stehen. Schon, nur Konto bedeutet doch auch automatisch Anlegen von einem POP-Konto und damit Empfang auf dieser Adresse, oder nicht? Es soll aber nur Senden. Oder kann ich das Abstellen, dass ein POP-Konto angelegt wird?
  25. Ich habe gerade einen Fall, bei dem ein generisches login für E-Mails glaube ich sinnvoll wäre. Im Moment ist es ja so, dass der SMTP login an eine reale E-Mail Adresse bzw. an ein angelegtes E-Mail Konto gebunden ist. Wenn nun aber Webscripte EMails versenden, z.B. Newsletter oder Statusmeldungen, dann müsste man für die entweder einen eigenen Account anlegen oder über bestehende Accounts versenden, was aber die Gefahr birgt, dass bei Änderungen an den E-Mails dann irgendwelche Skripte nicht mehr funktionieren. Daher die Idee und Frage, ob man nicht die MySQL Abfrage in mysql-virtual_sender_permissions.cf so erweitern kann, dass sie auch die Kundentabelle abfragt. So könnte man für ein Webscript das Kundenlogin mit Passwort als SMTP Login verwenden, ohne sich um die Organisation von E-Mail Adressen kümmern zu müssen.
×
×
  • Create New...