Jump to content
Froxlor Forum
  • 0

mod_fcgid: stderr: richdocumentscode (proxy.php) error exit, PID: 212444, Message: exec_disabled


tt33tt
 Share

Question

Hallo alle zusammen,

ich habe in der Nextcloud den eingebauten CODE-Server für Collabora installiert und aktiviert. Wenn ich jetzt versuche Word-Dateien in der Nextcloud über Collabora zu öffnen, taucht im Error-Log folgender Fehler auf:

mod_fcgid: stderr: richdocumentscode (proxy.php) error exit, PID: 212444, Message: exec_disabled

Was bedeutet diese Meldung?

Muss ich bei mod_fcgid irgendetwas enablen?

 

LG

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 1

Welche Anforderungen nextcloud, collabora server oder andere tools haben die du einsetzt musst du in deren Dokumentation / Hilfe nachlesen. Froxlor bietet dir ja alle Freiheiten die php configs / php.ini Einstellungen entsprechend anzupassen. Welches (sicherheits-)risiko du dabei eingehst ist ebenso dir überlassen. Diese Funktionen sind zurecht standardmäßig deaktiviert, aber genauso zu recht existieren sie, da Ihre Nutzung schlichtweg nötig sein kann.

Diese Anpassungen auf eine einzelne Domain zu begrenzen ist doch defintiv schon eine gute Sache - völlig ausschließen kann man nie etwas - aber damit minimierst du defintiv die Angriffsfläche

Link to comment
Share on other sites

  • 0

Ich ürde sagen die Meldung sagt recht eindeutig das die funktion "exec" disabled ist, was in der default php.ini von froxlor für kundendomains aus sicherheitsgründen auch der fall ist (disabled_functions Direktive)

Link to comment
Share on other sites

  • 0

Der Collabora Server in der Nextcloud scheint sowohl die exec-Funktion als auch allow_url_fopen = ON zu benötigen.

Ich habe beides angeschaltet, aber nur für die Nextcloud.

Es kam der Fehler

GuzzleHttp\Exception\RequestException: cURL error 1: Received HTTP/0.9 when not allowed (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://cloud.medien-bildung.info/apps/richdocumentscode/proxy.php?req=/lool/convert-to/png

 

Exec ist ok, aber fopen scheint noch nicht angenommen zu werden.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...