Jump to content
Froxlor Forum
  • 0

Used install script now my mysql root password is not working


Question

I am trying to install froxlor on my VPS. I started by downloading the php shell-installer as shown on this site: https://froxlor.org/download.php

During the install it asked for my mysql admin login (root/password) and all seemed to be going well until further in the script I got an access denied message for my root user. Now I can't seem to get back into mysql with my admin account. I can access the new unprivileged user account the script created, as well as other user accounts, but my root login gets access denied. Here is the sequence:

image.png.1f47a9fd11abce7430c3483d13b92805.png

As you can see I have successful login, creates the database and user. Then abruptly the login stops working and errors out when creating the tables. After the script stops I can no longer access mysql.

 

Anyone have any ideas? I have yet to reboot the server as it is running some minor services I would prefer not to take down during the week but I will try that on friday if nothing else.

 

Thank you

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Can you retry using the web-installer to see if this is an issue in the shell-installer or with your vps possibly

Link to post
Share on other sites
  • 0

I have been browsing the installer code and while I can't be sure I suspect something happened in line 401: 

$db_root->exec("UPDATE mysql.user SET `plugin` = '' WHERE `User` = '" . $this->_data['sql']['root_user'] . "';");

When I setup mysql a few years ago I believe I followed my VPS's guide (digital ocean) and it shows that my user table should look like this:

image.png.b524fa441db068bfe97b2df1d5aef5df.png

Perhaps removing the plugin has bricked my admin account?

Luckily this is not critical to get admin access back today. I found some instructions on resetting the account but I can't try it until the weekend when I can take down the mysql database for a while. 

 

Link to post
Share on other sites
  • 0

Does 'mysql -h localhost -u root -p' work? If you get the same "access denied" message you have to enable localhost access for root to your database.

Link to post
Share on other sites
  • 0

Just an update, I used the instructions here to reset my root account and was able to restore access. As I suspected, one of the steps was to add the 'mysql_native_password' string to the plugin field in the users table:

UPDATE mysql.user SET plugin = 'mysql_native_password' WHERE user = 'root';

 

I think line 401 in the installer script should be looked at and modified so it does not break for other Ubuntu/mysql users in the future

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...