Jump to content
Froxlor Forum
  • 0

ssl mit Presta-shop


Question

Hallo zusammen.

Ich benutze auf meiner Domain einen Webshop.

Da gibt es die Option SSL verwenden. Wenn ich jetzt aber SSL mit Let's Encrypt mache muss ich dann SSL Option im Shop deaktivieren oder trotzdem aktivieren.

Auch komm ich gerad mit der Weiterleitung nicht klar. Ich habe ein ssl zerti bekommen aber immer wenn ich auf die Seite gehe leitet er mich vom Domainnamen wieder auf die Ip um. Was muss ich machen, damit es funktioniert?
 

Hier meine DNS-Einstellungen (autowert habe da nix verändert)

$TTL 604800
$ORIGIN shop.arctrinitycluster.de.
@    604800    IN    SOA    arctrinitycluster.de admin.arctrinitycluster.de. 2021022203 3600 900 604800 604800
@    604800    IN    A    5.9.36.195
www    604800    IN    A    5.9.36.195
@    604800    IN    TXT    "v=spf1 a mx -all"
dkim1._domainkey    604800    IN    TXT    "v=DKIM1;k=rsa;p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCj/NqfPkMK4Lg6mOt+0SxZGNggSy/kd1mRaanCpgli3m/+qcJrhW3pFRXh1DqWvNgEAZ9oOFWkWaEfHoCW//j5L4nbUaisSuSvSi0OboiTuQIOrxGA2zvYlkd6P2Z7NTz1V5P8JBlEHL6BNmbg3Q3AzCQ2xmx2aOidhVuSthPWsQIDAQAB;t=s"
@    604800    IN    CAA    0 issue "letsencrypt.org"
www    604800    IN    CAA    0 issue "letsencrypt.org"

 

$TTL 604800
$ORIGIN shop.arctrinitycluster.de.
@	604800	IN	SOA	arctrinitycluster.de admin.arctrinitycluster.de. 2021022203 3600 900 604800 604800
@	604800	IN	A	5.9.36.195
www	604800	IN	A	5.9.36.195
@	604800	IN	TXT	"v=spf1 a mx -all"
dkim1._domainkey	604800	IN	TXT	"v=DKIM1;k=rsa;p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCj/NqfPkMK4Lg6mOt+0SxZGNggSy/kd1mRaanCpgli3m/+qcJrhW3pFRXh1DqWvNgEAZ9oOFWkWaEfHoCW//j5L4nbUaisSuSvSi0OboiTuQIOrxGA2zvYlkd6P2Z7NTz1V5P8JBlEHL6BNmbg3Q3AzCQ2xmx2aOidhVuSthPWsQIDAQAB;t=s"
@	604800	IN	CAA	0 issue "letsencrypt.org"
www	604800	IN	CAA	0 issue "letsencrypt.org"

 

 

Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0
Just now, Rund um BauerAndraste said:

Wenn ich jetzt aber SSL mit Let's Encrypt mache muss ich dann SSL Option im Shop deaktivieren oder trotzdem aktivieren.

Da ich nicht weiss was Presta Shop bei dieser option macht würde ich mir da die Doku einfach mal anschauen. Vllt macht er einen einfachen http zu https redirect

1 minute ago, Rund um BauerAndraste said:

Auch komm ich gerad mit der Weiterleitung nicht klar. Ich habe ein ssl zerti bekommen aber immer wenn ich auf die Seite gehe leitet er mich vom Domainnamen wieder auf die Ip um. Was muss ich machen, damit es funktioniert?

Wenn du ein Zertifikat von Lets Encrypt bekommn hast, muss wohl der Vhost für die Domain ansich passen, kann ich auch nur vermuten das ggfls der Presta Shop da was komisches an weiterleitung macht (mal geschaut ob es eine .htaccess gibt und was die so macht?)

Link to post
Share on other sites
  • 0

auszug:

RewriteCond %{HTTP_HOST} ^5.9.36.195$

Sie so aus als wäre der shop via IP installiert/konfiguriert worden und jetzt möchte er auch darauf laufen ....Ist leider ein reines Presta-Shop "problem" - da kann jetzt froxlor nicht viel helfen

Link to post
Share on other sites
  • 0

Du musst in den Optionen folgendes aktivieren:

 

ssl.thumb.JPG.d9f1a8968df7fd0ad06feaf7b2695a4d.JPG

 

Welcher Webserver wird benutzt? habe dieses Shop System oh. Probleme mit LE SSL getestet und ging ohne Probleme.

Und wie d00p, schon angemerkt hat, wurde deine Shop Seite per IP anstatt mit einer Domain installiert. Daher kannst du probieren in der DB, Manuel die Einträge zu ändern oder installiert den Shop noch mal richtig mit einer Domain.

 

*Nachtrag*

Du kannst die die Domain auch per DB ändern.
In folgenden Tabellen findet du die Einträge:

  • - ps_configuration
  • - ps_connections_source

Test Installation inkl. Demo Content > https://testing.anime-mitsuketa.tokyo/

  • Like 1
Link to post
Share on other sites
  • 0

vielen Dank für die Antwort

ich habe bei mir in der DB zwar 

  • - ps_configuration
    aber da steht keine ip oder Domain drin
  • in der ps_connections_source auch nicht

    Ich habe froxlor installiert und meine Domain liegt bei Vionity
    Ich benutze Apache2

 

so hab jetzt installiert aber schon unter https:// jetzt hab ich das Problem, wie ich an die Einstellungen komme. Er läd und läd die Aktivitäten und das Fenster unten links kann ich auch nicht wegklicken im Quelltext erscheint das : 


index.php?controller=AdminDashboard&token=b93a48f0b0999921bdb41c6dfaa9e1d3:1663 Mixed Content: The page at 'https://shop.arctrinitycluster.de/admin663y08okj/index.php?controller=AdminDashboard&token=b93a48f0b0999921bdb41c6dfaa9e1d3' was loaded over a secure connection, but contains a form that targets an insecure endpoint 'http://shop.arctrinitycluster.de/admin663y08okj/index.php?controller=AdminDashboard&token=b93a48f0b0999921bdb41c6dfaa9e1d3'. This endpoint should be made available over a secure connection.

was kann ich tun, damit ich weiterkomme

Link to post
Share on other sites
  • 0
1 hour ago, Rund um BauerAndraste said:

vielen Dank für die Antwort

ich habe bei mir in der DB zwar 

  • - ps_configuration
    aber da steht keine ip oder Domain drin

Ich bin jetzt ganz offen, hast du überhaupt ne Ahnung, was du da treibst? Wie erwähnt, habe das Sys ohne Probleme mit LE SSL installiert (siehe oberen link).
Poste doch mal den error log, von deiner Domain oder nenne doch mal deine Domain, das wir dir weiterhelfen können.
Laut deiner .htaccess läuft dein Shop Sys auf einer IP, anstatt einer richtigen Domain, die Datei bekommt ihre Infos aus der DB, also hast du einfach falsch installiert oder dein ganzes Sys läuft falsch.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...