Jump to content
Froxlor Forum
  • 0

Mit php-fpm wird nur Code im Browser ausgegeben


Aivas

Question

Hallo,

nachdem ich auf PHP-FPM umstelle, bekomme ich im Browser nur den PHP Code angezeigt.

Selbstverständlich bin ich nochmal alle Einstellungen und Konfigurationen im Panel durch gegangen, aber konnte nichts finden, was ich übersehen habe.

In einem anderen Post war die Lösung, dass auf dem Server ipv6 aktiviert war, ohne dass diese IP im Froxlor eingerichtet war. Aber Deaktivieren von ipv6 im System brachte auch keine Lösung.

Hat jemand Tipps, was ich speziell überprüfen sollte?

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Logs...? Vhost beispiel? Also da muss was schiefgelaufen sein, denn PHP Code bekommst du nur angezeigt wenn es keinen handler gibt. Selbst wenn fpm nicht läuft sollte aber in den generierten vhosts der handler angegeben sein und entsprechend ein 50x Fehler geworfen werden. Also...bitte erstmal error logs...da stimmt was anderes nicht

Link to post
Share on other sites
  • 0

Jetzt als ich die Logs kopieren wollte fällt mir erst auf:

[Sat Nov 21 08:55:08.271523 2020] [ssl:warn] [pid 1063:tid 140184625796224] AH01916: Init: (host:443) You configured HTTP(80) on the standard HTTPS(443) port!

Und im apache vhost bestätigt sich das auch.

Kann es daran liegen? Doch warum macht Froxlor das, obwohl SSL deaktiviert ist? Außerdem finde ich keine Einstellung im Panel, das zu ändern.

 

Link to post
Share on other sites
  • 0

Dachte, das wäre die Lösung gewesen, aber das Löschen des 443 vhost hat nichts geändert.

Der vHost ist:

<VirtualHost *:80>
DocumentRoot "/var/www/html"
  <FilesMatch \.(php)$>
  SetHandler proxy:unix:/var/lib/apache2/fastcgi/1-froxlor.panel-host-php-fpm.socket|fcgi://localhost
  </FilesMatch>
</VirtualHost>

Das Wort "host" habe ich fürs Forum abgeändert, da steht sonst der tatsächliche Hostname. Die socket Datei ist auch im genannten Verzeichnis vorhanden.

Im apache error.log steht:

[Sat Nov 21 11:49:50.989621 2020] [suexec:notice] [pid 3576] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Sat Nov 21 11:49:51.043390 2020] [:error] [pid 3577] python_init: Python version mismatch, expected '2.7.5+', found '2.7.16'.
[Sat Nov 21 11:49:51.043678 2020] [:error] [pid 3577] python_init: Python executable found '/usr/bin/python'.
[Sat Nov 21 11:49:51.043757 2020] [:error] [pid 3577] python_init: Python path being used '/usr/lib/python2.7:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
[Sat Nov 21 11:49:51.043805 2020] [:notice] [pid 3577] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
[Sat Nov 21 11:49:51.043830 2020] [:notice] [pid 3577] mod_python: using mutex_directory /tmp
[Sat Nov 21 11:49:51.071327 2020] [mpm_prefork:notice] [pid 3577] AH00163: Apache/2.4.38 (Debian) mod_fcgid/2.3.9 OpenSSL/1.1.1d mod_python/3.3.1 Python/2.7.16 mod_perl/2.0.10 Perl/v5.28.1 configured -- resuming normal operations
[Sat Nov 21 11:49:51.071455 2020] [core:notice] [pid 3577] AH00094: Command line: '/usr/sbin/apache2'

Welche Logs werden noch benötigt?

Link to post
Share on other sites
  • 0

Froxlor erstellt nur vhosts mit IP, Wildcard gibt's nicht. Die ganzen Python errors haben nix mit froxlor und deinem anderen Problem zu tun. Du wirst halt evtl in froxlor eine ip mit Port 443 angelegt aber kein Häkchen bei ssl gesetzt oder so.

Link to post
Share on other sites
  • 0

Nur funktioniert es mit IP nicht. Damit bekomme ich nur den PHP Code vom Panel angezeigt im Browser. Ändere ich das manuell auf * ab und restarte den Apache, dann passt es und das Panel wird angezeigt.

Also irgend wo sollte ich noch einen Fehler haben, aber kann es nicht finden.

Link to post
Share on other sites
  • 0

Habe es heraus gefunden. Habe anfangs völlig falsch gesucht, da ich nicht mehr dran gedacht habe, dass das System ein vServer ist, in dem die öffentliche IP nicht direkt konfiguriert ist, sondern die die Daten von Hostsystem nur durchgereicht bekommt. Somit muss ich natürlich die interne IP im Froxlor eintragen. Im Nachhinein klar, aber dauert manmchmal ewig bis man drauf kommt.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...