Jump to content
Froxlor Forum
  • 0
feiaweng

froxlor Upgrade von 0.9.40 auf 0.10.17 Debian Stretch funktioniert nicht

Question

Hallo Community,

ich habe froxlor 0.9.40 auf Debian Jessie laufen, und wollte auf dem 2. Server Debian und froxlor upgraden.

Nach dem Update auf Debian Stretch habe ich alle mysql-DBs gedumpt, und wollte diese auf dem anderen Server importieren.

Das hat teilweise funktioniert. Sobald ich php-fpm im Panel aktiviere, und angebe, ich möchte libnss-extrausers nutzen, fährt apache nicht mehr hoch.

Liegt daran, das getent passwd keine User liefert, und somit der Apache den User nicht kennt. Und die php-fpm config basiert ja noch auf libnss-mysql-bg. Wenn ich im Panel den Haken setze, ich will libnss-extrausers nutzen, legt er unter /var/lib/customers in den files passwd/group/shadow keine User an. Der cronjob mit --force --debug schlägt dann auch fehl.

Muss ich die  importierte mysql-DB vorher anpassen, konvertieren, damit das klappt. Oder liegt der Fehler woanders?

 

Danke euch schon mal, welche Logs etc. braucht ihr denn? Die files kann ich gezielt liefern.

 

Gruß feiaweng

Share this post


Link to post
Share on other sites

23 answers to this question

Recommended Posts

  • 0
21 minutes ago, feiaweng said:

Wenn ich im Panel den Haken setze, ich will libnss-extrausers nutzen, legt er unter /var/lib/customers in den files passwd/group/shadow keine User an. Der cronjob mit --force --debug schlägt dann auch fehl.

1) auch entsprechende config Templates ausgeführt?

2) Ausgabe des Fehler des cronjobs?

21 minutes ago, feiaweng said:

Muss ich die  importierte mysql-DB vorher anpassen, konvertieren, damit das klappt. Oder liegt der Fehler woanders?

Wüsste nicht was du da konvertieren willst?  Wo der Fehler liegt sehen wir dann wenn geforderte Info vorliegt ;)

Share this post


Link to post
Share on other sites
  • 0

ich habe nachdem ich die  DB importiert habe, im Apache SSL und PHP_FPM deaktiviert gelassen. Im Apachen SSL aktiviert. Funktioniert. Wenn ich PHP_FPM aktiviere und den Apachen neu starte hat er alle Letsencrypt Certs gelöscht, wenn ich diese vom alten System unt /etc/apache2/ssl einfüge, lässt er sich starten.

Ich muss dazu sagen, auf dem Server 1 habe ich viele LE Certs installiert.

getent passwd zeigt keine mysql user an, nur die lokalen.

Ausfürhren des cronjobs: /usr/bin/php7.2 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

[information] TasksCron: Searching for tasks to do
[information] Task4 started - Rebuilding froxlor_bind.conf
[information] Cleaning dns zone files from /etc/bind/domains/
[information] No domains found for nameserver-config, skipping...
[information] apache::createIpPort: creating ip/port settings for  IP:80
[notice] IP :: namevirtualhost-statement no longer needed for apache-2.4
[debug]IP :: inserted vhostcontainer
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/40-diroptions
[information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] Froxlor\Cron\Http\ApacheFcgi::reload: fpm config directory "/etc/php-fpm.d/" is empty. Creating dummy.
[information] Froxlor\Cron\Http\ApacheFcgi::reload: running service php7.2-fpm restart
[information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi
[notice] Creating passwd file
[notice] Writing 0 entries to passwd file
[notice] Succesfully wrote passwd file
[notice] Creating group file
[notice] Writing 0 entries to group file
[notice] Succesfully wrote group file
[notice] Creating shadow file
[notice] Writing 0 entries to shadow file
[notice] Succesfully wrote shadow file
[notice] Checking system's last guid

 

Das Verzeichnis /etc/php-fpm.d/" war nicht leer, da sind die fpm-configs drin. Die hat er aber überschrieben. Wo soll er denn die neuen Configs herhaben?

 

 

Share this post


Link to post
Share on other sites
  • 0

Also was du im gunde gemacht hast sind wieder viele kleine Dinge auf einmal die man ganz gemütlich eine nach der anderen macht und nicht so mischt, denn so ist es gerade für jemandem der hier mitliest unglaublich schwierig das alles aufzudröseln:

MySQL: Du sagst der import der gedumpten Datenbanken habe nur teilweise funktioniert ohne weitere Erläuterung, was sollen wir damit anfangen? Bei Umzug von Server A auf B beachte bitte das du auch die mysql-Datenbank mitnehmen musst, denn hier speichert der MySQL server seine Benutzer (ergo, die Zugänge zu deinen Datenbanken!).

libnss-extrausers / php-fpm: Allen voran hast du meine zwei Fragen bezogen auf diese Problematik aus meiner vorherigen Antwort nicht beantwortet, ich gehe also mal nicht davon aus. Zum Anderen bezweifle ich stark das die php-fpm pool configs unter debian buster (bei default installation) in dem von dir angegebenen Ordner /etc/php-fpm.d/ liegen.

Du hast also nach deinem gewaltigen Versionsprung und gleichzeitigem Aktivieren von php-fpm deine Einstellungen  nicht überprüft und an dein System angepasst.

Let's Encrypt: Sorry, aber das Aktivieren von php-fpm löscht sicher nicht alle Zertifikate, wie bereits gesagt, mach nicht 10 Dinge auf einmal. Richte eins nach dem anderen ein und behebe ein Problem nach dem anderen sonst weisst du am ende nicht warum woher welcher Fehler kommt weil du an 10 Schrauben gleichzeitig gedreht hast.

Share this post


Link to post
Share on other sites
  • 0
vor 1 Minute schrieb d00p:

Also was du im gunde gemacht hast sind wieder viele kleine Dinge auf einmal die man ganz gemütlich eine nach der anderen macht und nicht so mischt, denn so ist es gerade für jemandem der hier mitliest unglaublich schwierig das alles aufzudröseln:

MySQL: Du sagst der import der gedumpten Datenbanken habe nur teilweise funktioniert ohne weitere Erläuterung, was sollen wir damit anfangen? Bei Umzug von Server A auf B beachte bitte das du auch die mysql-Datenbank mitnehmen musst, denn hier speichert der MySQL server seine Benutzer (ergo, die Zugänge zu deinen Datenbanken!).

ich habe alle mysl-DBs in einem Dump, auch die mysql. Der Import war erfolgreich. Ich meinte mit, teilweise nicht funktioniert, dass der Dump aus einem Jessie mysql-db stammt, auf Stretch eine Maria-DB läuft. Und die Settings von froxlor 0.9.40 stammen. Hab mich unglücklich ausgedrückt. Also der Dump war erfolgreich.

libnss-extrausers / php-fpm: Allen voran hast du meine zwei Fragen bezogen auf diese Problematik aus meiner vorherigen Antwort nicht beantwortet, ich gehe also mal nicht davon aus. Zum Anderen bezweifle ich stark das die php-fpm pool configs unter debian buster (bei default installation) in dem von dir angegebenen Ordner /etc/php-fpm.d/ liegen.

Meinst du deine Frage 1) auch entsprechende config Templates ausgeführt? Dachte du redest von der Konfiguration ausführen für die Distro im Panel. Falls du was anderes gemeint hast, sag mir bitte was.

Ich gebe im Panel an, dass die php-fpm configs liegen unter /etc/php-fpm.d/, weil die da auf dem Server 1 auch liegen. In der conf /etc/php/7.2/fpm/php-fpm.conf habe ich unter include=/etc/php-fpm.d/*.conf angegeben.

Oder muss das der Defaultpfad sein?

Du hast also nach deinem gewaltigen Versionsprung und gleichzeitigem Aktivieren von php-fpm deine Einstellungen  nicht überprüft und an dein System angepasst.

Let's Encrypt: Sorry, aber das Aktivieren von php-fpm löscht sicher nicht alle Zertifikate, wie bereits gesagt, mach nicht 10 Dinge auf einmal. Richte eins nach dem anderen ein und behebe ein Problem nach dem anderen sonst weisst du am ende nicht warum woher welcher Fehler kommt weil du an 10 Schrauben gleichzeitig gedreht hast.

Ok, ich könnte ja nochmal von vorne anfangen:
mysqldump importieren

Konfiguration im Panel komplett durchgehen, bzw. das install-services.php script ausführen

Apache SSL aktiveren

php-fpm config anpassen

Wäre das der richtige Weg?

Share this post


Link to post
Share on other sites
  • 0
39 minutes ago, feiaweng said:

Ich gebe im Panel an, dass die php-fpm configs liegen unter /etc/php-fpm.d/, weil die da auf dem Server 1 auch liegen. In der conf /etc/php/7.2/fpm/php-fpm.conf habe ich unter include=/etc/php-fpm.d/*.conf angegeben.

Oder muss das der Defaultpfad sein?

Nein muss es natürlich nicht, wenn du es überall konsistent nutzt ist ja gut, dann sollte es ja passen.

39 minutes ago, feiaweng said:

Konfiguration im Panel komplett durchgehen, bzw. das install-services.php script ausführen

Und da stoppe ich doch schon, ERST einstellungen anpassen, DANN config-services script / manuell die config templates durchgehen.

SSL für apache wird dir dann von den config-templates schon aktiviert wenn du es in den Einstellungen entsprechend aktiviert hast (und auch Let's Encrypt -> acme.conf alias usw.) wenn die Einstellungen stimmen machen die config-templates das alles für dich - deswegen ist es ja so wichtig AM ANFANG alle Einstellungen anzupassen, bevor man die Dienste konfiguriert. Zumindest ist es so der einfachste weg.

Share this post


Link to post
Share on other sites
  • 0
vor 39 Minuten schrieb d00p:

Nein muss es natürlich nicht, wenn du es überall konsistent nutzt ist ja gut, dann sollte es ja passen.

Und da stoppe ich doch schon, ERST einstellungen anpassen, DANN config-services script / manuell die config templates durchgehen.

SSL für apache wird dir dann von den config-templates schon aktiviert wenn du es in den Einstellungen entsprechend aktiviert hast (und auch Let's Encrypt -> acme.conf alias usw.) wenn die Einstellungen stimmen machen die config-templates das alles für dich - deswegen ist es ja so wichtig AM ANFANG alle Einstellungen anzupassen, bevor man die Dienste konfiguriert. Zumindest ist es so der einfachste weg.

ok,danke,

ich werde das jetzt genau so mache. Froxlor reinstallieren, dann starten, alle Einstellungen durchgehen, dann services aus den config templates konfigurieren, dann mysql import.

Share this post


Link to post
Share on other sites
  • 0

Warum denn Neuinstallation? Übernimm doch erstmal alles vom alten Server auf den neuen, mach dann das Update - Pass alle (neuen) Einstellungen an und rekonfiguriere dann die Dienste nach Bedarf.

Share this post


Link to post
Share on other sites
  • 0
vor 3 Minuten schrieb d00p:

Warum denn Neuinstallation? Übernimm doch erstmal alles vom alten Server auf den neuen, mach dann das Update - Pass alle (neuen) Einstellungen an und rekonfiguriere dann die Dienste nach Bedarf.

also ich habe einen mysqldump vom alten Server (Debian 8 und Froxlor 0.9.40), den Dump importiere ich nun in mysql, dann habe ich alle Daten die ich brauche, dann starte ich froxlor auf dem  neuen Server (Debian 9 und Froxlor 0.10.17) gehe alle Einstellungen durch, und führe die config templates aus. Oder meintest du ich soll auf dem neuen Server die Froxlor Version 0.9.40 installieren, und diese dann updaten auf 0.10.17?

Share this post


Link to post
Share on other sites
  • 0

Na wenn du einen dump hast, hast du doch eh noch die Datenbank von 0.9.40 - das DB update musst du dann eh noch machen, kannst also ruhig auf dem neuen schon die 0.10.17 Dateien haben - nur frolxor brauchst du da nicht erst noch mal installieren von null, du nutzt ja eine bestehende Datenbank (also kopiere die lib/userdata.inc.php von 0.9.40 nach lib/ von 0.10.17). Danach machst du alle Einstellungen, dann konfigurierst du die Dienste. Easy

Share this post


Link to post
Share on other sites
  • 0
vor 12 Minuten schrieb d00p:

Na wenn du einen dump hast, hast du doch eh noch die Datenbank von 0.9.40 - das DB update musst du dann eh noch machen, kannst also ruhig auf dem neuen schon die 0.10.17 Dateien haben - nur frolxor brauchst du da nicht erst noch mal installieren von null, du nutzt ja eine bestehende Datenbank (also kopiere die lib/userdata.inc.php von 0.9.40 nach lib/ von 0.10.17). Danach machst du alle Einstellungen, dann konfigurierst du die Dienste. Easy

so hab jetzt folgendes gemacht:

dump importiert, froxlor DB update gemacht, alle Einstellungen konfiguriert im Panel, nach dem Cronjob von Froxlor kommt dann die Meldung, php7.2-fpm startet nicht. Hab wieder das Problem, dass Apache die User nicht, weil die /var/lib/extrausers files leer sind.

Jetzt weiß ich grad nicht weiter.

Share this post


Link to post
Share on other sites
  • 0

Was sagt fpm beim Start? Ohne Fehlermeldung ist helfen schwer. "Geht nicht" ist keine Meldung.

Offenbar hast Du dann libnss-extrausers nicht korrekt konfiguriert und oder in den Einstellungen nicht aktiviert

Share this post


Link to post
Share on other sites
  • 0
Gerade eben schrieb d00p:

Was sagt fpm beim Start? Ohne Fehlermeldung ist helfen schwer. "Geht nicht" ist keine Meldung.

Offenbar hast Du dann libnss-extrausers nicht korrekt konfiguriert und oder in den Einstellungen nicht aktiviert

sorry,

service apache2 restart
 AH00543: apache2: bad user name USER
 apachectl[19943]: Action 'start' failed.
 apachectl[19943]: The Apache error log may have more information.
 systemd[1]: apache2.service: Control process exited, code=exited status=1
 systemd[1]: Failed to start The Apache HTTP Server.

service php7.2-fpm restart

 Starting The PHP 7.2 FastCGI Process Manager...
 php-fpm7.2[20704]: [04-Jun-2020 19:36:57] ERROR: [pool adrenalinpur.de] cannot get uid for user 'USER'
 php-fpm7.2[20704]: [04-Jun-2020 19:36:57] ERROR: FPM initialization failed
 systemd[1]: php7.2-fpm.service: Main process exited, code=exited, status=78/n/a
systemd[1]: Failed to start The PHP 7.2 FastCGI Process Manager.

 

libnsss-extrausers ist installiert und aktiviert. Froxlor nutzt es aus irgendeinem Grund nciht.

Share this post


Link to post
Share on other sites
  • 0

Hier noch eine Ausgabe, was mich wundert, warum will der unbedingt  /etc/php/7.2/fpm/pool.d/www.conf haben, obwohl ich /etc/php-fpm.d konfiguriert habe?

Process: 20706 ExecStopPost=/usr/lib/php/php-fpm-socket-helper remove /run/php/php-fpm.sock /etc/php/7.2/fpm/pool.d/www.conf 72 (code=exited, status=0

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, feiaweng said:

libnsss-extrausers ist installiert und aktiviert. Froxlor nutzt es aus irgendeinem Grund nciht.

Na dann würde ich doch Mal die entsprechenden Konfigurationsdateien prüfen die du ja via config templates befüllt hast.

1 minute ago, feiaweng said:

Hier noch eine Ausgabe, was mich wundert, warum will der unbedingt  /etc/php/7.2/fpm/pool.d/www.conf haben, obwohl ich /etc/php-fpm.d konfiguriert habe?

Na weil der restart fehlschlägt Läuft er halt mit der config mit der der Dienst gestartet wurde.

Share this post


Link to post
Share on other sites
  • 0
vor 1 Stunde schrieb d00p:

Na dann würde ich doch Mal die entsprechenden Konfigurationsdateien prüfen die du ja via config templates befüllt hast.

Na weil der restart fehlschlägt Läuft er halt mit der config mit der der Dienst gestartet wurde.

Was meinst du mit Konfigurationsdateien prüfen ? Im Panel aktiviere ich die Checkbox, dass ich libnss-Extrausers nutzen will. Führe dann die Befehle aus dem Config Template aus. Wie werden denn die passwd group Shadow befüllt ? Aus der froxlor DB und dem cronjob. Im Debug zeigt er leider nur an, dass er 0 Datensätze angelegt hat. Wo kann ich denn noch gucken ? 

Share this post


Link to post
Share on other sites
  • 0

Also, die nsswitch.conf sagt dem System das sie."extrausers" benutzen sollen wenn du die.korrekt eingerichtet hast. Wenn in froxlor extrausers aktiviert ist, schreibt er die User in eine passwd, group und shadow Datei nach /var/lib/extrausers Über die das extrausers Plugin die dem System bereitstellt. K.a. was du da gemacht hast, das sind normal 2min dann läuft das. Bis auf das aktivieren und config Templates laufen lassen ist doch da nix zu tun.

Sorry, meine Erfahrungen bisher sagen Einfach: entweder was vergessen oder selbst irgendwo manuell in den configs rumgefrickelt ohne zu wissen was man tut - no offense.

Von mir aus schau ich da gern Mal auf die Kiste - zu 99% garantiere ich dir das es nach 2min funktioniert und ich mache nichts anderes als das was ich hier erkläre

Share this post


Link to post
Share on other sites
  • 0
vor 6 Minuten schrieb d00p:

Also, die nsswitch.conf sagt dem System das sie."extrausers" benutzen sollen wenn du die.korrekt eingerichtet hast. Wenn in froxlor extrausers aktiviert ist, schreibt er die User in eine passwd, group und shadow Datei nach /var/lib/extrausers Über die das extrausers Plugin die dem System bereitstellt. K.a. was du da gemacht hast, das sind normal 2min dann läuft das. Bis auf das aktivieren und config Templates laufen lassen ist doch da nix zu tun.

Sorry, meine Erfahrungen bisher sagen Einfach: entweder was vergessen oder selbst irgendwo manuell in den configs rumgefrickelt ohne zu wissen was man tut - no offense.

Von mir aus schau ich da gern Mal auf die Kiste - zu 99% garantiere ich dir das es nach 2min funktioniert und ich mache nichts anderes als das was ich hier erkläre

Ich guck am Wochenende nochmal ganz genau, ob ich was übersehen habe. Kann natürlich nicht ausschließen dass ich irgendwo was gemacht habe, was ich nicht mehr weiß, oder das vom Debian Upgrade kommt. Wenn ich nichts finde, nehm ich jedoch gerne mal dein Angebot an draufzugucken. 
Ich danke dir vielmals für deine Informationen und Mühe. 
Ich meld mich auf jeden Fall mit einem Feedback. 
 

Gruß feiaweng

Share this post


Link to post
Share on other sites
  • 0

Ich habe folgendes gemacht:

dump von Server 1 eingespielt, Froxlor DB Update gemacht, Alle Einstellungen durchgegangen, mod_proxy Haken aktiviert, libnss-extrausers angehakt,  Config Templates konfiguriert von Hand, Configs neu schreiben aktiviert, cronjob mit --force --debug laufen lassen. 
ich hatte noch libapache2-mod-fcgi installiert. Hab ich removed. 
das Modul fastcgi und fcgid brauch ich doch bei Debian Stretch nicht mehr, oder ? Dafür hab ich doch proxy_fcgi aktiviert. 
jetzt kommt allerdings ein Internal Server error 503. 

oder sollte ich doch im Panel Immer nur eine Einstellung ändern, dann configs neu schreiben lassen, dann die nächste Einstellung usw ? Ist der Schritt zu groß die Config von alter Froxlor Config auf neueSettings ? 
 

Gruß feiaweng

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, feiaweng said:

jetzt kommt allerdings ein Internal Server error 503. 

Dann läuft vermutlich php-fpm dienst nicht (korrekt).

Ich kanns dir ohne auf die Kiste zu schauen nicht sagen, das setup ist im grunde recht simpel. Wie in allen threads hier im forum ist es am ende irgendeine kleinigkeit. Zu 99% lag es daran, dass nicht die korrekte Ursache gefunden wurde weil die Fehlermeldungen nicht vollständig genannt wurden, oder als was anderes interpretiert wurden als sie sind, oder oder oder

Dieser Thread zieht sich jetzt schon etwas zu lang und es treten ständig andere Probleme auf die vermutlich alle irgendwo einen gemeinsamen Ursprung haben. Also, ich schau es mir gern auf der Kiste direkt an, andernfalls kommen wir hier nicht weiter.

Share this post


Link to post
Share on other sites
  • 0

ich bin immer noch an dem Thema dran.

Momentan bin ich am evlaluieren, welche Apache Modul denn laufen muss.

mpm_event, mpm_worker, mpm_prefork. Wenn ich alle 3 disable, dann a2enmod php7.2 eingebe, läd er automatisch mpm_prefork.

Andere lässt er wohl nicht zu. Was mich wundert, ist die Meldung

a2enmod php7.2
Considering dependency mpm_prefork for php7.2:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Enabling module mpm_prefork.
Considering conflict php5 for php7.2:
Enabling module php7.2.
To activate the new configuration, you need to run:
  systemctl restart apache2

Ist das ein Fehler, oder kann ich diese Meldung ignorieren?

Gruss feiaweng

 

Share this post


Link to post
Share on other sites
  • 0
16 hours ago, feiaweng said:

Ist das ein Fehler, oder kann ich diese Meldung ignorieren?

wo siehst du denn da einen fehler? Das a2enmod sagt nur was es macht und welche abhängigkeiten es beachten muss - ich seh da keine fehler

Share this post


Link to post
Share on other sites
  • 0
vor 1 Stunde schrieb d00p:

wo siehst du denn da einen fehler? Das a2enmod sagt nur was es macht und welche abhängigkeiten es beachten muss - ich seh da keine fehler

ich hab vermutet, dass diese Zeile einen Konflikt aussagt:

Considering conflict php5 for php7.2

Wenn dem nicht so ist, dann kann ich das wohl ignorieren. Bisher hatte ich noch keine solche Meldung beim Aktivieren eines Moduls.

 

Share this post


Link to post
Share on other sites
  • 0

Die Zeile sagt, dass a2enmod wohl gemerkt hat da du php5 und php7.2 installiert hast und nun konflikte prüfen muss, weil du nicht beide mod_php versionen gleichzeitig aktivieren kannst, sprich, er hat geprüft, ob php5 bereits geladen ist, weil das mit php7.2 conflicten würde

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...