Jump to content
Froxlor Forum
  • 0
irisdina

acme.sh Failed

Question

Hi,

habe froxlor heute auf dem neusten stand gebracht und wollte eine domain hinzufügen inkl. ssl settings.
Da ist mit dieser Fehler aufgefallen, durch den Fehler wird auch mein nginx process gekillt jedesmal.

 

php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug
[information] TasksCron: Searching for tasks to do
[information] Running Let's Encrypt cronjob prior to regenerating webserver config files
[information] Requesting 1 new Let's Encrypt certificates
[warning] Skipping Let's Encrypt generation for xxxxxxxxxxxxxx.eu due to an enabled ssl_redirect
[error] Could not find certificate-folder '/root/.acme.sh/xxxxxxx.eu/_ecc/'
[error] Could not get Let's Encrypt certificate for xxxxxxx.eu:

[error] Could not find certificate-folder '/root/.acme.sh/xxxxxxx.eu/_ecc/'
[error] Could not get Let's Encrypt certificate for xxxxxxx.eu:

[error] Could not find certificate-folder '/root/.acme.sh/xxxxxxx.eu/_ecc/'
[error] Could not get Let's Encrypt certificate for xxxxxxx.eu:

[error] Could not find certificate-folder '/root/.acme.sh/sayanee.eu/_ecc/'
[error] Could not get Let's Encrypt certificate for sayanee.eu:

[error] Could not find certificate-folder '/root/.acme.sh/music.xxxxxxx.eu/_ecc/'
[error] Could not get Let's Encrypt certificate for music.xxxxxxx.eu:

[error] Could not find certificate-folder '/root/.acme.sh/webmail.xxxxxxx.eu/_ecc/'
[error] Could not get Let's Encrypt certificate for webmail.xxxxxxx.eu:

[error] Could not find certificate-folder '/root/.acme.sh/pmaaaaa.xxxxxxx.eu/_ecc/'
[error] Could not get Let's Encrypt certificate for pmaaaaa.xxxxxxx.eu:

[error] Could not find certificate-folder '/root/.acme.sh/xxxxxxxxxxxxxx.eu/_ecc/'
[error] Could not get Let's Encrypt certificate for xxxxxxxxxxxxxx.eu:

[error] Could not find certificate-folder '/root/.acme.sh/tokushu.xxxxxxx.eu/_ecc/'
[error] Could not get Let's Encrypt certificate for tokushu.xxxxxxx.eu:

[information] Let's Encrypt certificates have been updated
[information] nginx::createIpPort: creating ip/port settings for  xxxxxxx:80
[information] nginx::createIpPort: creating ip/port settings for  xxxxxxx:443
[information] nginx::createIpPort: creating ip/port settings for  xxxxxxx:80
[information] nginx::createIpPort: creating ip/port settings for  xxxxxxx:443
[information] nginx::writeConfigs: rebuilding /etc/nginx/sites-enabled/
[information] Froxlor\Cron\Http\NginxFcgi::reload: running service php7.4-fpm restart
[information] Froxlor\Cron\Http\NginxFcgi::reload: reloading Froxlor\Cron\Http\NginxFcgi
[notice] Creating passwd file
[notice] Writing 2 entries to passwd file
[notice] Succesfully wrote passwd file
[notice] Creating group file
[notice] Writing 1 entries to group file
[notice] Succesfully wrote group file
[notice] Creating shadow file
[notice] Writing 2 entries to shadow file
[notice] Succesfully wrote shadow file
[notice] Checking system's last guid
root@tokushu ~ # php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug
[information] Requesting 1 new Let's Encrypt certificates
[information] Creating certificate for xxxxxxxxxxxxxx.eu
[information] Adding common-name: xxxxxxxxxxxxxx.eu
[information] Adding SAN entry: www.xxxxxxxxxxxxxx.eu
[information] Validating DNS of xxxxxxxxxxxxxx.eu
[information] Validating DNS of www.xxxxxxxxxxxxxx.eu
[information] Checking for LetsEncrypt client upgrades before renewing certificates:
[Sun 31 May 2020 02:22:28 AM CEST] Already uptodate!
[Sun 31 May 2020 02:22:28 AM CEST] Upgrade success!
[Sun 31 May 2020 02:22:28 AM CEST] Installing cron job
32 0 * * * "/root/.acme.sh"/acme.sh --cron --home "/root/.acme.sh" > /dev/null
[Sun 31 May 2020 02:22:28 AM CEST] Lets find script dir.
[Sun 31 May 2020 02:22:28 AM CEST] _SCRIPT_='/root/.acme.sh/acme.sh'
[Sun 31 May 2020 02:22:28 AM CEST] _script='/root/.acme.sh/acme.sh'
[Sun 31 May 2020 02:22:28 AM CEST] _script_home='/root/.acme.sh'
[Sun 31 May 2020 02:22:28 AM CEST] Using config home:/root/.acme.sh
[Sun 31 May 2020 02:22:28 AM CEST] Using server: https://acme-v02.api.letsencrypt.org/directory
[Sun 31 May 2020 02:22:28 AM CEST] Running cmd: issue
[Sun 31 May 2020 02:22:28 AM CEST] _main_domain='xxxxxxxxxxxxxx.eu'
[Sun 31 May 2020 02:22:28 AM CEST] _alt_domains='www.xxxxxxxxxxxxxx.eu'
[Sun 31 May 2020 02:22:28 AM CEST] Using config home:/root/.acme.sh
[Sun 31 May 2020 02:22:28 AM CEST] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Sun 31 May 2020 02:22:28 AM CEST] DOMAIN_PATH='/root/.acme.sh/xxxxxxxxxxxxxx.eu_ecc'
[Sun 31 May 2020 02:22:28 AM CEST] Using ACME_DIRECTORY: https://acme-v02.api.letsencrypt.org/directory
[Sun 31 May 2020 02:22:28 AM CEST] _init api for server: https://acme-v02.api.letsencrypt.org/directory
[Sun 31 May 2020 02:22:28 AM CEST] GET
[Sun 31 May 2020 02:22:28 AM CEST] url='https://acme-v02.api.letsencrypt.org/directory'
[Sun 31 May 2020 02:22:28 AM CEST] timeout=
[Sun 31 May 2020 02:22:28 AM CEST] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Sun 31 May 2020 02:22:29 AM CEST] ret='0'
[Sun 31 May 2020 02:22:29 AM CEST] ACME_KEY_CHANGE='https://acme-v02.api.letsencrypt.org/acme/key-change'
[Sun 31 May 2020 02:22:29 AM CEST] ACME_NEW_AUTHZ
[Sun 31 May 2020 02:22:29 AM CEST] ACME_NEW_ORDER='https://acme-v02.api.letsencrypt.org/acme/new-order'
[Sun 31 May 2020 02:22:29 AM CEST] ACME_NEW_ACCOUNT='https://acme-v02.api.letsencrypt.org/acme/new-acct'
[Sun 31 May 2020 02:22:29 AM CEST] ACME_REVOKE_CERT='https://acme-v02.api.letsencrypt.org/acme/revoke-cert'
[Sun 31 May 2020 02:22:29 AM CEST] ACME_AGREEMENT='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf'
[Sun 31 May 2020 02:22:29 AM CEST] ACME_NEW_NONCE='https://acme-v02.api.letsencrypt.org/acme/new-nonce'
[Sun 31 May 2020 02:22:29 AM CEST] ACME_VERSION='2'
[Sun 31 May 2020 02:22:29 AM CEST] Le_NextRenewTime='1595981974'
[Sun 31 May 2020 02:22:29 AM CEST] _saved_domain='xxxxxxxxxxxxxx.eu'
[Sun 31 May 2020 02:22:29 AM CEST] _saved_alt='www.xxxxxxxxxxxxxx.eu'
[debug] https://github.com/acmesh-official/acme.sh
v2.8.6
[Sun 31 May 2020 02:22:29 AM CEST] Domains not changed.
[Sun 31 May 2020 02:22:29 AM CEST] Skip, Next renewal time is: Thu 30 Jul 2020 12:19:34 AM UTC
[Sun 31 May 2020 02:22:29 AM CEST] Add '--force' to force to renew.
[error] Could not find certificate-folder '/root/.acme.sh/xxxxxxxxxxxxxx.eu/_ecc/'
[error] Could not get Let's Encrypt certificate for xxxxxxxxxxxxxx.eu:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Sun 31 May 2020 02:22:29 AM CEST] Domains not changed.
[Sun 31 May 2020 02:22:29 AM CEST] Skip, Next renewal time is: Thu 30 Jul 2020 12:19:34 AM UTC
[Sun 31 May 2020 02:22:29 AM CEST] Add '--force' to force to renew.
[information] Let's Encrypt certificates have been updated

im ordner .acme.sh sind auch alle cert's verschwunden. durch den fehler kann ich auch keine neue domain mit ssl hinzufügen.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Aktuell bleibt mir auch nichts anderes übrig, als dieses Manuelle gefrickel zu machen, solange ich im Limit bei Let's bin. Daher warte ich mal einige Tage, dann setze ich mich nochmal dran.

Share this post


Link to post
Share on other sites
  • 0
On 5/31/2020 at 2:35 AM, irisdina said:

im ordner .acme.sh sind auch alle cert's verschwunden. durch den fehler kann ich auch keine neue domain mit ssl hinzufügen.

sorry, absolut keine ahnung wie du das geschafft hast...du hast dir irgendwie auf deinem system einen status geschaffen den ich nicht mehr nachvollziehen kann.  Und was das ganze immer mit "killen deines nginx" zu tun hat könntest du auch ruhig mal mit logs und meldungen belgen. Wie soll man denn so irgendwas rausfinden? Ich kann hier nicht tagelang customized-gefrickel supporten und "raten" was es vllt sein könnte. 

und eins noch: bitte, vergiss doch mal "--letsencrypt", der task zum neuerstellen der webserver config inkludiert das doch. Es reicht also beim manuellen aufruf ein --force zu machen

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, d00p said:

sorry, absolut keine ahnung wie du das geschafft hast...du hast dir irgendwie auf deinem system einen status geschaffen den ich nicht mehr nachvollziehen kann.  Und was das ganze immer mit "killen deines nginx" zu tun hat könntest du auch ruhig mal mit logs und meldungen belgen. Wie soll man denn so irgendwas rausfinden? Ich kann hier nicht tagelang customized-gefrickel supporten und "raten" was es vllt sein könnte. 

und eins noch: bitte, vergiss doch mal "--letsencrypt", der task zum neuerstellen der webserver config inkludiert das doch. Es reicht also beim manuellen aufruf ein --force zu machen

ok, ich schreibe noch mal alles auf.

Limit Rate Fehler  

[Sat 06 Jun 2020 03:33:08 PM CEST] Create new order error. Le_OrderFinalize not found. {
  "type": "urn:ietf:params:acme:error:rateLimited",
  "detail": "Error creating new order :: too many certificates already issued for exact set of domains: imap.tokushu.xxxxxx.eu,imaps.tokushu.xxxxxx.eu,mail.tokushu.xxxxxx.eu,pop3.tokushu.xxxxxx.eu,pop3s.tokushu.xxxxxx.eu,smtp.tokushu.xxxxxx.eu,smtps.tokushu.xxxxxx.eu,ssl.smtp.tokushu.xxxxxx.eu,ssl.tokushu.xxxxxx.eu,tokushu.xxxxxx.eu: see https://letsencrypt.org/docs/rate-limits/",
  
[Sat 06 Jun 2020 03:33:06 PM CEST] Multi domain='DNS:tokushu.xxxxxx.eu,DNS:ssl.smtp.tokushu.xxxxxx.eu,DNS:smtp.tokushu.xxxxxx.eu,DNS:smtps.tokushu.xxxxxx.eu,DNS:pop3.tokushu.xxxxxx.eu,DNS:pop3s.tokushu.xxxxxx.eu,DNS:imaps.tokushu.xxxxxx.eu,DNS:imap.tokushu.xxxxxx.eu,DNS:mail.tokushu.xxxxxx.eu,DNS:ssl.tokushu.xxxxxx.eu
[Sat 06 Jun 2020 03:33:06 PM CEST] Getting domain auth token for each domain
[error] Could not find file 'tokushu.xxxxxx.eu.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu/'
[error] Could not find file 'ca.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu/'
[error] Could not find file 'fullchain.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu/'
[error] Could not get Let's Encrypt certificate for tokushu.xxxxxx.eu:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Sat 06 Jun 2020 03:33:03 PM CEST] Creating domain key
[Sat 06 Jun 2020 03:33:06 PM CEST] The domain key is here: /root/.acme.sh/tokushu.xxxxxx.eu/tokushu.xxxxxx.eu.key
[Sat 06 Jun 2020 03:33:06 PM CEST] Multi domain='DNS:tokushu.xxxxxx.eu,DNS:ssl.smtp.tokushu.xxxxxx.eu,DNS:smtp.tokushu.xxxxxx.eu,DNS:smtps.tokushu.xxxxxx.eu,DNS:pop3.tokushu.xxxxxx.eu,DNS:pop3s.tokushu.xxxxxx.eu,DNS:imaps.tokushu.xxxxxx.eu,DNS:imap.tokushu.xxxxxx.eu,DNS:mail.tokushu.xxxxxx.eu,DNS:ssl.tokushu.xxxxxx.eu'
[Sat 06 Jun 2020 03:33:06 PM CEST] Getting domain auth token for each domain
[error] Could not find file 'xxxxxx.eu.cer' in '/root/.acme.sh/xxxxxx.eu/'
[error] Could not find file 'ca.cer' in '/root/.acme.sh/xxxxxx.eu/'
[error] Could not find file 'fullchain.cer' in '/root/.acme.sh/xxxxxx.eu/'
[error] Could not get Let's Encrypt certificate for xxxxxx.eu:

[error] Could not find certificate-folder '/root/.acme.sh/webmail.xxxxxx.eu/'
[error] Could not get Let's Encrypt certificate for webmail.xxxxxx.eu:

[error] Could not find file 'xxxxxx.eu.cer' in '/root/.acme.sh/xxxxxx.eu/'
[error] Could not find file 'ca.cer' in '/root/.acme.sh/xxxxxx.eu/'
[error] Could not find file 'fullchain.cer' in '/root/.acme.sh/xxxxxx.eu/'
[error] Could not get Let's Encrypt certificate for xxxxxx.eu:

[error] Could not find file 'tokushu.xxxxxx.eu.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu/'
[error] Could not find file 'ca.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu/'
[error] Could not find file 'fullchain.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu/'
[error] Could not get Let's Encrypt certificate for tokushu.xxxxxx.eu:

nginx: [emerg] no "ssl_certificate" is defined for the "listen ... ssl" directive in /etc/nginx/sites-enabled/10_froxlor_ipandport_xxxxxxxx.443.conf:5
nginx: configuration file /etc/nginx/nginx.conf test failed

Hier heißt es halt einfach abwarten und tee trinken.

nginx meckert, deswegen.

nginx: [emerg] no "ssl_certificate" is defined for the "listen ... ssl" directive in /etc/nginx/sites-enabled/10_froxlor_ipandport_xxxxxxxx.443.conf:5
nginx: configuration file /etc/nginx/nginx.conf test failed

 

frox vohost

# 10_froxlor_ipandport_2a01.4f8.10a.1ca0.2.443.conf
# Created 06.06.2020 15:33
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

server { 
	listen    [xxxxx:443 default_server;
	# Froxlor default vhost
	server_name    tokushu.xxxxxx.eu ssl.smtp.tokushu.xxxxxx.eu smtp.tokushu.xxxxxx.eu smtps.tokushu.xxxxxx.eu pop3.tokushu.xxxxxx.eu pop3s.tokushu.xxxxxx.eu imaps.tokushu.xxxxxx.eu imap.tokushu.xxxxxx.eu mail.tokushu.xxxxxx.eu ssl.tokushu.xxxxxx.eu;
	access_log     /var/log/nginx/access.log combined;
	include /etc/nginx/acme.conf;
	root     /var/www/html/;
	index    index.php index.html index.htm;

	location / {
	}
	location ~ \.php {
		fastcgi_split_path_info ^(.+?\.php)(/.*)$;
		include /etc/nginx/fastcgi_params;
		fastcgi_param SCRIPT_FILENAME $request_filename;
		fastcgi_param PATH_INFO $fastcgi_path_info;
		try_files $fastcgi_script_name =404;
		fastcgi_param HTTPS on;
		fastcgi_pass unix:/var/run/1-froxlor.panel-tokushu.xxxxxx.eu-php-fpm.socket;
		fastcgi_index index.php;
	}
}

im vhost fehlt die komplette ssl teil, kA ob es jetzt daran liegt, weil die dateien gar nicht auf dem server existieren.

 

Und passiert ist das ganze, nachdem ich git update gemacht hatte und eine weitere sub-domain in frox eingefügt hatte inkl. außerhalb des standart verz. ich tippe, das bei der sub-domains in den dns settings irgendwas schief gegangen ist, weil sonst würde ich nicht ins limit von let's kommen. da muss ich aber warten was jetzt genau DD24 sagt.

 

*Edit*

habe gerade mal eine normal domain in frox wieder aktiviert und mir den vhost angesehen.

da erstellt er den ssl teil auch nicht.

# 35_froxlor_ssl_vhost_xxxxxx.eu.conf
# Created 06.06.2020 15:33
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

server {
	listen xxxxxx:443 ssl http2;
	listen xxxxxx:443 ssl http2;
	server_name xxxxxx.eu www.xxxxxx.eu;
	include /etc/nginx/acme.conf;
	access_log /var/customers/logs/miyu-xxxxxx.eu-access.log combined;
	error_log /var/customers/logs/miyu-xxxxxx.eu-error.log error;
	root /var/customers/webs/miyu/xxxxxx.eu/;
	location / {
		index index.php index.html index.htm;
		try_files $uri $uri/ @rewrites;
	}

	location @rewrites {
		rewrite ^ /index.php last;
	}

	location /wp-admin/ {
		auth_basic "admin";
		auth_basic_user_file /etc/nginx/froxlor-htpasswd/3-dd21b0986498e35eed24fc226a97dc1c.htpasswd;
		index index.php index.html index.htm;
		location ~ ^(.+?\.php)(/.*)?$ {
			try_files /524a059727b9e290aa349e62c68c172f.htm @php;
		}

	}

	location ~ ^(.+?\.php)(/.*)?$ {
		try_files /524a059727b9e290aa349e62c68c172f.htm @php;
	}

	location @php {
		try_files $1 =404;

		include /etc/nginx/fastcgi_params;
		fastcgi_split_path_info ^(.+?\.php)(/.*)$;
		fastcgi_param SCRIPT_FILENAME $request_filename;
		fastcgi_param PATH_INFO $2;
		fastcgi_param HTTPS on;
		fastcgi_pass unix:/var/run/1-miyu-xxxxxx.eu-php-fpm.socket;
		fastcgi_index index.php;
	}


}

 

Edited by irisdina
Nginx

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, irisdina said:

Hier heißt es halt einfach abwarten und tee trinken.

Nein eben nicht, du bist nicht wegen zu vielen fehlerhaften  Anfragen gesperrt, sondern weil es für die Liste der Domains schon zu viele Domains gibt, lies dazu doch einfach die Beschreibung oder google den Fehler.

10 minutes ago, irisdina said:

nginx meckert, deswegen.


nginx: [emerg] no "ssl_certificate" is defined for the "listen ... ssl" directive in /etc/nginx/sites-enabled/10_froxlor_ipandport_xxxxxxxx.443.conf:5
nginx: configuration file /etc/nginx/nginx.conf test failed

Joa, er kann kein domain spezifisches zertifikat erstellen und du hast keinen fallback in den Einstellungen angegeben

11 minutes ago, irisdina said:

im vhost fehlt die komplette ssl teil, kA ob es jetzt daran liegt, weil die dateien gar nicht auf dem server existieren.

Korrekt, froxlor erstellt das gar nicht ohne das es die Dateien gibt, macht ja auch keinen sinn

 

Share this post


Link to post
Share on other sites
  • 0
12 minutes ago, d00p said:

Nein eben nicht, du bist nicht wegen zu vielen fehlerhaften  Anfragen gesperrt, sondern weil es für die Liste der Domains schon zu viele Domains gibt, lies dazu doch einfach die Beschreibung oder google den Fehler.

Joa, er kann kein domain spezifisches zertifikat erstellen und du hast keinen fallback in den Einstellungen angegeben

Korrekt, froxlor erstellt das gar nicht ohne das es die Dateien gibt, macht ja auch keinen sinn

 

LE sagt ja bei Limit Rate

Quote

Sie können maximal 10 Konten pro IP-Adresse pro 3 Stunden erstellen. Sie können maximal 500 Konten pro IP-Bereich mit einem IPv6 /48 pro 3 Stunden erstellen. Es ist sehr selten, dass man in dieses Kontenlimit läuft und wir empfehlen, dass grosse Integratoren ein Design von ein Konto für viele Kunden verwenden.

Sie können ein Maximum von 300 Ausstehende Autorisierungen pro Konto haben. Das Erreichen dieses Rate Limits ist selten und entsteht meistens bei der Entwicklung von ACME Clients. Es bedeutet üblicherweise, dass Ihr Client Autorisierungsanfragen stellt, diese aber nicht richtig verarbeiten kann. Bitte benutzen Sie unsere Staging Umgebung, wenn Sie neue ACME Clients entwickeln.

Benutzer der ACME v2 API können ein Maximum von 300 Neue Aufträge pro Konto pro 3 Stunden erstellen.

Also nehme ich jetzt an, das es am IP Bereich liegt, aber dagegen kann ich ja selbst nicht tun, sondern, da müsste jetzt hetzner was machen. daher bleibt mir nichts anderes übrig, als einige tage zu warten.
Und 300 Anfragen kann ich ja selbst gar nicht, erstellen. ich benutze ja nicht mal den cron für frox, das er alle 5min die anfragen an LE sendet.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...